aboutsummaryrefslogtreecommitdiff
path: root/games/freeciv
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-02-08 23:31:37 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-02-08 23:31:37 +0000
commitd0f45ab36dc42e65663711d05f5a539e7a53d3a2 (patch)
tree435634554de178294c0b247a4736e4609a486972 /games/freeciv
parentbe7220047eed7e3b61fb6e5bde519b39306beffb (diff)
downloadports-d0f45ab36dc42e65663711d05f5a539e7a53d3a2.tar.gz
ports-d0f45ab36dc42e65663711d05f5a539e7a53d3a2.zip
Notes
Diffstat (limited to 'games/freeciv')
-rw-r--r--games/freeciv/Makefile52
-rw-r--r--games/freeciv/distinfo4
-rw-r--r--games/freeciv/pkg-plist8
3 files changed, 29 insertions, 35 deletions
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index c116078a7746..4b675a064856 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= freeciv
-PORTVERSION= 2.4.1
+PORTVERSION= 2.4.2
CATEGORIES= games
MASTER_SITES= SF/freeciv/Freeciv%20${PORTVERSION:R}/${PORTVERSION}
@@ -24,8 +24,15 @@ CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} --program-transform-name= \
--enable-aimodules --enable-shared \
--enable-fcdb=sqlite3
-OPTIONS_DEFINE?= X11 SDL MYSQL IPV6
-OPTIONS_DEFAULT?= X11 IPV6
+OPTIONS_DEFINE?= NLS X11 SDL MYSQL IPV6
+OPTIONS_DEFAULT?= NLS X11 IPV6
+OPTIONS_SUB= yes
+SDL_CONFIGURE_ON= --enable-client=gtk,sdl
+SDL_USE= SDL=sdl,image,ttf
+MYSQL_CONFIGURE_ON= --enable-fcdb=mysql --with-mysql-prefix=${LOCALBASE}
+MYSQL_USE= MYSQL=yes
+IPV6_CONFIGURE_EANBALE= ipv6
+NLS_USES= gettext
.include <bsd.port.options.mk>
@@ -41,51 +48,30 @@ LIB_DEPENDS+= libtiff.so:${PORTSDIR}/graphics/tiff \
libggzcore.so:${PORTSDIR}/games/ggz-client-libs \
libggzmod.so:${PORTSDIR}/games/ggz-client-libs
USE_XORG= xpm
-USE_SDL= mixer
+USE_SDL+= mixer
USE_GNOME= gtk20
INSTALLS_ICONS= yes
+. if ! ${PORT_OPTIONS:MSDL}
CONFIGURE_ARGS+=--enable-client=gtk
+. endif
CONFLICTS= freeciv-nox11-[0-9]*
-PLIST_SUB+= X11="" GTK=""
+PLIST_SUB+= GTK=""
.else
CONFIGURE_ARGS+=--enable-client=no
CONFLICTS= freeciv-[0-9]*
-PLIST_SUB+= X11="@comment " GTK="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSDL}
-CONFIGURE_ARGS+=--enable-client=gtk,sdl
-USE_SDL= sdl image ttf
-PLIST_SUB+= SDL=""
-.else
-PLIST_SUB+= SDL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-CONFIGURE_ARGS+=--enable-fcdb=mysql --with-mysql-prefix=${LOCALBASE}
-USE_MYSQL= yes
-.endif
-
-.if empty(PORT_OPTIONS:MIPV6)
-CONFIGURE_ARGS+=--disable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+PLIST_SUB+= GTK="@comment "
.endif
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in|${XARGS} ${REINPLACE_CMD} -e \
'/pkgdatadir/s|[(]datadir)/@PACKAGE@|(prefix)/${DATADIR_REL}|'
+ @${REINPLACE_CMD} 's/minor=99/minor=0/' ${WRKSRC}/configure
-.if ${PORT_OPTIONS:MX11}
post-install:
- @${INSTALL_DATA} ${WRKSRC}/data/civclient.dsc ${STAGEDIR}/${DATADIR}/
+.if ${PORT_OPTIONS:MX11}
+ @${INSTALL_DATA} ${WRKSRC}/data/civclient.dsc ${STAGEDIR}${DATADIR}/
@cd ${STAGEDIR}/${PREFIX}/bin && ${LN} -s freeciv-gtk2 freeciv-client
.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfreeciv*.so
.include <bsd.port.mk>
diff --git a/games/freeciv/distinfo b/games/freeciv/distinfo
index a452384abef0..62e1c907bd45 100644
--- a/games/freeciv/distinfo
+++ b/games/freeciv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freeciv-2.4.1.tar.bz2) = e8074e4c14b69fc23d6956084524a5f42dbbe4620196ffa8b612135af35bef80
-SIZE (freeciv-2.4.1.tar.bz2) = 38186597
+SHA256 (freeciv-2.4.2.tar.bz2) = 025d3cf51237a0c12422a5f100460a22ce1236b650a1e73cbd1c13c0b0676ce0
+SIZE (freeciv-2.4.2.tar.bz2) = 38545497
diff --git a/games/freeciv/pkg-plist b/games/freeciv/pkg-plist
index 0bf742eb86fa..5bc23508d5ed 100644
--- a/games/freeciv/pkg-plist
+++ b/games/freeciv/pkg-plist
@@ -22,8 +22,13 @@ man/man6/freeciv-qt.6.gz
man/man6/freeciv-sdl.6.gz
man/man6/freeciv-server.6.gz
man/man6/freeciv-xaw.6.gz
+%%GTK%%share/appdata/freeciv-gtk2.appdata.xml
+%%SDL%%share/appdata/freeciv-sdl.appdata.xml
+share/appdata/freeciv-modpack.appdata.xml
+share/appdata/freeciv-server.appdata.xml
share/applications/freeciv-server.desktop
%%X11%%share/applications/freeciv-modpack.desktop
+%%SDL%%share/applications/freeciv-sdl.desktop
%%X11%%share/applications/freeciv.desktop
%%PORTDOCS%%%%DOCSDIR%%/ABOUT-NLS
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -178,6 +183,7 @@ share/applications/freeciv-server.desktop
%%DATADIR%%/experimental/effects.ruleset
%%DATADIR%%/experimental/game.ruleset
%%DATADIR%%/experimental/governments.ruleset
+%%DATADIR%%/experimental/nations.ruleset
%%DATADIR%%/experimental/script.lua
%%DATADIR%%/experimental/techs.ruleset
%%DATADIR%%/experimental/terrain.ruleset
@@ -2468,6 +2474,7 @@ share/applications/freeciv-server.desktop
%%DATADIR%%/multiplayer/effects.ruleset
%%DATADIR%%/multiplayer/game.ruleset
%%DATADIR%%/multiplayer/governments.ruleset
+%%DATADIR%%/multiplayer/nations.ruleset
%%DATADIR%%/multiplayer/script.lua
%%DATADIR%%/multiplayer/techs.ruleset
%%DATADIR%%/multiplayer/terrain.ruleset
@@ -3334,6 +3341,7 @@ share/icons/hicolor/64x64/apps/freeciv-server.png
%%X11%%@dirrm %%DATADIR%%/trident
%%X11%%@dirrm %%DATADIR%%/wonders
@dirrmtry %%DATADIR%%
+@dirrmtry share/appdata
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/48x48/apps