aboutsummaryrefslogtreecommitdiff
path: root/games/freedoko
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-20 12:17:32 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-20 12:17:32 +0000
commite5e23610fe820eaa68782f084862efed3a7aee8f (patch)
tree0908e774fecaebe45200a917f9288d0a02979585 /games/freedoko
parent1231964f981e5ede95b7d8f4dc05a529cef2ce3a (diff)
Notes
Diffstat (limited to 'games/freedoko')
-rw-r--r--games/freedoko/Makefile1
-rw-r--r--games/freedoko/files/patch-Makefile10
2 files changed, 11 insertions, 0 deletions
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index f57d4fd7ab3b..3999cef6940d 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -18,6 +18,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
USES= compiler:c++14-lang gmake pkgconfig zip:infozip
USE_CXXSTD= c++14
USE_GNOME= gtkmm30
+LLD_UNSAFE= yes
MAKE_ENV= OS="${OPSYS}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
OPTIONS_DEFINE= DOCS NETWORK OPENAL
diff --git a/games/freedoko/files/patch-Makefile b/games/freedoko/files/patch-Makefile
new file mode 100644
index 000000000000..0506c2e82707
--- /dev/null
+++ b/games/freedoko/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2018-07-20 12:04:04 UTC
++++ Makefile
+@@ -252,6 +252,7 @@ $(PROGRAM) : show_settings objects $(DIRECTORIES)
+ $(INCLUDE_ALL) \
+ $(LIBS_ALL) \
+ $(CXXFLAGS) \
++ $(LDFLAGS) \
+ -o $@
+ @echo "$(PROGRAM) compiled successfully"
+