aboutsummaryrefslogtreecommitdiff
path: root/games/freedoko
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-08-01 14:55:06 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-08-01 14:55:06 +0000
commit3ab7cf9031cc137a04e1d5952da940abd36ede3a (patch)
tree736156e38c444af9e763d07b9e270313c5491b5c /games/freedoko
parent8e715deb0c0fee1a5998efeb6979d41cb49b1be7 (diff)
downloadports-3ab7cf9031cc137a04e1d5952da940abd36ede3a.tar.gz
ports-3ab7cf9031cc137a04e1d5952da940abd36ede3a.zip
Notes
Diffstat (limited to 'games/freedoko')
-rw-r--r--games/freedoko/Makefile49
-rw-r--r--games/freedoko/files/patch-Makefile.local5
-rw-r--r--games/freedoko/pkg-plist408
3 files changed, 235 insertions, 227 deletions
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index 601a21128923..98f57f78a855 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freedoko
PORTVERSION= 0.6.9
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= free-doko
@@ -16,32 +16,45 @@ DISTNAME= FreeDoko_${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Play the card game Doppelkopf
-LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
-USE_ZIP= yes
WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
+
+USE_ZIP= yes
+USE_GCC= 3.4+
USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ENV= OSTYPE=linux-gnu DATADIR=${DATADIR}
-CPIOFLAGS= --quiet -pdum -R ${SHAREOWN}:${SHAREGRP}
-DATASUBDIRS= ai backgrounds cardsets rules translations
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
+post-patch:
+ @${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\.\./data|$$(DATADIR)|g ; \
+ s|gtkmm-2.0|gtkmm-2.4|g ; \
+ s|@echo $$(CXX)|@true $(CXX)|g ; \
+ s|@$$(CXX)|$$(CXX)|g ; \
+ s|make -C|$$(MAKE) -C|g'
+ @${REINPLACE_CMD} -e \
+ 's|SigC::slot|sigc::ptr_fun|g' ${WRKSRC}/ui/gtkmm/utils.cpp
+ @${FIND} ${WRKSRC}/ui/gtkmm -name "*.cpp" -or -name "*.h" | \
+ ${XARGS} ${REINPLACE_CMD} -e \
+ 's|SigC::Object|sigc::trackable|g ; \
+ s|SigC::slot|sigc::mem_fun|g ; \
+ s|SigC::Connection|sigc::connection|g ; \
+ s|SigC::Slot|sigc::slot|g ; \
+ s|SigC|sigc|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/FreeDoko ${PREFIX}/bin
- ${LN} ${PREFIX}/bin/FreeDoko ${PREFIX}/bin/freedoko
+ ${LN} -sf FreeDoko ${PREFIX}/bin/freedoko
@${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/../data && \
- ${FIND} ${DATASUBDIRS} ! -name Makefile\* \
- | ${CPIO} ${CPIOFLAGS} ${DATADIR}
+.for dir in ai backgrounds cardsets rules translations
+ @cd ${WRKSRC}/../data && ${FIND} ${dir} ! -name "*Makefile*" | \
+ ${CPIO} --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/../doc && \
- ${FIND} . ! -name Makefile\* | ${CPIO} ${CPIOFLAGS} ${DOCSDIR}
+ @cd ${WRKSRC}/../doc && ${FIND} . ! -name "*Makefile*" | \
+ ${CPIO} --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/freedoko/files/patch-Makefile.local b/games/freedoko/files/patch-Makefile.local
deleted file mode 100644
index 9f381f759dcc..000000000000
--- a/games/freedoko/files/patch-Makefile.local
+++ /dev/null
@@ -1,5 +0,0 @@
---- /home/tg/.BACKUP/!home!tg!work!FreeBSD!ports!local!freedoko!work!FreeDoko_0.6.4!src!Makefile.local~ Tue Jun 1 13:46:45 2004
-+++ Makefile.local Fri Jun 4 18:09:39 2004
-@@ -1 +1 @@
--override CPPFLAGS += -DPUBLIC_DATA_DIRECTORY_VALUE="\"../data\""
-+override CPPFLAGS += -DPUBLIC_DATA_DIRECTORY_VALUE="\"$(DATADIR)\""
diff --git a/games/freedoko/pkg-plist b/games/freedoko/pkg-plist
index 5ef30990418b..ad6cca7867ec 100644
--- a/games/freedoko/pkg-plist
+++ b/games/freedoko/pkg-plist
@@ -1,5 +1,194 @@
-bin/freedoko
bin/FreeDoko
+bin/freedoko
+%%PORTDOCS%%%%DOCSDIR%%/Bugs
+%%PORTDOCS%%%%DOCSDIR%%/GPL
+%%PORTDOCS%%%%DOCSDIR%%/Implementation/HIG.txt
+%%PORTDOCS%%%%DOCSDIR%%/Implementation/Schweine.txt
+%%PORTDOCS%%%%DOCSDIR%%/Implementation/Zugriff.html
+%%PORTDOCS%%%%DOCSDIR%%/Roadmap
+%%PORTDOCS%%%%DOCSDIR%%/de/DDV_Kurzregeln.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/DDV_Turnierregeln.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Dateien.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Dateien.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/Einfuehrung.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Einfuehrung.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/FAQ.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/Fehler.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Fehler.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/GPL.de
+%%PORTDOCS%%%%DOCSDIR%%/de/Konfiguration.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Konfiguration.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/Kurzregeln.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Kurzregeln.tex
+%%PORTDOCS%%%%DOCSDIR%%/de/Kurzregeln.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.SuSE
+%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.Windows
+%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.gtkmm_2.4
+%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.html
+%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/MinGW32.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/Planung.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Planung.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/Regeln.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/Regeln.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/FAQ.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/README.Windows
+%%PORTDOCS%%%%DOCSDIR%%/en/README.html
+%%PORTDOCS%%%%DOCSDIR%%/en/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/configuration.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/configuration.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/introduction.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/introduction.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/rules.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/rules.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/shortrules.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/shortrules.tex
+%%PORTDOCS%%%%DOCSDIR%%/en/shortrules.txt
+%%PORTDOCS%%%%DOCSDIR%%/hpux.required_libs.txt
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/credits.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/files.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/_template.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/ai_config.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/bug_report.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/game_finished.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/game_review.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/keys.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/last_trick.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/menu.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/party_finished.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/party_points.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/party_settings.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/about.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/bug_report.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/cardset_license.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/changelog.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/current_trick.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/current_trick.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/full_trick.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/generate_error.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/last_trick.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/license.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.game.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.game.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.start.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/party_points.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/party_settings.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/player_config.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/reservation.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/reservation.solo.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/splash.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/contra.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/five_nines.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/fox_highest_trump.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/genscher.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.diamond.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.spade.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.color.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.foreign.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.spade.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.trump.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_0.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_0_reply.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_120.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_120_reply.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_30.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_30_reply.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_60.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_60_reply.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_90.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_90_reply.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.0.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.1.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.2.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.3.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/re.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/six_kings.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.diamond.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.jack.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.king-jack.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.king-queen.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.king.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.koehler.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.meatless.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.queen-jack.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.queen.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.spade.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.diamond.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.spade.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.diamond.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.spade.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/player_config.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/problems.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/reservation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/rules_config.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/settings.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/start.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/symbols.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/rules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/shortrules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/shortrules.ps
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/todo.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/credits.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/operation/ai_config.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/operation/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/rules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/shortrules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/toc.short.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/manual.css
+%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/FreeDoko.ico
+%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/FreeDoko.icon.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/flags/de.gif
+%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/flags/gb.gif
%%DATADIR%%/ai/normal
%%DATADIR%%/ai/normal.pro
%%DATADIR%%/ai/novice
@@ -116,209 +305,6 @@ bin/FreeDoko
%%DATADIR%%/translations/en/text.rules
%%DATADIR%%/translations/en/text.settings
%%DATADIR%%/translations/en/text.versions
-%%DOCSDIR%%/Bugs
-%%DOCSDIR%%/GPL
-%%DOCSDIR%%/Implementation/HIG.txt
-%%DOCSDIR%%/Implementation/Schweine.txt
-%%DOCSDIR%%/Implementation/Zugriff.html
-%%DOCSDIR%%/Roadmap
-%%DOCSDIR%%/de/DDV_Kurzregeln.pdf
-%%DOCSDIR%%/de/DDV_Turnierregeln.pdf
-%%DOCSDIR%%/de/Dateien.pdf
-%%DOCSDIR%%/de/Dateien.txt
-%%DOCSDIR%%/de/Einfuehrung.pdf
-%%DOCSDIR%%/de/Einfuehrung.txt
-%%DOCSDIR%%/de/FAQ.pdf
-%%DOCSDIR%%/de/FAQ.txt
-%%DOCSDIR%%/de/Fehler.pdf
-%%DOCSDIR%%/de/Fehler.txt
-%%DOCSDIR%%/de/GPL.de
-%%DOCSDIR%%/de/Konfiguration.pdf
-%%DOCSDIR%%/de/Konfiguration.txt
-%%DOCSDIR%%/de/Kurzregeln.pdf
-%%DOCSDIR%%/de/Kurzregeln.tex
-%%DOCSDIR%%/de/Kurzregeln.txt
-%%DOCSDIR%%/de/LIESMICH.SuSE
-%%DOCSDIR%%/de/LIESMICH.Windows
-%%DOCSDIR%%/de/LIESMICH.gtkmm_2.4
-%%DOCSDIR%%/de/LIESMICH.html
-%%DOCSDIR%%/de/LIESMICH.txt
-%%DOCSDIR%%/de/MinGW32.txt
-%%DOCSDIR%%/de/Planung.pdf
-%%DOCSDIR%%/de/Planung.txt
-%%DOCSDIR%%/de/Regeln.pdf
-%%DOCSDIR%%/de/Regeln.txt
-%%DOCSDIR%%/en/FAQ.pdf
-%%DOCSDIR%%/en/FAQ.txt
-%%DOCSDIR%%/en/README.Windows
-%%DOCSDIR%%/en/README.html
-%%DOCSDIR%%/en/README.txt
-%%DOCSDIR%%/en/configuration.pdf
-%%DOCSDIR%%/en/configuration.txt
-%%DOCSDIR%%/en/introduction.pdf
-%%DOCSDIR%%/en/introduction.txt
-%%DOCSDIR%%/en/rules.pdf
-%%DOCSDIR%%/en/rules.txt
-%%DOCSDIR%%/en/shortrules.pdf
-%%DOCSDIR%%/en/shortrules.tex
-%%DOCSDIR%%/en/shortrules.txt
-%%DOCSDIR%%/hpux.required_libs.txt
-%%DOCSDIR%%/manual/de/bugs.html
-%%DOCSDIR%%/manual/de/configuration.html
-%%DOCSDIR%%/manual/de/credits.html
-%%DOCSDIR%%/manual/de/faq.html
-%%DOCSDIR%%/manual/de/files.html
-%%DOCSDIR%%/manual/de/index.html
-%%DOCSDIR%%/manual/de/introduction.html
-%%DOCSDIR%%/manual/de/operation/_template.html
-%%DOCSDIR%%/manual/de/operation/ai_config.html
-%%DOCSDIR%%/manual/de/operation/bug_report.html
-%%DOCSDIR%%/manual/de/operation/game_finished.html
-%%DOCSDIR%%/manual/de/operation/game_review.html
-%%DOCSDIR%%/manual/de/operation/index.html
-%%DOCSDIR%%/manual/de/operation/interface.html
-%%DOCSDIR%%/manual/de/operation/keys.html
-%%DOCSDIR%%/manual/de/operation/last_trick.html
-%%DOCSDIR%%/manual/de/operation/menu.html
-%%DOCSDIR%%/manual/de/operation/overview.html
-%%DOCSDIR%%/manual/de/operation/party_finished.html
-%%DOCSDIR%%/manual/de/operation/party_points.html
-%%DOCSDIR%%/manual/de/operation/party_settings.html
-%%DOCSDIR%%/manual/de/operation/pictures/about.png
-%%DOCSDIR%%/manual/de/operation/pictures/bug_report.png
-%%DOCSDIR%%/manual/de/operation/pictures/cardset_license.png
-%%DOCSDIR%%/manual/de/operation/pictures/changelog.png
-%%DOCSDIR%%/manual/de/operation/pictures/current_trick.png
-%%DOCSDIR%%/manual/de/operation/pictures/current_trick.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/full_trick.png
-%%DOCSDIR%%/manual/de/operation/pictures/generate_error.png
-%%DOCSDIR%%/manual/de/operation/pictures/last_trick.png
-%%DOCSDIR%%/manual/de/operation/pictures/license.png
-%%DOCSDIR%%/manual/de/operation/pictures/main_window.game.png
-%%DOCSDIR%%/manual/de/operation/pictures/main_window.game.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/main_window.start.png
-%%DOCSDIR%%/manual/de/operation/pictures/party_points.png
-%%DOCSDIR%%/manual/de/operation/pictures/party_settings.png
-%%DOCSDIR%%/manual/de/operation/pictures/player_config.png
-%%DOCSDIR%%/manual/de/operation/pictures/reservation.png
-%%DOCSDIR%%/manual/de/operation/pictures/reservation.solo.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.png
-%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.small.png
-%%DOCSDIR%%/manual/de/operation/pictures/splash.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/contra.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/five_nines.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/fox_highest_trump.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/genscher.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.club.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.diamond.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.heart.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.spade.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.club.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.color.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.foreign.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.heart.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.spade.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.trump.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_0.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_0_reply.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_120.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_120_reply.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_30.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_30_reply.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_60.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_60_reply.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_90.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/no_90_reply.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.0.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.1.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.2.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.3.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/poverty.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/re.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/six_kings.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.club.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.diamond.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.heart.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.jack.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.king-jack.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.king-queen.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.king.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.koehler.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.meatless.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.queen-jack.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.queen.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/solo.spade.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.club.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.diamond.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.heart.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.spade.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.club.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.diamond.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.heart.png
-%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.spade.png
-%%DOCSDIR%%/manual/de/operation/player_config.html
-%%DOCSDIR%%/manual/de/operation/problems.html
-%%DOCSDIR%%/manual/de/operation/reservation.html
-%%DOCSDIR%%/manual/de/operation/rules_config.html
-%%DOCSDIR%%/manual/de/operation/settings.html
-%%DOCSDIR%%/manual/de/operation/start.html
-%%DOCSDIR%%/manual/de/operation/symbols.html
-%%DOCSDIR%%/manual/de/operation/toc.html
-%%DOCSDIR%%/manual/de/overview.html
-%%DOCSDIR%%/manual/de/rules.html
-%%DOCSDIR%%/manual/de/shortrules.html
-%%DOCSDIR%%/manual/de/shortrules.ps
-%%DOCSDIR%%/manual/de/toc.html
-%%DOCSDIR%%/manual/de/todo.html
-%%DOCSDIR%%/manual/en/configuration.html
-%%DOCSDIR%%/manual/en/credits.html
-%%DOCSDIR%%/manual/en/faq.html
-%%DOCSDIR%%/manual/en/index.html
-%%DOCSDIR%%/manual/en/introduction.html
-%%DOCSDIR%%/manual/en/operation/ai_config.html
-%%DOCSDIR%%/manual/en/operation/overview.html
-%%DOCSDIR%%/manual/en/overview.html
-%%DOCSDIR%%/manual/en/rules.html
-%%DOCSDIR%%/manual/en/shortrules.html
-%%DOCSDIR%%/manual/en/toc.html
-%%DOCSDIR%%/manual/en/toc.short.html
-%%DOCSDIR%%/manual/index.html
-%%DOCSDIR%%/manual/manual.css
-%%DOCSDIR%%/manual/pictures/FreeDoko.ico
-%%DOCSDIR%%/manual/pictures/FreeDoko.icon.png
-%%DOCSDIR%%/manual/pictures/flags/de.gif
-%%DOCSDIR%%/manual/pictures/flags/gb.gif
-@dirrm %%DOCSDIR%%/manual/pictures/flags
-@dirrm %%DOCSDIR%%/manual/pictures
-@dirrm %%DOCSDIR%%/manual/en/operation
-@dirrm %%DOCSDIR%%/manual/en
-@dirrm %%DOCSDIR%%/manual/de/operation/pictures/symbols
-@dirrm %%DOCSDIR%%/manual/de/operation/pictures/rules
-@dirrm %%DOCSDIR%%/manual/de/operation/pictures
-@dirrm %%DOCSDIR%%/manual/de/operation
-@dirrm %%DOCSDIR%%/manual/de
-@dirrm %%DOCSDIR%%/manual
-@dirrm %%DOCSDIR%%/en
-@dirrm %%DOCSDIR%%/de
-@dirrm %%DOCSDIR%%/Implementation
-@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/translations/en
@dirrm %%DATADIR%%/translations/de
@dirrm %%DATADIR%%/translations
@@ -336,3 +322,17 @@ bin/FreeDoko
@dirrm %%DATADIR%%/backgrounds
@dirrm %%DATADIR%%/ai
@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/pictures/flags
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/pictures
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/en/operation
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/en
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/de/operation/pictures/symbols
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/de/operation/pictures/rules
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/de/operation/pictures
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/de/operation
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/de
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/en
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/de
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/Implementation
+%%PORTDOCS%%@dirrm %%DOCSDIR%%