aboutsummaryrefslogtreecommitdiff
path: root/games/freedoko
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-16 12:40:16 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-16 12:40:16 +0000
commit10776b83987062d8072e7a1659fd07f66f851ca3 (patch)
treef56329bcbef7f1653b7d36b1ffa456b059e7bcbe /games/freedoko
parent60b59c1654e02ceb1f500340306c1956f120f60c (diff)
downloadports-10776b83987062d8072e7a1659fd07f66f851ca3.tar.gz
ports-10776b83987062d8072e7a1659fd07f66f851ca3.zip
Notes
Diffstat (limited to 'games/freedoko')
-rw-r--r--games/freedoko/Makefile8
-rw-r--r--games/freedoko/distinfo4
-rw-r--r--games/freedoko/files/patch-ui-gtkmm-icongroup.cpp18
-rw-r--r--games/freedoko/files/patch-ui-help.cpp171
-rw-r--r--games/freedoko/pkg-plist25
5 files changed, 218 insertions, 8 deletions
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index 98f57f78a855..b1a5a1243527 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freedoko
-PORTVERSION= 0.6.9
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= free-doko
@@ -16,7 +15,8 @@ DISTNAME= FreeDoko_${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Play the card game Doppelkopf
-LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ gnet-2.0.0:${PORTSDIR}/net/gnet2
WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
@@ -30,7 +30,7 @@ post-patch:
@${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
's|\.\./data|$$(DATADIR)|g ; \
s|gtkmm-2.0|gtkmm-2.4|g ; \
- s|@echo $$(CXX)|@true $(CXX)|g ; \
+ s|@echo $$(CXX)|@true $$(CXX)|g ; \
s|@$$(CXX)|$$(CXX)|g ; \
s|make -C|$$(MAKE) -C|g'
@${REINPLACE_CMD} -e \
diff --git a/games/freedoko/distinfo b/games/freedoko/distinfo
index 877179f535e4..26b7d67a078d 100644
--- a/games/freedoko/distinfo
+++ b/games/freedoko/distinfo
@@ -1,2 +1,2 @@
-MD5 (FreeDoko_0.6.9.src.zip) = cf1ae3d7c8d3a759ff10e6bc9e8b1013
-SIZE (FreeDoko_0.6.9.src.zip) = 7818155
+MD5 (FreeDoko_0.7.0.src.zip) = e285266ef30c02e0f82dae79a938ade6
+SIZE (FreeDoko_0.7.0.src.zip) = 7668449
diff --git a/games/freedoko/files/patch-ui-gtkmm-icongroup.cpp b/games/freedoko/files/patch-ui-gtkmm-icongroup.cpp
new file mode 100644
index 000000000000..a39a65c776c9
--- /dev/null
+++ b/games/freedoko/files/patch-ui-gtkmm-icongroup.cpp
@@ -0,0 +1,18 @@
+--- ui/gtkmm/icongroup.cpp.orig Sun Aug 21 15:51:54 2005
++++ ui/gtkmm/icongroup.cpp Fri Sep 16 07:37:05 2005
+@@ -218,6 +218,7 @@
+ << endl;
+ }
+ #endif
++#if 0
+ if (icon.is_null()
+ && ::setting(Setting::SHOW_AI_INFORMATION_TEAMS)
+ && (game.humanno() == 1)
+@@ -228,6 +229,7 @@
+ icon->saturate_and_pixelate(copy, 5, true);
+ icon = copy;
+ } // if (icon.is_null())
++#endif
+
+ if (icon)
+ possible_icons.push_back(icon);
diff --git a/games/freedoko/files/patch-ui-help.cpp b/games/freedoko/files/patch-ui-help.cpp
new file mode 100644
index 000000000000..1c700548a732
--- /dev/null
+++ b/games/freedoko/files/patch-ui-help.cpp
@@ -0,0 +1,171 @@
+--- ui/help.cpp.orig Sun Aug 7 15:59:22 2005
++++ ui/help.cpp Wed Sep 14 18:56:54 2005
+@@ -49,7 +49,7 @@
+ **
+ **/
+ string
+- Help::manual_directory()
++ manual_directory()
+ {
+ vector<string> directory;
+
+@@ -132,7 +132,7 @@
+ return ("http://free-doko.sourceforge.net/"
+ + ::setting(Setting::HELP_DIRECTORY) + "/"
+ + ::setting(Setting::LANGUAGE) + "/");
+- } // string Help::manual_directory()
++ } // string manual_directory()
+
+ /**
+ ** -> result
+@@ -147,10 +147,10 @@
+ **
+ **/
+ string
+- Help::operation_directory()
++ operation_directory()
+ {
+ return (manual_directory() + "operation/");
+- } // string Help::operation_directory()
++ } // string operation_directory()
+
+ /**
+ ** show the help page of the given location
+@@ -165,7 +165,7 @@
+ **
+ **/
+ void
+- Help::show(string const location)
++ show(string const location)
+ {
+ #ifndef WINDOWS
+ ::system((::setting(Setting::BROWSER) + " " + location + " &").c_str());
+@@ -174,7 +174,7 @@
+ #endif
+
+ return ;
+- } // void Help::show(string const location)
++ } // void show(string const location)
+
+ /**
+ ** show the manual help page of the given location
+@@ -189,12 +189,12 @@
+ **
+ **/
+ void
+- Help::show_manual(string const page)
++ show_manual(string const page)
+ {
+ show(manual_directory() + page + ".html");
+
+ return ;
+- } // void Help::show_manual(string const page)
++ } // void show_manual(string const page)
+
+ /**
+ ** show the operation help page of the given location
+@@ -209,12 +209,12 @@
+ **
+ **/
+ void
+- Help::show_operation(string const page)
++ show_operation(string const page)
+ {
+ show(operation_directory() + page + ".html");
+
+ return ;
+- } // void Help::show_operation(string const page)
++ } // void show_operation(string const page)
+
+ /**
+ ** shows the help for 'game_status'
+@@ -231,10 +231,10 @@
+ **
+ **/
+ void
+- Help::show(GameStatus const game_status)
++ show(GameStatus const game_status)
+ {
+ return ;
+- } // void Help::show(GameStatus const game_status)
++ } // void show(GameStatus const game_status)
+
+ /**
+ ** shows the help for the rule 'type'
+@@ -251,10 +251,10 @@
+ **
+ **/
+ void
+- Help::show(Rule::TypeBool const type)
++ show(Rule::TypeBool const type)
+ {
+ return ;
+- } // void Help::show(Rule::TypeBool const type)
++ } // void show(Rule::TypeBool const type)
+
+ /**
+ ** shows the help for the rule 'type'
+@@ -271,10 +271,10 @@
+ **
+ **/
+ void
+- Help::show(Rule::TypeUnsigned const type)
++ show(Rule::TypeUnsigned const type)
+ {
+ return ;
+- } // void Help::show(Rule::TypeUnsigned const type)
++ } // void show(Rule::TypeUnsigned const type)
+
+ /**
+ ** shows the help for the setting 'type'
+@@ -291,10 +291,10 @@
+ **
+ **/
+ void
+- Help::show(Setting::TypeBool const type)
++ show(Setting::TypeBool const type)
+ {
+ return ;
+- } // void Help::show(Setting::TypeBool const type)
++ } // void show(Setting::TypeBool const type)
+
+ /**
+ ** shows the help for the setting 'type'
+@@ -311,10 +311,10 @@
+ **
+ **/
+ void
+- Help::show(Setting::TypeUnsigned const type)
++ show(Setting::TypeUnsigned const type)
+ {
+ return ;
+- } // void Help::show(Setting::TypeUnsigned const type)
++ } // void show(Setting::TypeUnsigned const type)
+
+ /**
+ ** shows the help for the setting 'type'
+@@ -331,10 +331,10 @@
+ **
+ **/
+ void
+- Help::show(Setting::TypeString const type)
++ show(Setting::TypeString const type)
+ {
+ return ;
+- } // void Help::show(Setting::TypeString const type)
++ } // void show(Setting::TypeString const type)
+
+ /**
+ ** shows the help for the setting 'type'
+@@ -351,9 +351,9 @@
+ **
+ **/
+ void
+- Help::show(Setting::TypeCardsOrder const type)
++ show(Setting::TypeCardsOrder const type)
+ {
+ return ;
+- } // void Help::show(Setting::TypeCardsOrder const type)
++ } // void show(Setting::TypeCardsOrder const type)
+
+ } // namespace Help
diff --git a/games/freedoko/pkg-plist b/games/freedoko/pkg-plist
index ad6cca7867ec..d2243b58bde6 100644
--- a/games/freedoko/pkg-plist
+++ b/games/freedoko/pkg-plist
@@ -53,6 +53,7 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/de/faq.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/files.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/installation.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/introduction.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/_template.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/ai_config.html
@@ -112,6 +113,10 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.club.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.diamond.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.king.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.king.diamond.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.king.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.king.spade.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/hyperswines.spade.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.club.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/marriage.color.png
@@ -152,6 +157,10 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.club.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.diamond.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.king.club.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.king.diamond.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.king.heart.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.king.spade.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines-hyperswines.spade.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.club.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/swines.diamond.png
@@ -225,12 +234,18 @@ bin/freedoko
%%DATADIR%%/cardsets/Altenburg/french/cards/spade/queen.png
%%DATADIR%%/cardsets/Altenburg/french/cards/spade/ten.png
%%DATADIR%%/cardsets/Altenburg/french/icons/contra.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/dollen.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/doppelkopf.png
%%DATADIR%%/cardsets/Altenburg/french/icons/five_nines.png
%%DATADIR%%/cardsets/Altenburg/french/icons/fox_highest_trump.png
%%DATADIR%%/cardsets/Altenburg/french/icons/genscher.png
%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.club.png
%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.diamond.png
%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.heart.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.king.club.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.king.diamond.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.king.heart.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.king.spade.png
%%DATADIR%%/cardsets/Altenburg/french/icons/hyperswines.spade.png
%%DATADIR%%/cardsets/Altenburg/french/icons/marriage.club.png
%%DATADIR%%/cardsets/Altenburg/french/icons/marriage.color.png
@@ -271,6 +286,10 @@ bin/freedoko
%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.club.png
%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.diamond.png
%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.heart.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.king.club.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.king.diamond.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.king.heart.png
+%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.king.spade.png
%%DATADIR%%/cardsets/Altenburg/french/icons/swines-hyperswines.spade.png
%%DATADIR%%/cardsets/Altenburg/french/icons/swines.club.png
%%DATADIR%%/cardsets/Altenburg/french/icons/swines.diamond.png
@@ -285,10 +304,11 @@ bin/freedoko
%%DATADIR%%/translations/de/text.bug_report
%%DATADIR%%/translations/de/text.cards
%%DATADIR%%/translations/de/text.chat
-%%DATADIR%%/translations/de/text.gtkmm.menu
%%DATADIR%%/translations/de/text.gui
%%DATADIR%%/translations/de/text.help
+%%DATADIR%%/translations/de/text.menu
%%DATADIR%%/translations/de/text.messages
+%%DATADIR%%/translations/de/text.network
%%DATADIR%%/translations/de/text.rules
%%DATADIR%%/translations/de/text.settings
%%DATADIR%%/translations/de/text.versions
@@ -298,10 +318,11 @@ bin/freedoko
%%DATADIR%%/translations/en/text.bug_report
%%DATADIR%%/translations/en/text.cards
%%DATADIR%%/translations/en/text.chat
-%%DATADIR%%/translations/en/text.gtkmm.menu
%%DATADIR%%/translations/en/text.gui
%%DATADIR%%/translations/en/text.help
+%%DATADIR%%/translations/en/text.menu
%%DATADIR%%/translations/en/text.messages
+%%DATADIR%%/translations/en/text.network
%%DATADIR%%/translations/en/text.rules
%%DATADIR%%/translations/en/text.settings
%%DATADIR%%/translations/en/text.versions