aboutsummaryrefslogtreecommitdiff
path: root/games/freeorion
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-11 02:07:43 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-11 02:07:43 +0000
commitfa3b88e4ec61a6a3c7153795fab06d6b04c738ce (patch)
tree95792d570d94f314af96737021202883c3bd78e0 /games/freeorion
parent3c0d4e5257d4c4fe2b41b48c7a9c2bad6cbe8d4b (diff)
downloadports-fa3b88e4ec61a6a3c7153795fab06d6b04c738ce.tar.gz
ports-fa3b88e4ec61a6a3c7153795fab06d6b04c738ce.zip
Notes
Diffstat (limited to 'games/freeorion')
-rw-r--r--games/freeorion/Makefile1
-rw-r--r--games/freeorion/files/patch-UI__TechTreeWnd.cpp21
2 files changed, 12 insertions, 10 deletions
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
index 49f2bd80a272..afcc53d92561 100644
--- a/games/freeorion/Makefile
+++ b/games/freeorion/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeorion
PORTVERSION= 0.3.1.20071206
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
diff --git a/games/freeorion/files/patch-UI__TechTreeWnd.cpp b/games/freeorion/files/patch-UI__TechTreeWnd.cpp
index 6013690e6e6d..69f9fb83e838 100644
--- a/games/freeorion/files/patch-UI__TechTreeWnd.cpp
+++ b/games/freeorion/files/patch-UI__TechTreeWnd.cpp
@@ -1,13 +1,14 @@
--- ./UI/TechTreeWnd.cpp.orig Fri Aug 10 21:45:52 2007
-+++ ./UI/TechTreeWnd.cpp Sat Sep 8 15:48:32 2007
-@@ -55,6 +55,10 @@
- const double MIN_SCALE = 0.1073741824; // = 1.0/(1.25)^10
- const double MAX_SCALE = 1.0;
++++ ./UI/TechTreeWnd.cpp Thu Jan 10 23:14:08 2008
+@@ -20,6 +20,11 @@
+ #include <boost/format.hpp>
+ #include <algorithm>
-+ const double PI = 3.141594;
++#define PI M_PI
+
-+ double PS2INCH(double x) { return PS2INCH(x); }
-+
- pointf Bezier(pointf* patch, double t)
- {
- pointf temp[6][6];
++#define POINTS_PER_INCH 72
++#define POINTS(f_inch) (ROUND((f_inch)*POINTS_PER_INCH))
++#define PS2INCH(ps) ((ps)/(double)POINTS_PER_INCH)
+
+ namespace {
+ // command-line options