aboutsummaryrefslogtreecommitdiff
path: root/games/freeorion
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2010-01-08 10:32:17 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2010-01-08 10:32:17 +0000
commitf8399feeca94c52aad8276fda31cb0f4d4d37a69 (patch)
treec7c85b0bcc993b285a528d9d455eeeee261ef466 /games/freeorion
parentebdbc782d869220b4559f278824cfe9523aa39a2 (diff)
downloadports-f8399feeca94c52aad8276fda31cb0f4d4d37a69.tar.gz
ports-f8399feeca94c52aad8276fda31cb0f4d4d37a69.zip
Notes
Diffstat (limited to 'games/freeorion')
-rw-r--r--games/freeorion/Makefile7
-rw-r--r--games/freeorion/files/patch-SConstruct29
2 files changed, 28 insertions, 8 deletions
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
index 72fdd09a0686..9b1ac73e0756 100644
--- a/games/freeorion/Makefile
+++ b/games/freeorion/Makefile
@@ -27,7 +27,7 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_SCONS= yes
SCONS_ARGS= with_builtin_sdlnet=0
-SCONS_BUILDENV= PYTHON_LIB=${PYTHON_VERSION}
+SCONS_BUILDENV= PYTHON_LIB=${PYTHON_VERSION} LINKFLAGS=${LDFLAGS}
USE_SDL= sdl net
WRKSRC= ${WRKDIR}/${PORTNAME}/FreeOrion
@@ -40,13 +40,14 @@ SCONS_ARGS+= release=yes
post-patch:
@${REINPLACE_CMD} -e 's|ND_coord_i|ND_coord|g' \
${WRKSRC}/UI/TechTreeWnd.cpp
- @${REINPLACE_CMD} -e 's|"ogre_plugins.cfg"|"${DATADIR}/ogre_plugins.cfg"|g' \
- ${WRKSRC}/client/human/chmain.cpp
@${REINPLACE_CMD} -e 's|"OISInput.cfg"|"${DATADIR}/OISInput.cfg"|g' \
${WRKSRC}/client/human/HumanClientApp.cpp
@${REINPLACE_CMD} -e 's|Plugin=Plugin_CgProgramManager|#&|g; \
s|\(PluginFolder=\)\.|\1${LOCALBASE}/lib/OGRE|g' \
${WRKSRC}/ogre_plugins.cfg
+ @${REINPLACE_CMD} -e 's|\(prefix.*\)/usr/local|\1${PREFIX}|g; \
+ s|/usr/local/lib/OGRE|${LOCALBASE}/lib/OGRE|g' \
+ ${WRKSRC}/SConstruct
post-install:
${INSTALL_DATA} ${WRKSRC}/ogre_plugins.cfg ${DATADIR}
diff --git a/games/freeorion/files/patch-SConstruct b/games/freeorion/files/patch-SConstruct
index 2635afaaa950..7a90b7d15c62 100644
--- a/games/freeorion/files/patch-SConstruct
+++ b/games/freeorion/files/patch-SConstruct
@@ -1,6 +1,25 @@
---- SConstruct.orig 2009-03-16 18:14:04.000000000 +0100
-+++ SConstruct 2009-03-16 20:03:14.000000000 +0100
-@@ -197,6 +197,15 @@
+--- SConstruct.orig 2009-05-23 05:47:29.000000000 +0200
++++ SConstruct 2010-01-08 06:47:48.000000000 +0100
+@@ -25,6 +25,8 @@
+ options.Add('CC', 'The C-Compiler used to compile C-Files')
+ options.Add('CXX', 'The C++-Compiler used to compile C++-Files')
+ options.Add('CPPDEFINES', 'C++-Compiler macros')
++options.Add('CCFLAGS', 'C compiler flags', Split(''))
++options.Add('LINKFLAGS', 'C linker flags', Split(''))
+ options.Add(BoolOption('release', 'Build for public release (random numbers are nondeterminisitc, etc.). This will force debug=0.', 0))
+ options.Add(BoolOption('debug', 'Generate debug code', 0))
+ options.Add(BoolOption('multithreaded', 'Generate multithreaded code', 1))
+@@ -119,6 +122,9 @@
+
+ options.Update(env)
+
++env['CCFLAGS'] = Split(env['CCFLAGS'])
++env['LINKFLAGS'] = Split(env['LINKFLAGS'])
++
+ if env.has_key('use_distcc') and env['use_distcc']:
+ if 'distcc' not in env['CC']:
+ env['CC'] = 'distcc %s' % env['CC']
+@@ -197,6 +204,15 @@
else:
print 'Configuring unknown system (assuming the system is POSIX-like) ...'
@@ -16,7 +35,7 @@
# Python
import distutils.sysconfig
if str(Platform()) == 'win32':
-@@ -216,6 +225,8 @@
+@@ -216,6 +232,8 @@
matches = regex.findall(distutils.sysconfig.get_config_var('LDLIBRARY'))
if len(matches):
python_libname = matches[0]
@@ -25,7 +44,7 @@
else:
print 'Unable to determine the name of the Python runtime library. Terminating....'
Exit(1)
-@@ -265,15 +276,6 @@
+@@ -268,15 +286,6 @@
BoostLibWin32Name('python', env)
])