aboutsummaryrefslogtreecommitdiff
path: root/games/freesci/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-19 12:39:27 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-19 12:39:27 +0000
commit80ef25d4275600acad2bef4d6c382e791d28aa8e (patch)
tree3e73a67858bb0eb2350f254f6b3baee609917332 /games/freesci/Makefile
parentcb8895c30e6b971e698831a9b06ce03fda613608 (diff)
downloadports-80ef25d4275600acad2bef4d6c382e791d28aa8e.tar.gz
ports-80ef25d4275600acad2bef4d6c382e791d28aa8e.zip
Notes
Diffstat (limited to 'games/freesci/Makefile')
-rw-r--r--games/freesci/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/freesci/Makefile b/games/freesci/Makefile
new file mode 100644
index 000000000000..2dfbcd6e9e6d
--- /dev/null
+++ b/games/freesci/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: freesci
+# Date created: 17 December 2000
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freesci
+PORTVERSION= 0.3.0
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.linuxgames.com/freesci/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi \
+ png.4:${PORTSDIR}/graphics/png
+
+HAS_CONFIGURE= yes
+
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+USE_GLIB= yes
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/freesci
+ @${INSTALL_DATA} ${WRKSRC}/doc/sci.sgml ${PREFIX}/share/freesci
+
+.include <bsd.port.mk>