aboutsummaryrefslogtreecommitdiff
path: root/games/freesci
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /games/freesci
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
downloadports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.tar.gz
ports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.zip
Notes
Diffstat (limited to 'games/freesci')
-rw-r--r--games/freesci/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/freesci/Makefile b/games/freesci/Makefile
index 9bef9d963364..4c5fd823c636 100644
--- a/games/freesci/Makefile
+++ b/games/freesci/Makefile
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_REINPLACE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
+WANT_SDL= yes
CONFIGURE_TARGET=
CONFIGURE_ENV= CFLAGS=${PTHREAD_CFLAGS}
@@ -28,7 +29,7 @@ MAN6= freesci-tools.6 freesci.6
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
.if exists(${LOCALBASE}/lib/libdirectfb-0.9.so.16)
@@ -43,7 +44,7 @@ CONFIGURE_ARGS+= --with-console
.endif
.if defined(WITH_SDL) && !defined(WITHOUT_SDL)
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+USE_SDL= yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-sdl