aboutsummaryrefslogtreecommitdiff
path: root/games/frikqcc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-03-17 08:43:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-03-17 08:43:09 +0000
commit6c77fcfcd6757b4d4c577c04f0e029f73bf81357 (patch)
tree61c87e1fb6e495b24c814bbc4bdaab594210a4c2 /games/frikqcc
parent3f1a6e094fc7d1b903215d8a04f73ca624c04506 (diff)
downloadports-6c77fcfcd6757b4d4c577c04f0e029f73bf81357.tar.gz
ports-6c77fcfcd6757b4d4c577c04f0e029f73bf81357.zip
Notes
Diffstat (limited to 'games/frikqcc')
-rw-r--r--games/frikqcc/Makefile29
-rw-r--r--games/frikqcc/distinfo2
-rw-r--r--games/frikqcc/files/Makefile26
-rw-r--r--games/frikqcc/pkg-descr13
4 files changed, 70 insertions, 0 deletions
diff --git a/games/frikqcc/Makefile b/games/frikqcc/Makefile
new file mode 100644
index 000000000000..22827ac2af6f
--- /dev/null
+++ b/games/frikqcc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: FrikQCC
+# Date created: 16 Mar 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frikqcc
+PORTVERSION= 2.6
+CATEGORIES= games devel
+MASTER_SITES= http://wiki.quakesrc.org/files/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME:S/qcc//}${PORTVERSION:S/.//g}src
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Advanced QuakeC compiler/decompiler
+
+USE_ZIP= yes
+
+MAKEFILE= ${FILESDIR}/Makefile
+
+PLIST_FILES= bin/frikqcc bin/frikqcdec
+
+do-install:
+.for p in ${PLIST_FILES:S/bin\///g}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${p} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/frikqcc/distinfo b/games/frikqcc/distinfo
new file mode 100644
index 000000000000..929fabe5cc21
--- /dev/null
+++ b/games/frikqcc/distinfo
@@ -0,0 +1,2 @@
+MD5 (frik26src.zip) = 8743604be2d1db778b7e97b0e8f2249c
+SIZE (frik26src.zip) = 69840
diff --git a/games/frikqcc/files/Makefile b/games/frikqcc/files/Makefile
new file mode 100644
index 000000000000..e0644ecb4b9e
--- /dev/null
+++ b/games/frikqcc/files/Makefile
@@ -0,0 +1,26 @@
+#
+# $FreeBSD$
+
+CFLAGS+= -DINLINE
+
+COBJS= compiler/cmdlib.o \
+ compiler/hash.o \
+ compiler/main.o \
+ compiler/pr_comp.o \
+ compiler/pr_lex.o \
+ compiler/qcc.o
+
+DECOBJS= decompiler/cmdlib.o \
+ decompiler/decomp.o \
+ decompiler/main.o
+
+.c.o:
+ ${CC} ${CFLAGS} -c $< -o $*.o
+
+all: c dec
+
+c: ${COBJS}
+ ${CC} ${LDFLAGS} -o frikqcc ${COBJS}
+
+dec: ${DECOBJS}
+ ${CC} ${LDFLAGS} -o frikqcdec ${DECOBJS}
diff --git a/games/frikqcc/pkg-descr b/games/frikqcc/pkg-descr
new file mode 100644
index 000000000000..f1c453279b90
--- /dev/null
+++ b/games/frikqcc/pkg-descr
@@ -0,0 +1,13 @@
+FrikQCC was started a few months before the Quake engine source was
+released. Originally based off of FastQCC, it was widely (well among
+the people at MDQNet) enjoyed for a few months. Then J. P. Grossman
+released QCCX, back in March 2000. QCCX implemented a ton of neato-
+whizbang features that I just had to have. I immediately set out to
+add some of the better stuff from FrikQCC 1.x, such as warnings and
+some of my own ideas of optimizations to his code. The result was
+FrikQCC 2.0, which has been updated many times since then. I've
+started moving away from some of the old QCCX features (for example my
+Arrays are different, as is the new int type) in an effort to make the
+code more user friendly.
+
+WWW: http://wiki.quakesrc.org/index.php?pagename=FrikQCC