aboutsummaryrefslogtreecommitdiff
path: root/games/frogatto/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-09-22 10:37:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-09-22 10:37:51 +0000
commitcb0f480dec7b325d79fc0c714f5c4d9a9a93fd95 (patch)
treed8044ae9ca99596aa222085aeb7563c95bf3d9b7 /games/frogatto/Makefile
parent50ae66069b6482716ceb6a6baee4e6ab0af256f9 (diff)
downloadports-cb0f480dec7b325d79fc0c714f5c4d9a9a93fd95.tar.gz
ports-cb0f480dec7b325d79fc0c714f5c4d9a9a93fd95.zip
Notes
Diffstat (limited to 'games/frogatto/Makefile')
-rw-r--r--games/frogatto/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 365081a49479..a25fc37bb993 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: Frogatto
+# New ports collection makefile for: Frogatto & Friends
# Date created: 14 Jul 2010
# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
#
@@ -6,8 +6,7 @@
#
PORTNAME= frogatto
-PORTVERSION= 1.0
-PORTREVISION= 2
+PORTVERSION= 1.0.3
CATEGORIES= games
MASTER_SITES= http://www.frogatto.com/files/
@@ -31,8 +30,9 @@ post-patch:
@${REINPLACE_CMD} -E -e 's,(ccache )?g\+\+,$$(CXX) $$(CXXFLAGS),' \
-e 's,-O2,, ; s,-g,, ; s,/usr/X11R6,${LOCALBASE},' \
-e 's,-mt,,g ; /server/s,`.*mixer,${PTHREAD_LIBS},' \
+ -e 's,-L/usr/lib,, ; s,-L/sw/lib,,' \
-e '/server/s,-lX11,,' ${WRKSRC}/Makefile
-# Point to the right location where look for the resources on FreeBSD
+# Point to the right location where to look for resources on FreeBSD
@${REINPLACE_CMD} -e 's,HAVE_CONFIG_H,__FreeBSD__,' \
-e 's,DATADIR,"${DATADIR}",' ${WRKSRC}/src/filesystem.cpp
@${REINPLACE_CMD} -E 's,(music|sounds)/,${DATADIR}/&,' \
@@ -43,8 +43,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/${PORTNAME}-server
cd ${WRKSRC} && ${COPYTREE_SHARE} "data images music sounds" \
${DATADIR}
-# Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700)
- ${CHMOD} 755 ${DATADIR}
+# Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700
+# if target directory (${DATADIR}) does not exist)
+ @${CHMOD} 755 ${DATADIR}
# Dynamically generate part of the PLIST for game resources (lots of them)
@${FIND} ${DATADIR} -not -type d | \
${SED} 's,^${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}