aboutsummaryrefslogtreecommitdiff
path: root/games/frogatto
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-28 21:14:43 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-28 21:14:43 +0000
commit908f7b5dfcda46ed454c37316fd62552dc8998ba (patch)
tree452af3e7e7227b810f18b4ff946ed9cf3a320630 /games/frogatto
parent250e583ec1a9a8e9c9f68379011fb5250ff89d61 (diff)
downloadports-908f7b5dfcda46ed454c37316fd62552dc8998ba.tar.gz
ports-908f7b5dfcda46ed454c37316fd62552dc8998ba.zip
Notes
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index c816fd55455e..74e07ef1b729 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= frogatto
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= fiziologus@gmail.com
@@ -20,13 +21,15 @@ GH_COMMIT= 58bd7c6
USES= gmake pkgconfig
ALL_TARGET= game server
-USE_GL= glew
-USE_SDL= image mixer ttf
+USE_GL= glew glu
+USE_SDL= sdl image mixer ttf
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
post-patch:
- @${ECHO_CMD} >> ${WRKSRC}/src/difficulty.hpp
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|-Werror||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,%lu,%u,' ${WRKSRC}/src/server.cpp
@${REINPLACE_CMD} -e 's,__linux__,__${OPSYS}__,' \
${WRKSRC}/src/clipboard.cpp