aboutsummaryrefslogtreecommitdiff
path: root/games/frogatto
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-15 17:18:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-15 17:18:18 +0000
commit8fc09c9b757593151c9310baee6c1e415ab71583 (patch)
treea8dfbddfaf47ed8d65d678c7cbe1af64c25eb623 /games/frogatto
parentdceefd37dab9ed0af45b674991b0a4ef63d82844 (diff)
downloadports-8fc09c9b757593151c9310baee6c1e415ab71583.tar.gz
ports-8fc09c9b757593151c9310baee6c1e415ab71583.zip
Notes
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile58
-rw-r--r--games/frogatto/distinfo4
-rw-r--r--games/frogatto/files/patch-Makefile47
-rw-r--r--games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg11
-rw-r--r--games/frogatto/files/patch-src-custom_object.cpp11
5 files changed, 75 insertions, 56 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 1c47d7aac7aa..c816fd55455e 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= frogatto
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.3.1
CATEGORIES= games
-MASTER_SITES= GH
MAINTAINER= fiziologus@gmail.com
COMMENT= Old-school 2D classic adventure platformer game
@@ -17,52 +15,48 @@ NO_PACKAGE= Package will be 144M, set FORCE_PACKAGE if you really want it
USE_GITHUB= yes
GH_ACCOUNT= frogatto
-GH_PROGECT= frogatto
GH_TAGNAME= ${PORTVERSION}
-GH_COMMIT= 64c84bf
+GH_COMMIT= 58bd7c6
-USES= gmake
+USES= gmake pkgconfig
ALL_TARGET= game server
USE_GL= glew
USE_SDL= image mixer ttf
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
-NO_STAGE= yes
post-patch:
-# Sanitize Makefile: honor CC/CXX and C[XX]FLAGS, trim `-mt' suffix from boost
-# libraries, remove superfluous libraries when linking server executable (add
-# missing -pthread instead), etc.
- @${REINPLACE_CMD} -E -e 's,= (ccache )?gcc,:= $$(CC) $$(CFLAGS),' \
- -e 's,= (ccache )?g\+\+,:= $$(CXX) $$(CXXFLAGS),' \
- -e 's, -O2,, ; s, -g,, ; s, -L/usr/lib,, ; s, -L/sw/lib,,' \
- -e '/server/s,`.*mixer,-L${LOCALBASE}/lib ${PTHREAD_LIBS},' \
- -e 's,-mt,,g' -e 's,-lpng,-lpng15,g' ${WRKSRC}/Makefile
+ @${ECHO_CMD} >> ${WRKSRC}/src/difficulty.hpp
+ @${REINPLACE_CMD} -e 's,%lu,%u,' ${WRKSRC}/src/server.cpp
+ @${REINPLACE_CMD} -e 's,__linux__,__${OPSYS}__,' \
+ ${WRKSRC}/src/clipboard.cpp
# Point to the right location where to look for resources on FreeBSD
@${REINPLACE_CMD} -e 's,HAVE_CONFIG_H,__FreeBSD__,' \
-e 's,DATADIR,"${DATADIR}",' ${WRKSRC}/src/filesystem.cpp
- @${REINPLACE_CMD} -E 's,(music|sounds)/,${DATADIR}/&,' \
+ @${REINPLACE_CMD} -e 's,itor->second,"${DATADIR}/" + &,' \
${WRKSRC}/src/sound.cpp
@${REINPLACE_CMD} -e '/\/locale\//s,\.,${PREFIX}/share,' \
${WRKSRC}/src/i18n.cpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/game ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/${PORTNAME}-server
- cd ${WRKSRC} && ${COPYTREE_SHARE} "data images music sounds" \
- ${DATADIR}
- cd ${WRKSRC}/locale && ${MV} hu_HU hu && ${MV} ms_MY ms
- cd ${WRKSRC} && ${COPYTREE_SHARE} "locale" ${PREFIX}/share
-# Fix permissions on DATADIR after COPYTREE_SHARE (cpio(1) defaults to 700
-# if target directory (${DATADIR}) does not exist)
- @${CHMOD} 755 ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/game ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/server \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-server
+ cd ${WRKSRC}/modules/frogatto/locale && \
+ ${MV} hu_HU hu && ${MV} ms_MY ms
+ cd ${WRKSRC}/modules/frogatto && ${COPYTREE_SHARE} \
+ locale ${STAGEDIR}${PREFIX}/share
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "data images music modules utils" \
+ ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.ttf *.cfg ${STAGEDIR}${DATADIR}
# Dynamically generate part of the PLIST for NLS files and game resources
-# (lots of them)
- @${FIND} ${PREFIX}/share/locale -name ${PORTNAME}.mo | \
- ${SED} 's,^${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
- @${FIND} ${DATADIR} -not -type d | \
- ${SED} 's,^${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' | ${SORT} -r >> ${TMPPLIST}
+# (really lots of them)
+ @${FIND} ${STAGEDIR}${PREFIX}/share/locale -name ${PORTNAME}.mo | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${DATADIR} -not -type d | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,,' | ${SORT} >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${DATADIR} -type d | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' | \
+ ${SORT} -r >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/games/frogatto/distinfo b/games/frogatto/distinfo
index ec8b4dcf5c41..5bbbb1b4cb9e 100644
--- a/games/frogatto/distinfo
+++ b/games/frogatto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (frogatto-1.2.tar.gz) = b735bda8d409612eecc79e84d218b3bd460470f8bccca3472d08c893d91d1232
-SIZE (frogatto-1.2.tar.gz) = 261545835
+SHA256 (frogatto-1.3.1.tar.gz) = 071059b99ea9b947bed42f99d885770455b72e584da8516443ef316cf187256a
+SIZE (frogatto-1.3.1.tar.gz) = 500362508
diff --git a/games/frogatto/files/patch-Makefile b/games/frogatto/files/patch-Makefile
new file mode 100644
index 000000000000..72fc79ea8a2b
--- /dev/null
+++ b/games/frogatto/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig
++++ Makefile
+@@ -22,7 +22,7 @@
+ # found in PATH), this option has no effect.
+ #
+
+-OPTIMIZE=yes
++OPTIMIZE=no
+ CCACHE?=ccache
+ USE_CCACHE?=$(shell which $(CCACHE) 2>&1 > /dev/null && echo yes)
+ ifneq ($(USE_CCACHE),yes)
+@@ -34,14 +34,14 @@ BASE_CXXFLAGS += -O2
+ endif
+
+ # Initial compiler options, used before CXXFLAGS and CPPFLAGS.
+-BASE_CXXFLAGS += -g -fno-inline-functions -fthreadsafe-statics -Wnon-virtual-dtor -Werror -Wignored-qualifiers -Wformat -Wswitch
++BASE_CXXFLAGS += -fno-inline-functions -fthreadsafe-statics -Wnon-virtual-dtor -Werror -Wformat -Wswitch
+
+ # Compiler include options, used after CXXFLAGS and CPPFLAGS.
+-INC := $(shell pkg-config --cflags x11 sdl glu glew SDL_image libpng zlib)
++INC := $(shell pkg-config --cflags x11 sdl glu glew SDL_image libpng)
+
+ # Linker library options.
+ LIBS := $(shell pkg-config --libs x11 ) -lSDLmain \
+- $(shell pkg-config --libs sdl glu glew SDL_image libpng zlib) -lSDL_ttf -lSDL_mixer
++ $(shell pkg-config --libs sdl glu glew SDL_image libpng) -lSDL_ttf -lSDL_mixer
+
+ include Makefile.common
+
+@@ -60,7 +60,7 @@ game: $(objects)
+ $(CCACHE) $(CXX) \
+ $(BASE_CXXFLAGS) $(LDFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(INC) \
+ $(objects) -o game \
+- $(LIBS) -lboost_regex-mt -lboost_system-mt -lpthread -fthreadsafe-statics
++ $(LIBS) -lboost_regex -lboost_system -lpthread -fthreadsafe-statics
+
+ # pull in dependency info for *existing* .o files
+ -include $(objects:.o=.d)
+@@ -69,7 +69,7 @@ server: $(server_objects)
+ $(CCACHE) $(CXX) \
+ $(BASE_CXXFLAGS) $(LDFLAGS) $(CXXFLAGS) $(CPPFLAGS) \
+ $(server_objects) -o server \
+- $(LIBS) -lboost_regex-mt -lboost_system-mt -lboost_thread-mt -lboost_iostreams-mt
++ $(LIBS) -lboost_regex -lboost_system -lboost_thread -lboost_iostreams
+
+ clean:
+ rm -f *.o *.d game
diff --git a/games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg b/games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg
deleted file mode 100644
index 55d5a4c7fe12..000000000000
--- a/games/frogatto/files/patch-data-objects-enemies-milgramen-milgram_pod_launcher.cfg
+++ /dev/null
@@ -1,11 +0,0 @@
---- data/objects/enemies/milgramen/milgram_pod_launcher.cfg.orig 2012-11-10 21:52:46.000000000 +0400
-+++ data/objects/enemies/milgramen/milgram_pod_launcher.cfg 2012-11-10 21:54:05.000000000 +0400
-@@ -74,7 +74,7 @@
-
- on_die="spawn('explosion_big_recurring', midpoint_x, midpoint_y, facing)"
-
-- solid_area=10,20,38,50
-+ solid_area=14,20,34,50
-
- [base:animation]
- image=enemies/milgram-pod-launcher.png
diff --git a/games/frogatto/files/patch-src-custom_object.cpp b/games/frogatto/files/patch-src-custom_object.cpp
deleted file mode 100644
index 10ab1b8e5f64..000000000000
--- a/games/frogatto/files/patch-src-custom_object.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/custom_object.cpp.orig 2011-11-30 09:31:31.000000000 +0400
-+++ src/custom_object.cpp 2012-11-10 21:39:11.000000000 +0400
-@@ -1394,7 +1394,7 @@
- set_driver_position();
-
- if(blur_) {
-- blur_->next_frame(start_x, start_y, x(), y(), frame_, time_in_frame_, face_right(), upside_down(), rotate_.value());
-+ blur_->next_frame(start_x, start_y, x(), y(), frame_, time_in_frame_, face_right(), upside_down(), rotate_.as_float());
- if(blur_->destroyed()) {
- blur_.reset();
- }