aboutsummaryrefslogtreecommitdiff
path: root/games/frogatto
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-06-19 15:43:01 +0000
committerSteve Wills <swills@FreeBSD.org>2018-06-19 15:43:01 +0000
commitc477ed1df55cbfff077c447e4c2522235961ca5f (patch)
tree038daefbc575165213d70d4dcb72f1b61f4ff2f3 /games/frogatto
parent40fc1f9225dc15e9eb0d830871fc853360ec59c9 (diff)
downloadports-c477ed1df55cbfff077c447e4c2522235961ca5f.tar.gz
ports-c477ed1df55cbfff077c447e4c2522235961ca5f.zip
Notes
Diffstat (limited to 'games/frogatto')
-rw-r--r--games/frogatto/Makefile3
-rw-r--r--games/frogatto/files/patch-src-surface_cache.cpp16
2 files changed, 10 insertions, 9 deletions
diff --git a/games/frogatto/Makefile b/games/frogatto/Makefile
index 7d50a66fb52c..7c05c6bdc69d 100644
--- a/games/frogatto/Makefile
+++ b/games/frogatto/Makefile
@@ -22,11 +22,12 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
USE_GITHUB= yes
GH_ACCOUNT= frogatto
-USES= gmake pkgconfig
+USES= gmake pkgconfig dos2unix
ALL_TARGET= game server
USE_GL= glew glu
USE_SDL= sdl image mixer ttf
USE_CXXSTD= c++11
+DOS2UNIX_FILES= src/surface_cache.cpp
PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-server
diff --git a/games/frogatto/files/patch-src-surface_cache.cpp b/games/frogatto/files/patch-src-surface_cache.cpp
index f0ecde358279..7f3d8a8781dd 100644
--- a/games/frogatto/files/patch-src-surface_cache.cpp
+++ b/games/frogatto/files/patch-src-surface_cache.cpp
@@ -1,11 +1,11 @@
--- src/surface_cache.cpp.orig 2018-06-16 13:59:29.319430000 +0300
+++ src/surface_cache.cpp 2018-06-16 14:00:09.140102000 +0300
@@ -116,7 +116,7 @@
- }
- #endif // ANDROID
- //std::cerr << "loading image '" << fname << "'\n";
-- if(surf.get() == false || surf->w == 0) {
-+ if(surf.get() == nullptr || surf->w == 0) {
- if(key != "") {
- std::cerr << "failed to load image '" << key << "'\n";
- }
+ }
+ #endif // ANDROID
+ //std::cerr << "loading image '" << fname << "'\n";
+- if(surf.get() == false || surf->w == 0) {
++ if(surf.get() == nullptr || surf->w == 0) {
+ if(key != "") {
+ std::cerr << "failed to load image '" << key << "'\n";
+ }