aboutsummaryrefslogtreecommitdiff
path: root/games/frotz/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:43:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:43:01 +0000
commit3daca20fea8da4c00f97b4e0755c2a5c0adbe61b (patch)
tree822e02b77d760f407399bf49af1adeb1919176a4 /games/frotz/Makefile
parent2cabf9c962792b3da42e0cde79292d7d75b9cacf (diff)
Notes
Diffstat (limited to 'games/frotz/Makefile')
-rw-r--r--games/frotz/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
index 076f7cd90bc9..b531ba370712 100644
--- a/games/frotz/Makefile
+++ b/games/frotz/Makefile
@@ -7,26 +7,39 @@
PORTNAME= frotz
PORTVERSION= 2.43
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ftp://ftp.ifarchive.org/if-archive/infocom/interpreters/frotz/ \
- http://wuarchive.wustl.edu/doc/misc/if-archive/infocom/interpreters/frotz/ \
+MASTER_SITES= SF \
http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/
MAINTAINER= ports@FreeBSD.org
COMMENT= Infocom games interpreter
+LICENSE= GPLv2 # (or later)
+
MAKE_ARGS= CC="${CC}" OPTS="${CFLAGS}" PREFIX="${PREFIX}" \
- CONFIG_DIR="${PREFIX}/etc" INCL="" LIB=""
+ CONFIG_DIR="${PREFIX}/etc" SOUND_DEFS="-DOSS_SOUND" \
+ SOUND_DEV="/dev/dsp" INCL="" LIB=""
+MAKE_JOBS_SAFE= yes
MAN6= frotz.6
+PORTDOCS= BUGS HOW_TO_PLAY README
+PORTEXAMPLES= frotz.conf-big frotz.conf-small
+PLIST_FILES= bin/frotz
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/doc/frotz.6 ${MANPREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/frotz.6 ${MANPREFIX}/man/man6
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in BUGS HOW_TO_PLAY README
- @${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${ex} ${EXAMPLESDIR}
.endfor
.endif