aboutsummaryrefslogtreecommitdiff
path: root/games/frotz
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-02 15:43:42 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-02 15:43:42 +0000
commitb1cb10f79f44084e975bd4fe3f5b9919795c21dc (patch)
treef04c6bb013d3386a0394ee1aa843ed9e523681a8 /games/frotz
parent7fa3bd05703d757403778754189b94b3a368dcd3 (diff)
downloadports-b1cb10f79f44084e975bd4fe3f5b9919795c21dc.tar.gz
ports-b1cb10f79f44084e975bd4fe3f5b9919795c21dc.zip
Notes
Diffstat (limited to 'games/frotz')
-rw-r--r--games/frotz/Makefile23
-rw-r--r--games/frotz/pkg-descr2
2 files changed, 11 insertions, 14 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
index dc22e38e20b9..3017e68492e7 100644
--- a/games/frotz/Makefile
+++ b/games/frotz/Makefile
@@ -32,27 +32,24 @@ DUMB_DESC= Install dfrotz (dumb frotz)
OSS_MAKE_ENV= SOUND_DEFS='-DOSS_SOUND -DSOUND_DEV=\"/dev/dsp\"'
DUMB_PLIST_FILES= bin/dfrotz \
man/man6/dfrotz.6.gz
+DUMB_PORTDOCS= DUMB
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDUMB}
-PORTDOCS+= DUMB
-.endif
-
-.if ${PORT_OPTIONS:MOSS}
-pre-build:
+pre-build-OSS-on:
cd ${WRKSRC} && ${DO_MAKE_BUILD} soundcard.h
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
-.if ${PORT_OPTIONS:MDUMB}
- ${INSTALL_PROGRAM} ${WRKSRC}/d${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/doc/d${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
-.endif
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+do-install-DUMB-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/d${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/doc/d${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/games/frotz/pkg-descr b/games/frotz/pkg-descr
index 0c24b39aa2e2..a31a0ac7e7c6 100644
--- a/games/frotz/pkg-descr
+++ b/games/frotz/pkg-descr
@@ -7,4 +7,4 @@ to transfer the story files. There is an increasing number
of new games available on the Internet. Check the if-archive
at ftp.ifarchive.org.
-WWW: https://github.com/DavidGriffith/frotz/
+WWW: https://github.com/DavidGriffith/frotz