aboutsummaryrefslogtreecommitdiff
path: root/games/frotz
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-05-18 04:10:08 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-05-18 04:10:08 +0000
commit18ecf4a8f50885dd5cbdc08307d31fa2d41ca208 (patch)
treeba06afb4047ea08c535a5d35cefbab793d2df90f /games/frotz
parent134aef9dc10ee669521481b5b940e70071ee9935 (diff)
downloadports-18ecf4a8f50885dd5cbdc08307d31fa2d41ca208.tar.gz
ports-18ecf4a8f50885dd5cbdc08307d31fa2d41ca208.zip
Notes
Diffstat (limited to 'games/frotz')
-rw-r--r--games/frotz/Makefile29
-rw-r--r--games/frotz/distinfo1
-rw-r--r--games/frotz/files/patch-aa38
-rw-r--r--games/frotz/pkg-comment1
-rw-r--r--games/frotz/pkg-descr10
-rw-r--r--games/frotz/pkg-plist4
6 files changed, 83 insertions, 0 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
new file mode 100644
index 000000000000..59f93d686e79
--- /dev/null
+++ b/games/frotz/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: frotz
+# Version required: 2.32
+# Date created: 16 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= UnixFrotz232R2Std10
+PKGNAME= frotz-2.32
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.gmd.de/if-archive/infocom/interpreters/frotz/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+ALL_TARGET=
+WRKSRC= ${WRKDIR}/frotz-2.32
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/frotz
+.for file in Readme.unix Todo
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/frotz
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/frotz/distinfo b/games/frotz/distinfo
new file mode 100644
index 000000000000..e84d0ed45219
--- /dev/null
+++ b/games/frotz/distinfo
@@ -0,0 +1 @@
+MD5 (UnixFrotz232R2Std10.tar.gz) = 5c40f4a9da46a65cd0fd09821bf93538
diff --git a/games/frotz/files/patch-aa b/games/frotz/files/patch-aa
new file mode 100644
index 000000000000..205a8fedb898
--- /dev/null
+++ b/games/frotz/files/patch-aa
@@ -0,0 +1,38 @@
+--- Makefile Fri Oct 17 20:11:10 1997
++++ /home/andy/tmp/wrk/Makefile Sat May 16 15:29:57 1998
+@@ -1,7 +1,7 @@
+
+ # Define your c compiler. I recommend gcc if you've got it.
+ #CC = cc
+-CC = gcc
++#CC = gcc
+
+ # Define your optimization flags. Most compilers understand -O and -O2,
+ # Debugging (don't use)
+@@ -43,7 +43,7 @@
+ # have that option.
+ #
+ #DEFS = -DUSE_GETOPT_H -DCOLOR_SUPPORT -DEMACS_EDITING
+-DEFS =
++DEFS = -DCOLOR_SUPPORT -DEMACS_EDITING -DUSE_NCURSES_H -DUSE_NOTHING
+
+ # This should point to the location of your curses or ncurses include file
+ # if it's in a non-standard place.
+@@ -57,7 +57,7 @@
+ #CURSES = -lncurses
+ #LIB = -L/5usr/lib
+ LIB =
+-CURSES = -lcurses
++CURSES = -lncurses
+
+ # Nothing under this line should need to be changed.
+
+@@ -66,7 +66,7 @@
+ text.o ux_init.o ux_input.o ux_pic.o ux_screen.o ux_sample.o \
+ ux_text.o variable.o
+
+-CFLAGS = $(OPTS) $(DEFS) $(INCL)
++CFLAGS+= $(DEFS)
+
+ frotz: $(OBJECTS)
+ $(CC) -o frotz $(OBJECTS) $(LIB) $(CURSES)
diff --git a/games/frotz/pkg-comment b/games/frotz/pkg-comment
new file mode 100644
index 000000000000..3513cebd32bc
--- /dev/null
+++ b/games/frotz/pkg-comment
@@ -0,0 +1 @@
+Infocom games interpreter.
diff --git a/games/frotz/pkg-descr b/games/frotz/pkg-descr
new file mode 100644
index 000000000000..c99dee6423c7
--- /dev/null
+++ b/games/frotz/pkg-descr
@@ -0,0 +1,10 @@
+An interpreter for all Infocom games. Complies with standard
+1.0 of Graham Nelson's specification. Frotz runs text adventures
+which come in so-called story files: ZORK1.DAT, TRINITY.DAT,
+CURSES.Z5, JIGSAW.Z8, ARTHUR.ZIP etc. It is possible to play
+Atari ST, Amiga or Macintosh games on your PC once you manage
+to transfer the story files. There is an increasing number
+of new games available on the Internet. Check the if-archive
+at ftp.gmd.de.
+
+Homepage: http://www.geocities.com/SiliconValley/Heights/3222/frotz.html
diff --git a/games/frotz/pkg-plist b/games/frotz/pkg-plist
new file mode 100644
index 000000000000..e38ca887f98b
--- /dev/null
+++ b/games/frotz/pkg-plist
@@ -0,0 +1,4 @@
+bin/frotz
+share/doc/frotz/Readme.unix
+share/doc/frotz/Todo
+@dirrm share/doc/frotz