aboutsummaryrefslogtreecommitdiff
path: root/games/frozenbubble/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
commit52e8b487f6dc73b0d0baafc955c59e83ab33c41a (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /games/frozenbubble/Makefile
parentdbe27c5fd4471209e8b77eecbae08f3a2ad57040 (diff)
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Notes
Notes: svn path=/head/; revision=301600
Diffstat (limited to 'games/frozenbubble/Makefile')
-rw-r--r--games/frozenbubble/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/games/frozenbubble/Makefile b/games/frozenbubble/Makefile
index 46fb293e391d..2ea85c928458 100644
--- a/games/frozenbubble/Makefile
+++ b/games/frozenbubble/Makefile
@@ -30,7 +30,9 @@ MAN6= frozen-bubble-editor.6 frozen-bubble.6
LEXECDIR= ${PREFIX}/libexec/${PORTNAME}
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
RUN_DEPENDS+= p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
PLIST_SUB+= NLS=""
.else
@@ -54,24 +56,18 @@ pre-install:
do-install:
cd ${WRKSRC}/c_stuff && ${GMAKE} install
-
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC}/po && ${GMAKE} install
.endif
-
${INSTALL_SCRIPT} ${BUILD_WRKSRC}/frozen-bubble ${PREFIX}/bin/
${INSTALL_SCRIPT} ${BUILD_WRKSRC}/frozen-bubble-editor ${PREFIX}/bin/
-
${INSTALL_MAN} ${MAN6:S,^,${WRKSRC}/doc/,} ${PREFIX}/man/man6/
-
${MKDIR} ${DATADIR}
@(cd ${WRKSRC}/ && ${COPYTREE_SHARE} "gfx snd data" ${DATADIR}/)
-
${MKDIR} ${LEXECDIR}
${INSTALL_PROGRAM} ${WRKSRC}/server/fb-server ${LEXECDIR}/
post-install:
-
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>