aboutsummaryrefslogtreecommitdiff
path: root/games/fuhquake
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/fuhquake
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'games/fuhquake')
-rw-r--r--games/fuhquake/Makefile5
-rw-r--r--games/fuhquake/files/patch-image.c38
2 files changed, 41 insertions, 2 deletions
diff --git a/games/fuhquake/Makefile b/games/fuhquake/Makefile
index a5367951ea6c..99db1c609e10 100644
--- a/games/fuhquake/Makefile
+++ b/games/fuhquake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fuhquake
PORTVERSION= 0.31
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= http://www.fuhquake.net/files/releases/v${PORTVERSION}/ \
ftp://gibbage.mine.nu/clients/fuhquake/releases/v${PORTVERSION}/ \
@@ -45,8 +45,9 @@ IGNORE= needs at least one client (GLX or X11)
.if defined(WITH_GLX)
USE_GL= yes
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
+CFLAGS+= -I${LOCALBASE}/include/libpng15
PLIST_SUB+= GLX=""
CLIENTS+= glx
.else
diff --git a/games/fuhquake/files/patch-image.c b/games/fuhquake/files/patch-image.c
new file mode 100644
index 000000000000..24084f0116ad
--- /dev/null
+++ b/games/fuhquake/files/patch-image.c
@@ -0,0 +1,38 @@
+--- image.c.orig 2004-01-07 00:43:22.000000000 +0100
++++ image.c 2012-05-26 15:10:53.000000000 +0200
+@@ -24,6 +24,8 @@
+
+ #ifdef WITH_PNG
+ #include "png.h"
++#include "zlib.h"
++#include "pngpriv.h"
+ #endif
+
+ #ifdef WITH_JPEG
+@@ -569,7 +571,7 @@
+ return NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_ptr->longjmp_buffer)) {
+ qpng_destroy_read_struct(&png_ptr, &pnginfo, NULL);
+ fclose(fin);
+ return NULL;
+@@ -678,7 +680,7 @@
+ return false;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_ptr->longjmp_buffer)) {
+ qpng_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return false;
+@@ -743,7 +745,7 @@
+ return false;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_ptr->longjmp_buffer)) {
+ qpng_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return false;