aboutsummaryrefslogtreecommitdiff
path: root/games/galaxis
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-22 13:50:38 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-22 13:50:38 +0000
commit8ac11b29f859ef21a240e94143789f8edf487409 (patch)
treef0d9c758411b64e7ca734f48f00d0e7e1f2a03ce /games/galaxis
parent140ec0e71f4eaee102e69ec07ddcfa6e3c80d458 (diff)
downloadports-8ac11b29f859ef21a240e94143789f8edf487409.tar.gz
ports-8ac11b29f859ef21a240e94143789f8edf487409.zip
Notes
Diffstat (limited to 'games/galaxis')
-rw-r--r--games/galaxis/Makefile32
-rw-r--r--games/galaxis/distinfo2
-rw-r--r--games/galaxis/files/galaxis.desktop10
-rw-r--r--games/galaxis/files/patch-galaxis.c20
4 files changed, 57 insertions, 7 deletions
diff --git a/games/galaxis/Makefile b/games/galaxis/Makefile
index 97526abdc698..7ed7a503ba67 100644
--- a/games/galaxis/Makefile
+++ b/games/galaxis/Makefile
@@ -3,22 +3,40 @@
PORTNAME= galaxis
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://www.catb.org/~esr/galaxis/
+MASTER_SITES= http://www.catb.org/~esr/galaxis/ \
+ SF/nemysisfreebsdp/games/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Clone of the nifty little Macintosh game
+LICENSE= BSD3CLAUSE
+
+USES= gmake
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DNDEBUG"
ALL_TARGET= ${PORTNAME}
-USE_GMAKE= yes
-MAN6= ${PORTNAME}.6
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz \
+ share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${MAN6PREFIX}/man/man6/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/galaxis/distinfo b/games/galaxis/distinfo
index 7c400b0a3a6e..63a487534bb9 100644
--- a/games/galaxis/distinfo
+++ b/games/galaxis/distinfo
@@ -1,2 +1,4 @@
SHA256 (galaxis-1.8.tar.gz) = bc36c7e5b1e1d96e5a8c6cdb117b3891833a99e99df709c5531c7d44009a8adc
SIZE (galaxis-1.8.tar.gz) = 8962
+SHA256 (galaxis.png) = 628880218f4979e82a673a8843126dea745526e1bdf78bce0cfc05b93101bc07
+SIZE (galaxis.png) = 1997
diff --git a/games/galaxis/files/galaxis.desktop b/games/galaxis/files/galaxis.desktop
new file mode 100644
index 000000000000..aa3903dcafd0
--- /dev/null
+++ b/games/galaxis/files/galaxis.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Galaxis
+GenericName=Galaxis game
+Comment=Clone of the nifty little Macintosh game
+Icon=galaxis
+Exec=galaxis
+Categories=Game;ArcadeGame;
+Terminal=true
diff --git a/games/galaxis/files/patch-galaxis.c b/games/galaxis/files/patch-galaxis.c
new file mode 100644
index 000000000000..8a923b4f7933
--- /dev/null
+++ b/games/galaxis/files/patch-galaxis.c
@@ -0,0 +1,20 @@
+--- ./galaxis.c.orig 2010-10-13 12:13:31.000000000 +0200
++++ ./galaxis.c 2013-12-22 12:01:31.000000000 +0100
+@@ -15,6 +15,8 @@
+ #include <assert.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <time.h>
++#include <unistd.h>
+
+ #ifndef A_UNDERLINE /* BSD curses */
+ #define beep() write(1,"\007",1);
+@@ -644,7 +646,7 @@
+ }
+ }
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {