aboutsummaryrefslogtreecommitdiff
path: root/games/galaxyhack
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 16:35:45 +0000
commit3a283e24f296371e9b753c09e3e62a92ef3d8703 (patch)
tree88e0a2bbddafb5c9bdc18e8e02c5e59fb9f9d471 /games/galaxyhack
parent7a0a8929bea1c510b4f30261d294a78b556b49d7 (diff)
downloadports-3a283e24f296371e9b753c09e3e62a92ef3d8703.tar.gz
ports-3a283e24f296371e9b753c09e3e62a92ef3d8703.zip
Notes
Diffstat (limited to 'games/galaxyhack')
-rw-r--r--games/galaxyhack/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index c59beb7f5c59..694aa69a3352 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -27,16 +27,17 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/src
CXXFLAGS+= -DBOOST_FILESYSTEM_VERSION=2
-OPTIONS= FLEETS "Install additional fleets" off \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+OPTIONS_DEFINE= FLEETS OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
+FLEETS_DESC= Install additional fleets
ALL_TARGET= ${PORTNAME}
SUB_FILES= ${PORTNAME}-sh
FLEETS_FILE= gh_fleets_020906.zip
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FLEETS)
+.if ${PORT_OPTIONS:MFLEETS}
EXTRACT_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
DISTFILES+= ${FLEETS_FILE}
PLIST_SUB+= FLEETS=""
@@ -44,7 +45,7 @@ PLIST_SUB+= FLEETS=""
PLIST_SUB+= FLEETS="@comment "
.endif
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ENV+= OPTIMIZED_CFLAGS=YES
.endif
@@ -56,7 +57,7 @@ do-install:
.for d in fleets gamedata graphics music standardpictures
${CP} -R ${WRKSRC}/../${d} ${DATADIR}
.endfor
-.if defined(WITH_FLEETS)
+.if ${PORT_OPTIONS:MFLEETS}
@${UNZIP_CMD} -o ${DISTDIR}/${FLEETS_FILE} -x "*/CVS/*" "*/.svn/*" \
-d ${DATADIR}
.endif
@@ -68,4 +69,4 @@ post-install:
@${FIND} ${DATADIR} -type d -print0 | \
${XARGS} -0 ${CHMOD} ${BINMODE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>