aboutsummaryrefslogtreecommitdiff
path: root/games/galaxymage/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/galaxymage/Makefile
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
Notes
Diffstat (limited to 'games/galaxymage/Makefile')
-rw-r--r--games/galaxymage/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/games/galaxymage/Makefile b/games/galaxymage/Makefile
index 3a14c7872157..ad23464d116d 100644
--- a/games/galaxymage/Makefile
+++ b/games/galaxymage/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: galaxymage
-# Date created: 2006-01-30
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= galaxymage
PORTVERSION= 0.3.0
@@ -23,11 +19,12 @@ USE_TWISTED= yes
USES= gettext
NO_BUILD= yes
-OPTIONS= PSYCO "Use just-in-time Python compiler" off
+OPTIONS_DEFINE= PSYCO
+PSYCO_DESC= Use just-in-time Python compiler
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PSYCO)
+.if ${PORT_OPTIONS:MPSYCO}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
@@ -50,7 +47,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/locale/${FILE}/LC_MESSAGES/* \
${PREFIX}/share/locale/${FILE}/LC_MESSAGES
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/doc && \
${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
@@ -58,4 +55,4 @@ do-install:
"${DOCSDIR}/{}" \;
@${INSTALL_DATA} ${WRKSRC}/CREDITS.txt ${WRKSRC}/README.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>