aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-14 21:07:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-02-14 21:07:04 +0000
commita62cb5534288fb1c43bea0bc346d658b0bc18355 (patch)
treef3183397fd97e04ebd097beeefb851dad8690a83 /games/gcompris/Makefile
parent5bbfcf585f3c1506b328a907bab5f4399ed3ea6e (diff)
downloadports-a62cb5534288fb1c43bea0bc346d658b0bc18355.tar.gz
ports-a62cb5534288fb1c43bea0bc346d658b0bc18355.zip
Notes
Diffstat (limited to 'games/gcompris/Makefile')
-rw-r--r--games/gcompris/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index 6d5444aa33f0..8fc19525e531 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -2,15 +2,15 @@
# $FreeBSD$
PORTNAME= gcompris
-PORTVERSION= 15.02
-PORTREVISION= 1
+PORTVERSION= 15.10
CATEGORIES= games gnome
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= http://gcompris.net/download/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gnome2 educational games and activities for kids ages 2 to 10
-LICENSE= GPLv2
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
@@ -21,15 +21,13 @@ LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
gnucap:${PORTSDIR}/cad/gnucap
-USES= display:configure gettext gmake libtool pathfix pkgconfig \
- python:2 shebangfix sqlite tar:bzip2
+USES= display:configure gettext gmake libtool localbase pathfix \
+ pkgconfig python:2 shebangfix sqlite tar:bzip2
SHEBANG_FILES= boards/voices/*.sh
GNU_CONFIGURE= yes
USE_GSTREAMER= yes
USE_SDL= mixer
USE_GNOME= intlhack gnomeprefix gtk20 pygtk2 libxml2 librsvg2
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \