aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-02-22 19:08:35 +0000
committerRene Ladan <rene@FreeBSD.org>2020-02-22 19:08:35 +0000
commitd8fa717c4c841a445c7863481c033e16dcf6ce62 (patch)
tree84d2d2393ec3a2b1e2de1d239eb7f3669b825f28 /games/gcompris/Makefile
parenta389cc412bb103b1ff038cf56cede56e018d8339 (diff)
downloadports-d8fa717c4c841a445c7863481c033e16dcf6ce62.tar.gz
ports-d8fa717c4c841a445c7863481c033e16dcf6ce62.zip
Notes
Diffstat (limited to 'games/gcompris/Makefile')
-rw-r--r--games/gcompris/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
deleted file mode 100644
index 3637d187568e..000000000000
--- a/games/gcompris/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# Created by: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
-# $FreeBSD$
-
-PORTNAME= gcompris
-PORTVERSION= 15.10
-PORTREVISION= 2
-CATEGORIES= games gnome
-MASTER_SITES= http://gcompris.net/download/
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Gnome2 educational games and activities for kids ages 2 to 10
-
-BROKEN= unfetchable
-DEPRECATED= Broken, uses EOLed python27
-EXPIRATION_DATE= 2020-02-19
-
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BUILD_DEPENDS= texi2html:textproc/texi2html \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-LIB_DEPENDS= libvorbis.so:audio/libvorbis \
- libao.so:audio/libao \
- libassetml.so:devel/libassetml \
- libdbus-glib-1.so:devel/dbus-glib
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
- gnucap:cad/gnucap
-
-USES= display:configure gettext gmake gnome libtool localbase pathfix \
- perl5 pkgconfig python:2.7 sdl shebangfix sqlite tar:bzip2
-USE_PERL5= run
-SHEBANG_FILES= boards/voices/*.sh boards/voices/*.pl
-GNU_CONFIGURE= yes
-USE_GSTREAMER= yes
-USE_SDL= mixer
-USE_GNOME= intlhack gnomeprefix gtk20 pygtk2 libxml2 librsvg2
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/src/gcompris/gcompris.c
- @${FIND} ${WRKSRC} -type f -name "*.bak" -delete
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gcompris/lib*.so
-
-.include <bsd.port.mk>