aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-22 05:49:51 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-22 05:49:51 +0000
commite83dfbadce53b05c63bce0c476b07dab400365d1 (patch)
treea8d4f6248064a728dda31e5fdc06cb67224a27ba /games/gcompris2/Makefile
parent590bd54f9d1aa46af17d04f805c129b28529a599 (diff)
downloadports-e83dfbadce53b05c63bce0c476b07dab400365d1.tar.gz
ports-e83dfbadce53b05c63bce0c476b07dab400365d1.zip
Notes
Diffstat (limited to 'games/gcompris2/Makefile')
-rw-r--r--games/gcompris2/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/gcompris2/Makefile b/games/gcompris2/Makefile
index 693084a686dc..0ac5c7dfb4c0 100644
--- a/games/gcompris2/Makefile
+++ b/games/gcompris2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gcompris2
-PORTVERSION= 6.4
-PORTREVISION= 1
+PORTVERSION= 6.5
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gcompris
@@ -30,10 +29,15 @@ USE_PYTHON= yes
USE_SDL= mixer
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui pygnome2
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="${PTHREAD_LIBS} -lm"
INFO= gcompris
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-DGNOME_DISABLE_DEPRECATED||g'
+
.include <bsd.port.mk>