aboutsummaryrefslogtreecommitdiff
path: root/games/gemrb/Makefile
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-11-23 13:16:59 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-11-23 13:16:59 +0000
commitc885de11ad29b545cb247f0b9ca0d15814c530e3 (patch)
tree7ecc6933470ffccd9866c87af8969106c52f6a46 /games/gemrb/Makefile
parent30ca31e0f3f69ab71dbaf57fdc00abfb0754b1f8 (diff)
downloadports-c885de11ad29b545cb247f0b9ca0d15814c530e3.tar.gz
ports-c885de11ad29b545cb247f0b9ca0d15814c530e3.zip
Notes
Diffstat (limited to 'games/gemrb/Makefile')
-rw-r--r--games/gemrb/Makefile36
1 files changed, 4 insertions, 32 deletions
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index 925dd379f57b..d673922eae10 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= gemrb
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.0.1
CATEGORIES= games emulators
-MASTER_SITES= SF/${PORTNAME}/GemRB%20Sources/GemRB%20${PORTVERSION}%20Sources
+MASTER_SITES= SF/${PORTNAME}/GemRB%20Sources/GemRB%20${PORTVERSION:.1=}%20Sources
MAINTAINER= beyert@cs.ucr.edu
COMMENT= GemRB (Game engine made with preRendered Background)
@@ -12,8 +12,8 @@ COMMENT= GemRB (Game engine made with preRendered Background)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USES= cmake
USE_SDL= sdl mixer ttf
@@ -24,32 +24,4 @@ CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
CMAKE_C_FLAGS= ${CFLAGS}
CMAKE_ARGS= -DDOC_DIR="${DOCSDIR}" -DMAN_DIR="${MAN6PREFIX}/man/man6/" -DDISABLE_WERROR=1 -DINSOURCEBUILD=1
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-MAN6= gemrb.6
-
-post-patch:
- @${REINPLACE_CMD} \
- -e '/^ADD_SUBDIRECTORY( VLCPlayer )/d' \
- ${WRKSRC}/gemrb/plugins/CMakeLists.txt
-
-.if empty(PORT_OPTIONS:MDOCS)
- @${REINPLACE_CMD} \
- -e '/^INSTALL( FILES README INSTALL COPYING NEWS AUTHORS DESTINATION \$${DOC_DIR} )/d' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} \
- -e '/^ADD_SUBDIRECTORY( docs )/d' \
- ${WRKSRC}/gemrb/CMakeLists.txt
- @${REINPLACE_CMD} \
- -e '/^ADD_SUBDIRECTORY( en )/d' \
- ${WRKSRC}/gemrb/docs/CMakeLists.txt
-.endif
-
-post-install:
- @if [ ! -f ${PREFIX}/etc/gemrb.cfg ]; then \
- ${CP} ${WRKSRC}/gemrb/GemRB.cfg.sample ${PREFIX}/etc/gemrb.cfg; \
- fi
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>