aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-txt-client
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-19 18:02:38 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-19 18:02:38 +0000
commit974048e9660e355fa58a22e2d0f4fb881336a167 (patch)
tree349a7701db20141541b5f00da694110a50418026 /games/ggz-txt-client
parentec4de84f8e9ac84a4987b0aad5175f7029a2e7f6 (diff)
downloadports-974048e9660e355fa58a22e2d0f4fb881336a167.tar.gz
ports-974048e9660e355fa58a22e2d0f4fb881336a167.zip
Notes
Diffstat (limited to 'games/ggz-txt-client')
-rw-r--r--games/ggz-txt-client/Makefile8
-rw-r--r--games/ggz-txt-client/distinfo4
-rw-r--r--games/ggz-txt-client/files/patch-ggz-txt::loop.c10
-rw-r--r--games/ggz-txt-client/files/patch-ggz-txt::output.c14
-rw-r--r--games/ggz-txt-client/files/patch-tttxt::main.c10
-rw-r--r--games/ggz-txt-client/pkg-plist3
6 files changed, 43 insertions, 6 deletions
diff --git a/games/ggz-txt-client/Makefile b/games/ggz-txt-client/Makefile
index 0ca34ae5870b..96dc0cbfb3dc 100644
--- a/games/ggz-txt-client/Makefile
+++ b/games/ggz-txt-client/Makefile
@@ -7,20 +7,20 @@
#
PORTNAME= ggz-txt-client
-PORTVERSION= 0.0.8
+PORTVERSION= 0.0.9
CATEGORIES= games
-MASTER_SITES= http://ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITES= http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The GGZ Gaming Zone - Console (Text) Frontend
-LIB_DEPENDS= ggzcore.4:${PORTSDIR}/games/ggz-client-libs
+LIB_DEPENDS= ggzcore.5:${PORTSDIR}/games/ggz-client-libs
USE_GNOME= gnometarget
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/ggz-txt-client/distinfo b/games/ggz-txt-client/distinfo
index d843e2aa9233..8f66a0f45f5c 100644
--- a/games/ggz-txt-client/distinfo
+++ b/games/ggz-txt-client/distinfo
@@ -1,2 +1,2 @@
-MD5 (ggz-txt-client-0.0.8.tar.gz) = c75bdf17ed8576fb36ec9c00fb79dedf
-SIZE (ggz-txt-client-0.0.8.tar.gz) = 124315
+MD5 (ggz-txt-client-0.0.9.tar.gz) = c9ef37dd4b8c2679f9136cdf4f714b76
+SIZE (ggz-txt-client-0.0.9.tar.gz) = 132926
diff --git a/games/ggz-txt-client/files/patch-ggz-txt::loop.c b/games/ggz-txt-client/files/patch-ggz-txt::loop.c
new file mode 100644
index 000000000000..174b2920b273
--- /dev/null
+++ b/games/ggz-txt-client/files/patch-ggz-txt::loop.c
@@ -0,0 +1,10 @@
+--- ggz-txt/loop.c.orig Mon May 17 23:20:01 2004
++++ ggz-txt/loop.c Sun Jul 18 20:25:18 2004
+@@ -32,6 +32,7 @@
+ #include <ggz.h>
+ #include <unistd.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
+
diff --git a/games/ggz-txt-client/files/patch-ggz-txt::output.c b/games/ggz-txt-client/files/patch-ggz-txt::output.c
new file mode 100644
index 000000000000..6062361d91bc
--- /dev/null
+++ b/games/ggz-txt-client/files/patch-ggz-txt::output.c
@@ -0,0 +1,14 @@
+--- ggz-txt/output.c.orig Fri Jun 25 22:32:46 2004
++++ ggz-txt/output.c Sun Jul 18 20:29:22 2004
+@@ -145,10 +145,10 @@
+ char message[1024]; /* FIXME: Make me dynamic */
+ int x;
+ char *token, *messagedup, *orig;
++ va_list ap;
+
+ if(!output_enabled) return;
+
+- va_list ap;
+ va_start(ap, fmt);
+ vsnprintf(message, sizeof(message), fmt, ap);
+ va_end(ap);
diff --git a/games/ggz-txt-client/files/patch-tttxt::main.c b/games/ggz-txt-client/files/patch-tttxt::main.c
new file mode 100644
index 000000000000..e16834251384
--- /dev/null
+++ b/games/ggz-txt-client/files/patch-tttxt::main.c
@@ -0,0 +1,10 @@
+--- tttxt/main.c.orig Mon May 17 23:21:10 2004
++++ tttxt/main.c Sun Jul 18 20:32:02 2004
+@@ -24,6 +24,7 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <string.h>
++#include <sys/time.h>
+
+ #include <ggz_common.h>
+ #include <ggzmod.h>
diff --git a/games/ggz-txt-client/pkg-plist b/games/ggz-txt-client/pkg-plist
index 6c24c4b10f96..74f29bf59fd6 100644
--- a/games/ggz-txt-client/pkg-plist
+++ b/games/ggz-txt-client/pkg-plist
@@ -1,2 +1,5 @@
bin/ggz-txt
+etc/ggz.modules
+lib/ggz/tttxt
share/locale/de/LC_MESSAGES/ggz-txt.mo
+@unexec rmdir %D/lib/ggz 2>/dev/null || true