aboutsummaryrefslogtreecommitdiff
path: root/games/gillo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 13:47:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 13:47:16 +0000
commitc1082e00056e43a468cd6143fde221192a5037b1 (patch)
treec6eb9f30bba7e25e3b15d21d8745689e0a196c63 /games/gillo
parentd44adee0d55638f442d92a399abf15447728f89d (diff)
- Fix build with clang
PR: 184836 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=340292
Diffstat (limited to 'games/gillo')
-rw-r--r--games/gillo/Makefile14
-rw-r--r--games/gillo/files/patch-src__goal.cpp11
-rw-r--r--games/gillo/files/patch-src__goal.h11
-rw-r--r--games/gillo/files/patch-src__simpleball.cpp11
-rw-r--r--games/gillo/files/patch-src__simpleball.h13
5 files changed, 54 insertions, 6 deletions
diff --git a/games/gillo/Makefile b/games/gillo/Makefile
index 04c50785b969..cca67eae79dc 100644
--- a/games/gillo/Makefile
+++ b/games/gillo/Makefile
@@ -11,18 +11,20 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Players are cars throwing a magnetic fuzzy ball into a goal
+LICENSE= GPLv2
+
BUILD_DEPENDS= ${JAM}:${PORTSDIR}/devel/jam \
${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
${LOCALBASE}/lib/libplibsg.a:${PORTSDIR}/x11-toolkits/plib
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
USE_BZIP2= yes
USE_GL= gl
USE_SDL= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
JAM?= ${LOCALBASE}/bin/jam
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -i '' -e 's|SDL/||g' ${WRKSRC}/src/*
@${REINPLACE_CMD} -e 's|%%SDL_CFLAGS%%|`${SDL_CONFIG} --cflags`|' \
@@ -33,11 +35,11 @@ post-patch:
do-build:
cd ${WRKSRC} && ${SETENV} "C++=${CC}" "LOCALBASE=${LOCALBASE}" \
"CFLAGS=${CFLAGS} -DDATADIR=\\\"${PREFIX}/share\\\"" \
- ${JAM} -dx -sPREFIX=${PREFIX}
+ ${JAM} -dx -sPREFIX=${PREFIX}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gillo3 ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/data/*.* ${DATADIR}
+ (cd ${WRKSRC}/src && ${INSTALL_PROGRAM} gillo3 ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/data && ${INSTALL_DATA} *.* ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>
diff --git a/games/gillo/files/patch-src__goal.cpp b/games/gillo/files/patch-src__goal.cpp
new file mode 100644
index 000000000000..fd928a6786a9
--- /dev/null
+++ b/games/gillo/files/patch-src__goal.cpp
@@ -0,0 +1,11 @@
+--- src/goal.cpp.orig
++++ src/goal.cpp
+@@ -22,6 +22,8 @@
+
+ namespace gillo {
+
++const float Goal::areaRadius = ODE_GOAL_DISTANCE;
++
+ Goal::Goal(Context& c)
+ : Entity(c)
+ {
diff --git a/games/gillo/files/patch-src__goal.h b/games/gillo/files/patch-src__goal.h
new file mode 100644
index 000000000000..91d7ffab5a6b
--- /dev/null
+++ b/games/gillo/files/patch-src__goal.h
@@ -0,0 +1,11 @@
+--- src/goal.h.orig
++++ src/goal.h
+@@ -32,7 +32,7 @@
+ */
+ class Goal : public Entity
+ {
+- static const float areaRadius = ODE_GOAL_DISTANCE;
++ static const float areaRadius;
+ dGeomID gids[6];
+ public:
+ Goal(Context& c);
diff --git a/games/gillo/files/patch-src__simpleball.cpp b/games/gillo/files/patch-src__simpleball.cpp
new file mode 100644
index 000000000000..0a8d7e7a8753
--- /dev/null
+++ b/games/gillo/files/patch-src__simpleball.cpp
@@ -0,0 +1,11 @@
+--- src/simpleball.cpp.orig
++++ src/simpleball.cpp
+@@ -26,6 +26,8 @@
+ const sgVec4 SimpleBall::p1[3] = { {0.3, 0.0, 0.0, 1.0}, {1.0, 0.0, 0.0, 1.0}, {1.0, 0.4, 0.4, 1.0} };
+ const sgVec4 SimpleBall::ne[3] = { {0.0, 0.0, 0.0, 1}, {0.6, 0.6, 0.6, 1}, {1.0, 1.0, 1.0, 1} };
+ const sgVec4 SimpleBall::p2[3] = { {0.0, 0.0, 0.3, 1}, {0.0, 0.0, 1.0, 1}, {0.4, 0.4, 1.0, 1} };
++const double SimpleBall::weight = ODE_BALL_MASS;
++const double SimpleBall::radius = ODE_BALL_RADIUS;
+
+ SimpleBall::SimpleBall(Context& c)
+ : Entity(c), ballEffectPtr(NULL), possessionIncrement(0), targetSize(2*radius), currentSize(2*radius)
diff --git a/games/gillo/files/patch-src__simpleball.h b/games/gillo/files/patch-src__simpleball.h
new file mode 100644
index 000000000000..ce26cc72cc61
--- /dev/null
+++ b/games/gillo/files/patch-src__simpleball.h
@@ -0,0 +1,13 @@
+--- src/simpleball.h.orig
++++ src/simpleball.h
+@@ -37,8 +37,8 @@
+ static const sgVec4 p1[3];
+ static const sgVec4 ne[3];
+ static const sgVec4 p2[3];
+- static const double weight = ODE_BALL_MASS;
+- static const double radius = ODE_BALL_RADIUS;
++ static const double weight;
++ static const double radius;
+
+ SimpleBall(Context& c);
+ SimpleBall(Context& c, float size, ssgSimpleState* state);