aboutsummaryrefslogtreecommitdiff
path: root/games/gish-demo/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 02:51:59 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 02:51:59 +0000
commite5f88d9b156cb0ce1fda4bc49a25fa5ea58df5e8 (patch)
treee427c40bb8bd9e270c86a01fd752340f372436d6 /games/gish-demo/Makefile
parent0a95ed3134930e5bce059f0c8c606f7852d0af31 (diff)
downloadports-e5f88d9b156cb0ce1fda4bc49a25fa5ea58df5e8.tar.gz
ports-e5f88d9b156cb0ce1fda4bc49a25fa5ea58df5e8.zip
Notes
Diffstat (limited to 'games/gish-demo/Makefile')
-rw-r--r--games/gish-demo/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/gish-demo/Makefile b/games/gish-demo/Makefile
new file mode 100644
index 000000000000..b459bfd02726
--- /dev/null
+++ b/games/gish-demo/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gish-demo
+# Date created: 04 September 2006
+# Whom: Jona Joachim <walkingshadow@grummel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gish-demo
+PORTVERSION= 1.2
+CATEGORIES= games linux
+MASTER_SITES= http://s159260531.onlinehome.us/demos/
+DISTNAME= gishdemo
+
+MAINTAINER= walkingshadow@grummel.net
+COMMENT= A platform game with a gelatinous 12-pound ball of tar named Gish (Demo version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis \
+ ${LINUXBASE}/usr/lib/libopenal.so.0:${PORTSDIR}/audio/linux-openal \
+ ${LINUXBASE}/usr/lib/libalut.so.0:${PORTSDIR}/audio/linux-freealut \
+ ${LINUXBASE}/usr/X11R6/lib/libGL.so.1.2:${PORTSDIR}/graphics/linux_dri
+
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= is an i386 Linux binary
+USE_LINUX= yes
+NO_BUILD= yes
+DATADIR= ${PREFIX}/lib/${PORTNAME}
+SUB_FILES= rungish.sh
+SUB_LIST= LINUXBASE=${LINUXBASE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/* ${DATADIR}
+ ${BRANDELF} -t Linux ${DATADIR}/gish
+ ${INSTALL_SCRIPT} ${WRKDIR}/rungish.sh ${PREFIX}/bin/gish
+
+.include <bsd.port.mk>