aboutsummaryrefslogtreecommitdiff
path: root/games/glasteroids
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-09-07 10:10:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-09-07 10:10:11 +0000
commitad3dff30b7c4b25052900b3c6adb896ccc027305 (patch)
tree48d358dc6d4f9244ae12e6ee7d16091536ac8530 /games/glasteroids
parent61f9142ed6b705e9382824d87f1da0cbaa1e4c95 (diff)
downloadports-ad3dff30b7c4b25052900b3c6adb896ccc027305.tar.gz
ports-ad3dff30b7c4b25052900b3c6adb896ccc027305.zip
Notes
Diffstat (limited to 'games/glasteroids')
-rw-r--r--games/glasteroids/Makefile42
-rw-r--r--games/glasteroids/distinfo2
-rw-r--r--games/glasteroids/files/Makefile.FreeBSD33
-rw-r--r--games/glasteroids/files/patch-BCenemy.h11
-rw-r--r--games/glasteroids/files/patch-aa11
-rw-r--r--games/glasteroids/files/patch-ab19
-rw-r--r--games/glasteroids/files/patch-ac21
-rw-r--r--games/glasteroids/pkg-descr7
-rw-r--r--games/glasteroids/pkg-plist11
9 files changed, 0 insertions, 157 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
deleted file mode 100644
index 9436a77d6323..000000000000
--- a/games/glasteroids/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# New ports collection makefile for: glasteroids
-# Date created: 16 August 1999
-# Whom: Andrey Zakhvatov
-#
-# $FreeBSD$
-#
-
-PORTNAME= glasteroids
-PORTVERSION= 1.0
-PORTREVISION= 6
-CATEGORIES= games
-MASTER_SITES= http://www.honors.montana.edu/~jjc/Glasteroids/
-DISTNAME= Glasteriods
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= 3D Asteroids game for X Window System
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
-WRKSRC= ${WRKDIR}/Glasteroids
-
-USE_GL= glut
-MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
-
-do-install:
- ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/gameText.txf ${DATADIR}
- ${TAR} -C ${WRKSRC} -cf - scores.txt textures | \
- ${TAR} -C ${DATADIR} --unlink -xf -
- @${CHMOD} a+rx ${DATADIR}/textures
- @${CHMOD} g+rw,a-x ${DATADIR}/scores.txt
- @${CHOWN} root:games ${DATADIR}/scores.txt
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/games/glasteroids/distinfo b/games/glasteroids/distinfo
deleted file mode 100644
index 74b9a0410dcf..000000000000
--- a/games/glasteroids/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (Glasteriods.tar.gz) = 41950624da6dceebc5d60d3106dd8d26cf24cdec1b07b32d2fe57207f09229bc
-SIZE (Glasteriods.tar.gz) = 1003820
diff --git a/games/glasteroids/files/Makefile.FreeBSD b/games/glasteroids/files/Makefile.FreeBSD
deleted file mode 100644
index b023c005dafd..000000000000
--- a/games/glasteroids/files/Makefile.FreeBSD
+++ /dev/null
@@ -1,33 +0,0 @@
-SRCS = Glasteroids.cxx Bobcat.cxx MarchingCubes.cxx BCship.cxx BCobject.cxx\
- BCcollide.cxx GlutFunctions.cxx BCmenu.cxx BCenemy.cxx TexFont.cxx \
- SplashScreen.cxx
-OBJS = Glasteroids.o Bobcat.o MarchingCubes.o BCship.o BCobject.o\
- BCcollide.o GlutFunctions.o BCmenu.o BCenemy.o TexFont.o \
- SplashScreen.o
-CXX ?= c++
-CXXFLAGS += -DGL_GLEXT_LEGACY ${PTHREAD_CFLAGS}
-PROG = Glasteroids
-
-LIBS = -lglut -lGLU -lGL -lXmu -lX11 -lXext -lm -lXi ${PTHREAD_LIBS}
-
-INCDIR = -I${LOCALBASE}/include
-LIBDIR = -L${LOCALBASE}/lib
-
-PREFIX ?= /usr/X11R6
-X11BASE ?= /usr/X11R6
-
-.SUFFIXES: .cxx .o
-
-.cxx.o:
- $(CXX) $(CXXFLAGS) -DPREFIX=\"${PREFIX}\" -c $< $(INCDIR)
-
-all: $(PROG)
-
-$(PROG): $(OBJS)
- $(CXX) -o $(PROG) -Wall $(OBJS) $(LIBDIR) $(LIBS)
-
-clean:
- rm -f *.o *~ $(PROG)
-
-depend:
- makedepend -- $(INCDIR) -- $(SRCS)
diff --git a/games/glasteroids/files/patch-BCenemy.h b/games/glasteroids/files/patch-BCenemy.h
deleted file mode 100644
index de83d1ee6ec0..000000000000
--- a/games/glasteroids/files/patch-BCenemy.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- BCenemy.h.orig Thu Dec 21 17:33:04 2006
-+++ BCenemy.h Thu Dec 21 17:33:15 2006
-@@ -37,7 +37,7 @@
- void DrawEnemyShipExploding ( void );
- void ResetShip ( );
-
-- int BCenemy::GetStatus ( void );
-+ int GetStatus ( void );
-
- BCship *Ship;
-
diff --git a/games/glasteroids/files/patch-aa b/games/glasteroids/files/patch-aa
deleted file mode 100644
index d484839dc974..000000000000
--- a/games/glasteroids/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- BCmenu.h Thu Aug 12 04:48:58 1999
-+++ /home/andy/tmp/wrk/BCmenu.h Tue Aug 17 15:28:12 1999
-@@ -23,7 +23,7 @@
- #include "BCincludes.h"
- #include "TexFont.h"
-
--#define HIGH_SCORE_FILE "scores.txt"
-+#define HIGH_SCORE_FILE PREFIX "/share/glasteroids/scores.txt"
- #define MAX_HIGH_SCORES 10
- #define MAX_NAME_LENGTH 10
-
diff --git a/games/glasteroids/files/patch-ab b/games/glasteroids/files/patch-ab
deleted file mode 100644
index df2f64692275..000000000000
--- a/games/glasteroids/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- Bobcat.cxx Thu Aug 12 04:48:58 1999
-+++ /home/andy/tmp/wrk/Bobcat.cxx Tue Aug 17 15:28:23 1999
-@@ -111,14 +111,14 @@
-
- glutIdleFunc ( InternalIdle );
-
-- font = txfLoadFont ( "gameText.txf" );
-+ font = txfLoadFont ( PREFIX "/share/glasteroids/gameText.txf" );
-
- Menu = new BCmenu ( font );
-
- InitTextures ( );
- InitOpenGL ( );
-
-- LoadSplashScreen ( "textures/splash.raw" );
-+ LoadSplashScreen ( PREFIX "/share/glasteroids/textures/splash.raw" );
-
- numActiveDust = 0;
- for ( i = 0; i < MAX_ASTEROID_DUST_SYSTEMS; i++ )
diff --git a/games/glasteroids/files/patch-ac b/games/glasteroids/files/patch-ac
deleted file mode 100644
index 528ea4331054..000000000000
--- a/games/glasteroids/files/patch-ac
+++ /dev/null
@@ -1,21 +0,0 @@
---- Glasteroids.cxx.orig Wed Aug 11 19:48:58 1999
-+++ Glasteroids.cxx Sun Aug 6 19:33:33 2000
-@@ -1,5 +1,8 @@
- #include <stdlib.h>
- #include <time.h>
-+#if defined(__FreeBSD__) && defined(__i386__)
-+#include <floatingpoint.h>
-+#endif
- #include "Bobcat.h"
-
- /*
-@@ -75,6 +78,9 @@
- {
- BCworld *world;
-
-+#if defined(__FreeBSD__) && defined(__i386__)
-+ fpsetmask(0);
-+#endif
- world = BCgetWorld ( );
-
- world->InitWorld ( argc, argv,"Glasteroids", 640, 480, 100 );
diff --git a/games/glasteroids/pkg-descr b/games/glasteroids/pkg-descr
deleted file mode 100644
index 9b4096724f2d..000000000000
--- a/games/glasteroids/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-3D Asteroids game clone for X Window System.
-The goal is simple: Don't get killed.
-
-Feel free to email questions, comments, ideas,
-etc. to cohen@cs.montana.edu
-
-WWW: http://www.honors.montana.edu/~jjc/Glasteroids/
diff --git a/games/glasteroids/pkg-plist b/games/glasteroids/pkg-plist
deleted file mode 100644
index 474f7c557824..000000000000
--- a/games/glasteroids/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/glasteroids
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%DATADIR%%/gameText.txf
-@mode 666
-%%DATADIR%%/scores.txt
-@mode
-%%DATADIR%%/textures/splash.raw
-%%DATADIR%%/textures/splash_non.raw
-@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/textures
-@dirrm %%DATADIR%%