aboutsummaryrefslogtreecommitdiff
path: root/games/glasteroids
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-06 12:17:30 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-06 12:17:30 +0000
commitde0ab4aa1bd98696f67abca37c5019bc0732ca51 (patch)
tree846c7ba861c614c04204f998d5b89f76e965f9aa /games/glasteroids
parentc010659195e23ea3b0dfb259c50181586cdf2e9e (diff)
downloadports-de0ab4aa1bd98696f67abca37c5019bc0732ca51.tar.gz
ports-de0ab4aa1bd98696f67abca37c5019bc0732ca51.zip
Notes
Diffstat (limited to 'games/glasteroids')
-rw-r--r--games/glasteroids/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index c0dae1f4edb9..87efb65cd33b 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -25,6 +25,12 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
@${MKDIR} ${DATADIR}
@@ -39,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>