aboutsummaryrefslogtreecommitdiff
path: root/games/glasteroids
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-21 17:41:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-21 17:41:17 +0000
commit30480c3a02c3cf372a3a1920a5352aee12eb300b (patch)
tree8a0fbaf1f82650e822d9e6f4fac10509e1f37a91 /games/glasteroids
parentded31b50a18f232ca132e71daf503da588a5b974 (diff)
downloadports-30480c3a02c3cf372a3a1920a5352aee12eb300b.tar.gz
ports-30480c3a02c3cf372a3a1920a5352aee12eb300b.zip
Notes
Diffstat (limited to 'games/glasteroids')
-rw-r--r--games/glasteroids/Makefile36
-rw-r--r--games/glasteroids/files/Makefile.FreeBSD5
-rw-r--r--games/glasteroids/files/patch-ac4
-rw-r--r--games/glasteroids/pkg-plist17
4 files changed, 29 insertions, 33 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index d4f6acfb0463..c0dae1f4edb9 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -7,7 +7,7 @@
PORTNAME= glasteroids
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.honors.montana.edu/~jjc/Glasteroids/
DISTNAME= Glasteriods
@@ -15,32 +15,28 @@ DISTNAME= Glasteriods
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D Asteroids game for X Window System
-MAKEFILE= Makefile.FreeBSD
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
WRKSRC= ${WRKDIR}/Glasteroids
USE_X_PREFIX= yes
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
-USE_MESA= yes
-
-pre-build:
- @ ${CP} ${FILESDIR}/Makefile.FreeBSD ${WRKSRC}
+USE_GL= yes
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
do-install:
- @ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
- @ ${MKDIR} ${PREFIX}/share/glasteroids
- @ ${INSTALL_DATA} ${WRKSRC}/gameText.txf ${PREFIX}/share/glasteroids
- @ cd ${WRKSRC}; tar -cf - scores.txt textures | \
- ( cd ${PREFIX}/share/glasteroids; tar -xf - )
- @ ${CHMOD} a+rx ${PREFIX}/share/glasteroids/textures
- @ ${CHMOD} g+rw,a-x ${PREFIX}/share/glasteroids/scores.txt
- @ ${CHOWN} root:games ${PREFIX}/share/glasteroids/scores.txt
-
-post-install:
+ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gameText.txf ${DATADIR}
+ ${TAR} -C ${WRKSRC} -cf - scores.txt textures | \
+ ${TAR} -C ${DATADIR} --unlink -xf -
+ @${CHMOD} a+rx ${DATADIR}/textures
+ @${CHMOD} g+rw,a-x ${DATADIR}/scores.txt
+ @${CHOWN} root:games ${DATADIR}/scores.txt
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/glasteroids
- @ ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/glasteroids
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/glasteroids
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/glasteroids/files/Makefile.FreeBSD b/games/glasteroids/files/Makefile.FreeBSD
index 2c3f1ff52861..73f971e341a5 100644
--- a/games/glasteroids/files/Makefile.FreeBSD
+++ b/games/glasteroids/files/Makefile.FreeBSD
@@ -10,10 +10,11 @@ PROG = Glasteroids
LIBS = -lglut -lGLU -lGL -lXmu -lX11 -lXext -lm -lXi ${PTHREAD_LIBS}
-INCDIR = -I/usr/X11R6/include
-LIBDIR = -L/usr/X11R6/lib
+INCDIR = -I${X11BASE}/include
+LIBDIR = -L${X11BASE}/lib
PREFIX ?= /usr/X11R6
+X11BASE ?= /usr/X11R6
.SUFFIXES: .cxx .o
diff --git a/games/glasteroids/files/patch-ac b/games/glasteroids/files/patch-ac
index c3217da91aac..00643ffc1f38 100644
--- a/games/glasteroids/files/patch-ac
+++ b/games/glasteroids/files/patch-ac
@@ -3,7 +3,7 @@
@@ -1,5 +1,8 @@
#include <stdlib.h>
#include <time.h>
-+#ifdef __FreeBSD__
++#if defined(__FreeBSD__) && (defined(__i386__) || defined(__amd64__))
+#include <floatingpoint.h>
+#endif
#include "Bobcat.h"
@@ -13,7 +13,7 @@
{
BCworld *world;
-+#if defined(__FreeBSD__) && !defined(__alpha__)
++#if defined(__FreeBSD__) && (defined(__i386__) || defined(__amd64__))
+ fpsetmask(0);
+#endif
world = BCgetWorld ( );
diff --git a/games/glasteroids/pkg-plist b/games/glasteroids/pkg-plist
index 5a79f4c36d7d..474f7c557824 100644
--- a/games/glasteroids/pkg-plist
+++ b/games/glasteroids/pkg-plist
@@ -1,12 +1,11 @@
bin/glasteroids
-%%PORTDOCS%%share/doc/glasteroids/COPYING
-%%PORTDOCS%%share/doc/glasteroids/README
-share/glasteroids/gameText.txf
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/gameText.txf
@mode 666
-share/glasteroids/scores.txt
+%%DATADIR%%/scores.txt
@mode
-share/glasteroids/textures/splash.raw
-share/glasteroids/textures/splash_non.raw
-@dirrm share/doc/glasteroids
-@dirrm share/glasteroids/textures
-@dirrm share/glasteroids
+%%DATADIR%%/textures/splash.raw
+%%DATADIR%%/textures/splash_non.raw
+@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/textures
+@dirrm %%DATADIR%%