aboutsummaryrefslogtreecommitdiff
path: root/games/glaxium
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-25 09:31:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-25 09:31:31 +0000
commitb6948d866feb46add587613097d9061b4c3c0999 (patch)
tree3838687a4b6fe06912040f24fa8e96117d287089 /games/glaxium
parentc48a12df40bb371b978a026ad076c6c4ded9e133 (diff)
downloadports-b6948d866feb46add587613097d9061b4c3c0999.tar.gz
ports-b6948d866feb46add587613097d9061b4c3c0999.zip
Notes
Diffstat (limited to 'games/glaxium')
-rw-r--r--games/glaxium/Makefile4
-rw-r--r--games/glaxium/files/patch-scene.cpp11
-rw-r--r--games/glaxium/files/patch-variables.cpp10
3 files changed, 24 insertions, 1 deletions
diff --git a/games/glaxium/Makefile b/games/glaxium/Makefile
index 20eb03c3540b..b316fb519e4a 100644
--- a/games/glaxium/Makefile
+++ b/games/glaxium/Makefile
@@ -7,7 +7,7 @@
PORTNAME= glaxium
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://xhosxe.free.fr/glaxium/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -27,6 +27,8 @@ ALL_TARGET= ${PORTNAME}
MAN6= glaxium.6
+USE_DOS2UNIX=variables.cpp scene.cpp
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g; \
s|/games/glaxium|/glaxium|g' ${WRKSRC}/configure
diff --git a/games/glaxium/files/patch-scene.cpp b/games/glaxium/files/patch-scene.cpp
new file mode 100644
index 000000000000..3b55656d3d70
--- /dev/null
+++ b/games/glaxium/files/patch-scene.cpp
@@ -0,0 +1,11 @@
+--- ./scene.cpp.orig Thu Oct 10 16:57:58 2002
++++ ./scene.cpp Sat Jul 21 17:54:40 2007
+@@ -2361,7 +2361,7 @@
+ oldTimer = newTimer;
+ globalList->move() ;
+ #ifndef PI
+-#define PI=3.151592653589793
++#define PI=3.141592653589793
+ #endif
+ benchFrames++;
+
diff --git a/games/glaxium/files/patch-variables.cpp b/games/glaxium/files/patch-variables.cpp
new file mode 100644
index 000000000000..f0bc977ada98
--- /dev/null
+++ b/games/glaxium/files/patch-variables.cpp
@@ -0,0 +1,10 @@
+--- ./variables.cpp.orig Fri Oct 18 01:53:00 2002
++++ ./variables.cpp Sat Jul 21 17:51:10 2007
+@@ -453,6 +453,7 @@
+ static char strReturn[1024];
+ strcpy(strReturn, getenv("HOME"));
+ strcat(strReturn, "~/.glaxiumrc");
++ return strReturn;
+ #endif
+ }
+