aboutsummaryrefslogtreecommitdiff
path: root/games/glbsp
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-23 09:55:33 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-23 09:55:33 +0000
commit85f87a32fc26d5c1a3f286895996662c9480f7c6 (patch)
tree5e9710019a380050bbadb486b326345aaa992837 /games/glbsp
parentfdd8b072a2319c5ec9ddb73706bf93c91dfe2024 (diff)
downloadports-85f87a32fc26d5c1a3f286895996662c9480f7c6.tar.gz
ports-85f87a32fc26d5c1a3f286895996662c9480f7c6.zip
Notes
Diffstat (limited to 'games/glbsp')
-rw-r--r--games/glbsp/Makefile66
-rw-r--r--games/glbsp/distinfo1
-rw-r--r--games/glbsp/files/patch-cmdline-makefile.unx13
-rw-r--r--games/glbsp/files/patch-fltk-makefile.unx24
-rw-r--r--games/glbsp/pkg-descr13
-rw-r--r--games/glbsp/pkg-plist5
6 files changed, 122 insertions, 0 deletions
diff --git a/games/glbsp/Makefile b/games/glbsp/Makefile
new file mode 100644
index 000000000000..b5fba2efe378
--- /dev/null
+++ b/games/glbsp/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: glbsp
+# Date created: 22 Jan 2004
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glbsp
+PORTVERSION= 2.05
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_src_${PORTVERSION:S/.//}
+
+MAINTAINER= tiamat@comset.net
+COMMENT= BSP node builder for OpenGL ports of the DOOM game engine
+
+.ifdef (WITH_GUI_VERSION)
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+.endif
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.if !defined (WITH_GUI_VERSION)
+PLIST_SUB= GUI_VERSION="@comment "
+.else
+PLIST_SUB= GUI_VERSION=""
+.endif
+
+.ifndef (WITH_GUI_VERSION)
+pre-everything::
+ @${ECHO_CMD} "***********************************************************"
+ @${ECHO_CMD} "Define WITH_GUI_VERSION=yes to build FLTK based GUI version"
+ @${ECHO_CMD} "***********************************************************"
+.endif
+
+.ifdef (WITH_GUI_VERSION)
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%FLTK_CONFIG%%|${X11BASE}\/bin\/fltk-config|g' \
+ ${WRKSRC}/fltk/makefile.unx
+.endif
+
+do-build:
+ ${SETENV} CC=${CC} "CFLAGS=${CFLAGS}" \
+ ${GMAKE} -C ${WRKSRC}/cmdline -f makefile.unx all
+.ifdef (WITH_GUI_VERSION)
+ ${SETENV} CC=${CC} CXX=${CXX} "CFLAGS=${CFLAGS}" "CXXFLAGS=${CXXFLAGS}" \
+ ${GMAKE} -C ${WRKSRC}/fltk -f makefile.unx all
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cmdline/glbsp ${PREFIX}/bin
+.ifdef (WITH_GUI_VERSION)
+ ${INSTALL_PROGRAM} ${WRKSRC}/fltk/glBSPX ${PREFIX}/bin
+.endif
+
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/USAGE.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/glbsp/distinfo b/games/glbsp/distinfo
new file mode 100644
index 000000000000..9b48a7245446
--- /dev/null
+++ b/games/glbsp/distinfo
@@ -0,0 +1 @@
+MD5 (glbsp_src_205.tar.gz) = fd6779afb5fb8ffe5f266fe038584ac9
diff --git a/games/glbsp/files/patch-cmdline-makefile.unx b/games/glbsp/files/patch-cmdline-makefile.unx
new file mode 100644
index 000000000000..6e96f89e26f0
--- /dev/null
+++ b/games/glbsp/files/patch-cmdline-makefile.unx
@@ -0,0 +1,13 @@
+--- cmdline/makefile.unx.orig Thu Jan 22 12:16:08 2004
++++ cmdline/makefile.unx Thu Jan 22 12:18:10 2004
+@@ -8,8 +8,8 @@
+
+ PROGNAME=glbsp
+
+-CC=cc
+-CFLAGS=-O3 -Wall -DGLBSP_TEXT -DUNIX -DINLINE_G=inline
++CC?=gcc
++CFLAGS+=-O3 -Wall -DGLBSP_TEXT -DUNIX -DINLINE_G=inline
+ LIBS=-lm
+
+ OBJS=$(SYSDIR)/main.o \
diff --git a/games/glbsp/files/patch-fltk-makefile.unx b/games/glbsp/files/patch-fltk-makefile.unx
new file mode 100644
index 000000000000..1110fa178986
--- /dev/null
+++ b/games/glbsp/files/patch-fltk-makefile.unx
@@ -0,0 +1,24 @@
+--- fltk/makefile.unx.orig Thu Jan 22 12:32:28 2004
++++ fltk/makefile.unx Thu Jan 22 12:35:18 2004
+@@ -8,14 +8,14 @@
+
+ PROGNAME=glBSPX
+
+-FLTK_CFLAGS=-I/usr/local/lib
+-FLTK_LIBS=-lfltk_images -lfltk -lX11 -lXext -lpng -ljpeg
++FLTK_CFLAGS=`%%FLTK_CONFIG%% --cflags`
++FLTK_LIBS=`%%FLTK_CONFIG%% --ldflags` -lfltk_images
+
+-CC=gcc
+-CXX=g++
+-CFLAGS=-O2 -Wall -DGLBSP_GUI -DUNIX -DINLINE_G=inline $(FLTK_CFLAGS)
+-CXXFLAGS=$(CFLAGS)
+-LDFLAGS=-L/usr/X11R6/lib
++CC?=gcc
++CXX?=g++
++CFLAGS+=-O2 -Wall -DGLBSP_GUI -DUNIX -DINLINE_G=inline $(FLTK_CFLAGS)
++CXXFLAGS+=$(CFLAGS)
++LDFLAGS=-L${X11BASE}/lib
+ LIBS=-lm $(FLTK_LIBS)
+
+ OBJS=$(SYSDIR)/main.o \
diff --git a/games/glbsp/pkg-descr b/games/glbsp/pkg-descr
new file mode 100644
index 000000000000..3ec51f311dd9
--- /dev/null
+++ b/games/glbsp/pkg-descr
@@ -0,0 +1,13 @@
+glBSP is a node builder specially designed to be used with OpenGL
+ports of the DOOM game engine. It adheres to the "GL-Friendly Nodes"
+specification, which means it adds some new special nodes to a WAD
+file that makes it very easy (and fast !) for an OpenGL DOOM engine to
+compute the polygons needed for drawing the levels.
+There are many DOOM ports that understand the GL Nodes which glBSP
+creates, including: EDGE, the Doomsday engine (JDOOM), Doom3D, PrBoom,
+and Vavoom.
+
+WWW: http://glbsp.sourceforge.net/
+
+- Igor Pokrovsky
+tiamat@comset.net
diff --git a/games/glbsp/pkg-plist b/games/glbsp/pkg-plist
new file mode 100644
index 000000000000..dc7ad49a8069
--- /dev/null
+++ b/games/glbsp/pkg-plist
@@ -0,0 +1,5 @@
+bin/glbsp
+%%GUI_VERSION%%bin/glBSPX
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/USAGE.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%