aboutsummaryrefslogtreecommitdiff
path: root/games/glest
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-03-28 00:06:32 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-03-28 00:06:32 +0000
commit8d5141a34cba5f05a8c602797bb034ff0a456d48 (patch)
tree9ba51f6fceca0ce7634a6b5e61f0a0b56c6557f4 /games/glest
parent88445dcbc8c7b07adbdea10c7d5a50130c84058d (diff)
downloadports-8d5141a34cba5f05a8c602797bb034ff0a456d48.tar.gz
ports-8d5141a34cba5f05a8c602797bb034ff0a456d48.zip
Notes
Diffstat (limited to 'games/glest')
-rw-r--r--games/glest/Makefile37
-rw-r--r--games/glest/distinfo6
-rw-r--r--games/glest/files/glest-wrapper.in2
-rw-r--r--games/glest/files/patch-mk__linux__autogen.sh4
-rw-r--r--games/glest/files/pkg-message.in10
-rw-r--r--games/glest/pkg-plist1
6 files changed, 39 insertions, 21 deletions
diff --git a/games/glest/Makefile b/games/glest/Makefile
index f875412bece1..9a119adbba3a 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= glest
-PORTVERSION= 2.0.1
-PORTREVISION= 3
+PORTVERSION= 3.1.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}_source_${PORTVERSION}
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
@@ -25,37 +24,43 @@ BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
RUN_DEPENDS= ${DATADIR}/configuration.xml:${PORTSDIR}/games/glest-data
USE_AUTOTOOLS= automake:15:env autoconf:261:env
-USE_ZIP= yes
+USE_BZIP2= yes
USE_DOS2UNIX= yes
-USE_GCC= 3.2+
USE_SDL= yes
USE_GL= yes
GNU_CONFIGURE= yes
-CONFIGURE_SCRIPT= mk/linux/configure
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-EXTRACT_AFTER_ARGS= -d ${WRKSRC}
SUB_FILES= glest-wrapper pkg-message
JAM_CMD= ${LOCALBASE}/bin/jam -qa
+OPTIONS= EDITOR "Build map editor" off
+
.include <bsd.port.pre.mk>
-pre-extract:
- @${MKDIR} ${WRKSRC}
+.if defined(WITH_EDITOR)
+USE_WX= 2.6+
+WX_CONF_ARGS= relative
+WANT_UNICODE= yes
+PLIST_SUB+= EDITOR=""
+HAVE_EDITOR= true
+.else
+PLIST_SUB+= EDITOR="@comment "
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|%%ACLOCAL%%|${ACLOCAL}|g" -e "s|%%AUTOCONF%%|${AUTOCONF}|g" \
- ${WRKSRC}/mk/linux/autogen.sh
+ ${WRKSRC}/autogen.sh
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|PTHREAD_LIBS="-l[$$]flag"|PTHREAD_LIBS="${PTHREAD_LIBS}"|g ; \
s|pthreads library -l[$$]flag|pthreads library ${PTHREAD_LIBS}|g' \
- ${WRKSRC}/mk/linux/configure.ac ${WRKSRC}/mk/linux/mk/autoconf/*
+ ${WRKSRC}/configure.ac ${WRKSRC}/mk/autoconf/*
@${FIND} -E ${WRKDIR} -type f -name '*.bak' -o -name '*.orig' | ${XARGS} ${RM}
pre-configure:
- @cd ${WRKSRC}/mk/linux && ${SH} autogen.sh
+ @cd ${WRKSRC} && ${SH} autogen.sh
do-build:
@cd ${WRKSRC} && ${JAM_CMD}
@@ -63,13 +68,17 @@ do-build:
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/license.txt ${DOCSDIR}/license-game.txt
+ ${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}/license-game.txt
.endif
@${MKDIR} ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/glest ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/mk/linux/glest.ini ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/glest.ini ${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/glest-wrapper ${PREFIX}/bin/${PORTNAME}
+.if defined(HAVE_EDITOR)
+ ${INSTALL_PROGRAM} ${WRKSRC}/glest_editor ${PREFIX}/bin/
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/games/glest/distinfo b/games/glest/distinfo
index 8668195e3eb8..d30d7721c362 100644
--- a/games/glest/distinfo
+++ b/games/glest/distinfo
@@ -1,3 +1,3 @@
-MD5 (glest/glest_source_2.0.1.zip) = 2d35a5d08331957f63240cadc9766b75
-SHA256 (glest/glest_source_2.0.1.zip) = f476665f374537def35ebd7737b7fa8940ef9f014cfabd5fbbd50a4c647b42b2
-SIZE (glest/glest_source_2.0.1.zip) = 510653
+MD5 (glest/glest-source-3.1.2.tar.bz2) = e72ec79dacdf7ff5a27c2f5b74ffc01e
+SHA256 (glest/glest-source-3.1.2.tar.bz2) = bc96a78dd86f240568d230fd4dd6b69bca8922ba673b4d1138e09d1ad88fbfdf
+SIZE (glest/glest-source-3.1.2.tar.bz2) = 388086
diff --git a/games/glest/files/glest-wrapper.in b/games/glest/files/glest-wrapper.in
index 964fcb7a808d..7bc6873afc5b 100644
--- a/games/glest/files/glest-wrapper.in
+++ b/games/glest/files/glest-wrapper.in
@@ -16,8 +16,10 @@ else
mkdir -p ~/.glest/shaders/standard
touch ~/.glest/glest.log
rm ~/.glest/glest.ini ~/.glest/configuration.xml ~/.glest/glest
+ rm ~/.glest/servers.ini
cp -f %%DATADIR%%/configuration.xml ~/.glest/
cp -f %%DATADIR%%/glest.ini ~/.glest/
+ cp -f %%DATADIR%%/servers.ini ~/.glest/
fi
cd ~/.glest || exit 1
diff --git a/games/glest/files/patch-mk__linux__autogen.sh b/games/glest/files/patch-mk__linux__autogen.sh
index 570f404547a5..ec4f473eed6d 100644
--- a/games/glest/files/patch-mk__linux__autogen.sh
+++ b/games/glest/files/patch-mk__linux__autogen.sh
@@ -1,5 +1,5 @@
---- mk/linux/autogen.sh.orig Thu Dec 1 09:52:33 2005
-+++ mk/linux/autogen.sh Thu Dec 1 09:53:14 2005
+--- autogen.sh.orig Thu Dec 1 09:52:33 2005
++++ autogen.sh Thu Dec 1 09:53:14 2005
@@ -8,11 +8,11 @@
echo "aclocal..."
diff --git a/games/glest/files/pkg-message.in b/games/glest/files/pkg-message.in
index 6cda4f748b37..205beef5c32b 100644
--- a/games/glest/files/pkg-message.in
+++ b/games/glest/files/pkg-message.in
@@ -3,8 +3,14 @@
The glest game was installed
1) You can see the glest configuration files into your ~/.glest directory
-2) If you have problems to run glest, please you should remove your ~/glest
+
+2) If you choose install glest map editor, you can run it using :
+
+ # glest_editor
+
+3) If you have problems to run glest, please you should remove your ~/glest
directory and try again
-3) Enjoy it ;)
+
+4) Enjoy it ;)
###############################################################################
diff --git a/games/glest/pkg-plist b/games/glest/pkg-plist
index ffd80e1c97cd..1219a76aaad8 100644
--- a/games/glest/pkg-plist
+++ b/games/glest/pkg-plist
@@ -1,4 +1,5 @@
bin/glest
+%%EDITOR%%bin/glest_editor
%%DATADIR%%/glest
%%DATADIR%%/glest.ini
%%PORTDOCS%%%%DOCSDIR%%/license-game.txt