aboutsummaryrefslogtreecommitdiff
path: root/games/glmaze
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-06-06 03:18:22 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-06-06 03:18:22 +0000
commit98429e0a05632846624ddd353338fbd409e4558b (patch)
treec491bdb60949504836e60aaba33c553cbd03aef9 /games/glmaze
parenta4e862af1a27a56ce8f7fde60753082c1712f63c (diff)
downloadports-98429e0a05632846624ddd353338fbd409e4558b.tar.gz
ports-98429e0a05632846624ddd353338fbd409e4558b.zip
Notes
Diffstat (limited to 'games/glmaze')
-rw-r--r--games/glmaze/Makefile27
-rw-r--r--games/glmaze/distinfo1
-rw-r--r--games/glmaze/files/patch-Makefile36
-rw-r--r--games/glmaze/files/patch-shot.c10
-rw-r--r--games/glmaze/files/patch-sound.c11
-rw-r--r--games/glmaze/pkg-descr6
-rw-r--r--games/glmaze/pkg-plist51
7 files changed, 142 insertions, 0 deletions
diff --git a/games/glmaze/Makefile b/games/glmaze/Makefile
new file mode 100644
index 000000000000..5c19edb61038
--- /dev/null
+++ b/games/glmaze/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: glmaze
+# Date created: 5 June 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= glmaze
+PORTVERSION= 1.1a
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Multiplayer OpenGL Maze Game
+
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+MAN1= glmaze.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/shot.c
+
+.include <bsd.port.mk>
diff --git a/games/glmaze/distinfo b/games/glmaze/distinfo
new file mode 100644
index 000000000000..dc7d10848283
--- /dev/null
+++ b/games/glmaze/distinfo
@@ -0,0 +1 @@
+MD5 (glmaze-1.1a.tar.gz) = 7d0fd464b84767726f9fdc1c3dbcf4fe
diff --git a/games/glmaze/files/patch-Makefile b/games/glmaze/files/patch-Makefile
new file mode 100644
index 000000000000..b8ad19757aa4
--- /dev/null
+++ b/games/glmaze/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig Wed Jan 23 06:44:46 2002
++++ Makefile Thu Jun 5 19:54:58 2003
+@@ -2,16 +2,16 @@
+
+ VERSION = "1.1a"
+
+-DESTPATH = /usr/local
++DESTPATH = ${PREFIX}
+ BINPATH = $(DESTPATH)/bin
+-GAMEPATH = $(DESTPATH)/games/glMaze
++GAMEPATH = $(DESTPATH)/share/glmaze
+ MANPATH = $(DESTPATH)/man/man1
+
+ OBJECTS = load_maze.o main.o controls.o shot.o player.o net.o \
+ username.o radar.o prefs.o sound.o
+
+-SDL_FLAGS=`sdl-config --cflags`
+-SDL_LIBS=`sdl-config --libs`
++SDL_FLAGS=`sdl11-config --cflags`
++SDL_LIBS=`sdl11-config --libs`
+
+ # comment the follwing if you don't want sound
+ CC += -DSOUND
+@@ -31,10 +31,10 @@
+ prefs.o: prefs.c maze.h
+
+ .c.o:
+- $(CC) -DVERSION=\"$(VERSION)\" $(SDL_FLAGS) -c -o $@ $<
++ $(CC) -I${X11BASE}/include -DVERSION=\"$(VERSION)\" $(SDL_FLAGS) -c -o $@ $<
+
+ glmaze: $(OBJECTS)
+- $(CC) $(OBJECTS) -o $@ $(SDL_LIBS) -lGL -lGLU -lm
++ $(CC) $(OBJECTS) -o $@ -L${X11BASE}/lib $(SDL_LIBS) -lGL -lGLU -lm
+
+ clean:
+ @echo Cleaning up...
diff --git a/games/glmaze/files/patch-shot.c b/games/glmaze/files/patch-shot.c
new file mode 100644
index 000000000000..7330ae2f4aed
--- /dev/null
+++ b/games/glmaze/files/patch-shot.c
@@ -0,0 +1,10 @@
+--- shot.c.orig Thu Jun 5 19:55:39 2003
++++ shot.c Thu Jun 5 19:56:34 2003
+@@ -47,6 +47,7 @@
+ "/usr/games/glmaze/",
+ "/usr/local/games/glMaze/",
+ "/usr/local/games/glmaze/",
++ "%%PREFIX%%/share/glmaze/",
+ "./",
+ ""
+ };
diff --git a/games/glmaze/files/patch-sound.c b/games/glmaze/files/patch-sound.c
new file mode 100644
index 000000000000..ab3771b21533
--- /dev/null
+++ b/games/glmaze/files/patch-sound.c
@@ -0,0 +1,11 @@
+--- sound.c.orig Thu Jun 5 19:49:36 2003
++++ sound.c Thu Jun 5 19:50:22 2003
+@@ -18,7 +18,7 @@
+ #include "maze.h"
+
+ #ifdef SOUND
+-#include <SDL/SDL_mixer.h>
++#include <SDL_mixer.h>
+ Mix_Chunk *sound[5];
+ Mix_Music *music;
+ #endif
diff --git a/games/glmaze/pkg-descr b/games/glmaze/pkg-descr
new file mode 100644
index 000000000000..3440500be36f
--- /dev/null
+++ b/games/glmaze/pkg-descr
@@ -0,0 +1,6 @@
+glMaze is a multiplayer OpenGL maze game. Up to six players hunt
+each other online in a real 3-D maze.
+
+WWW: http://glmaze.sourceforge.net
+
+-Adam Weinberger <adamw@FreeBSD.org>
diff --git a/games/glmaze/pkg-plist b/games/glmaze/pkg-plist
new file mode 100644
index 000000000000..2f0d57ece9cc
--- /dev/null
+++ b/games/glmaze/pkg-plist
@@ -0,0 +1,51 @@
+bin/glmaze
+share/glmaze/data/Font.bmp
+share/glmaze/data/Star.bmp
+share/glmaze/data/bar.bmp
+share/glmaze/data/crosshair.bmp
+share/glmaze/data/hit1.bmp
+share/glmaze/data/hit2.bmp
+share/glmaze/data/hit3.bmp
+share/glmaze/data/hit4.bmp
+share/glmaze/data/hit5.bmp
+share/glmaze/data/master.bmp
+share/glmaze/data/paused.bmp
+share/glmaze/data/radar.bmp
+share/glmaze/data/shield.bmp
+share/glmaze/data/slave.bmp
+share/glmaze/data/smiley_b.bmp
+share/glmaze/data/smiley_b_icon.bmp
+share/glmaze/data/smiley_c.bmp
+share/glmaze/data/smiley_c_icon.bmp
+share/glmaze/data/smiley_g.bmp
+share/glmaze/data/smiley_g_icon.bmp
+share/glmaze/data/smiley_m.bmp
+share/glmaze/data/smiley_m_icon.bmp
+share/glmaze/data/smiley_r.bmp
+share/glmaze/data/smiley_r_icon.bmp
+share/glmaze/data/smiley_y.bmp
+share/glmaze/data/smiley_y_icon.bmp
+share/glmaze/levels/369.maz
+share/glmaze/levels/brick_b.bmp
+share/glmaze/levels/brick_c.bmp
+share/glmaze/levels/brick_d.bmp
+share/glmaze/levels/brick_g.bmp
+share/glmaze/levels/brick_m.bmp
+share/glmaze/levels/brick_r.bmp
+share/glmaze/levels/brick_y.bmp
+share/glmaze/levels/bricks.bmp
+share/glmaze/levels/complex.maz
+share/glmaze/levels/crate.bmp
+share/glmaze/levels/empty.maz
+share/glmaze/levels/floor1.bmp
+share/glmaze/levels/maze.maz
+share/glmaze/sounds/button.wav
+share/glmaze/sounds/hit.wav
+share/glmaze/sounds/kill.wav
+share/glmaze/sounds/music.mod
+share/glmaze/sounds/shot.wav
+share/glmaze/sounds/wall.wav
+@dirrm share/glmaze/sounds
+@dirrm share/glmaze/levels
+@dirrm share/glmaze/data
+@dirrm share/glmaze