aboutsummaryrefslogtreecommitdiff
path: root/games/glmaze
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-01 12:56:41 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-01 12:56:41 +0000
commit53566686ec4e1c4d6dcc746db1024343170c491d (patch)
tree570f3132183c2a804dacfb4ae7dbd09795f1a05a /games/glmaze
parenta6383cf6b518bd966957825741ae9aadce5ba6b8 (diff)
downloadports-53566686ec4e1c4d6dcc746db1024343170c491d.tar.gz
ports-53566686ec4e1c4d6dcc746db1024343170c491d.zip
Notes
Diffstat (limited to 'games/glmaze')
-rw-r--r--games/glmaze/Makefile35
-rw-r--r--games/glmaze/distinfo2
-rw-r--r--games/glmaze/files/patch-Makefile26
-rw-r--r--games/glmaze/pkg-descr11
-rw-r--r--games/glmaze/pkg-plist53
5 files changed, 105 insertions, 22 deletions
diff --git a/games/glmaze/Makefile b/games/glmaze/Makefile
index 6fd9d2505192..ce1d716815cc 100644
--- a/games/glmaze/Makefile
+++ b/games/glmaze/Makefile
@@ -3,22 +3,43 @@
PORTNAME= glmaze
PORTVERSION= 1.1a
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Multiplayer OpenGL Maze Game
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
USE_GL= gl
USE_SDL= mixer sdl
-WRKSRC= ${WRKDIR}/${PORTNAME}
+CFLAGS+= -w
+
+PORTDOCS= readme.txt
-PLIST_FILES= bin/${PORTNAME} \
- man/man1/glmaze.1.gz
-PORTDATA= *
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="glMaze" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+post-extract:
+ @(cd ${WRKSRC} && ${MV} ${PORTNAME}.1 ${PORTNAME}.6)
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/shot.c
+post-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/games/glmaze/distinfo b/games/glmaze/distinfo
index 831db17031ee..aadc8308309e 100644
--- a/games/glmaze/distinfo
+++ b/games/glmaze/distinfo
@@ -1,2 +1,4 @@
SHA256 (glmaze-1.1a.tar.gz) = 39cdb8a3231f03d56f3583f6ad306f9c180112de8ce9fb26db5ebbb1d6ac5037
SIZE (glmaze-1.1a.tar.gz) = 588179
+SHA256 (glmaze.png) = 34facdd5f8c919ceab8fbdbfcac7becd60681e2c468a0ca4b31c6783d5119bca
+SIZE (glmaze.png) = 3632
diff --git a/games/glmaze/files/patch-Makefile b/games/glmaze/files/patch-Makefile
index e70560af55f9..c7b5e1777739 100644
--- a/games/glmaze/files/patch-Makefile
+++ b/games/glmaze/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Wed Jan 23 06:44:46 2002
-+++ Makefile Tue Jun 17 23:14:54 2003
-@@ -1,17 +1,17 @@
+--- ./Makefile.orig 2002-01-23 15:44:46.000000000 +0100
++++ ./Makefile 2014-02-01 12:41:16.000000000 +0100
+@@ -1,11 +1,11 @@
-CC = gcc -O2 -ffast-math -Wall
+#CC = gcc -O2 -ffast-math -Wall
@@ -10,19 +10,12 @@
+DESTPATH = ${DESTDIR}${PREFIX}
BINPATH = $(DESTPATH)/bin
-GAMEPATH = $(DESTPATH)/games/glMaze
+-MANPATH = $(DESTPATH)/man/man1
+GAMEPATH = $(DESTPATH)/share/glmaze
- MANPATH = $(DESTPATH)/man/man1
++MANPATH = $(DESTPATH)/man/man6
OBJECTS = load_maze.o main.o controls.o shot.o player.o net.o \
username.o radar.o prefs.o sound.o
-
--SDL_FLAGS=`sdl-config --cflags`
--SDL_LIBS=`sdl-config --libs`
-+SDL_FLAGS=`sdl-config --cflags`
-+SDL_LIBS=`sdl-config --libs`
-
- # comment the follwing if you don't want sound
- CC += -DSOUND
@@ -31,10 +31,10 @@
prefs.o: prefs.c maze.h
@@ -36,3 +29,12 @@
clean:
@echo Cleaning up...
+@@ -48,7 +48,7 @@
+
+ install: glmaze
+ install -s glmaze $(BINPATH)
+- install glmaze.1 $(MANPATH)
++ install glmaze.6 $(MANPATH)
+ install -d $(GAMEPATH)/data
+ install data/*.* $(GAMEPATH)/data
+ install -d $(GAMEPATH)/levels
diff --git a/games/glmaze/pkg-descr b/games/glmaze/pkg-descr
index a1e6f570308c..2e1405b43394 100644
--- a/games/glmaze/pkg-descr
+++ b/games/glmaze/pkg-descr
@@ -1,4 +1,9 @@
-glMaze is a multiplayer OpenGL maze game. Up to six players hunt
-each other online in a real 3-D maze.
+glMaze is a multiplayer maze game based on the opengl 3d graphics engine.
+If a command line argument is present, glmaze tries to interpret this as
+the server name to connect to. If no argument was given, glmaze becomes
+the master client and starts a local server. Up to six players can join
+a session. Only the master client can start the session. Other players
+can join a running game. The game stops when the first player reaches
+ten kills. The player with the top score at this moment is the winner.
-WWW: http://glmaze.sourceforge.net
+WWW: http://glmaze.sourceforge.net/
diff --git a/games/glmaze/pkg-plist b/games/glmaze/pkg-plist
new file mode 100644
index 000000000000..73a0f6c65f89
--- /dev/null
+++ b/games/glmaze/pkg-plist
@@ -0,0 +1,53 @@
+bin/glmaze
+man/man6/glmaze.6.gz
+share/glmaze/data/Font.bmp
+share/glmaze/data/Star.bmp
+share/glmaze/data/bar.bmp
+share/glmaze/data/crosshair.bmp
+share/glmaze/data/hit1.bmp
+share/glmaze/data/hit2.bmp
+share/glmaze/data/hit3.bmp
+share/glmaze/data/hit4.bmp
+share/glmaze/data/hit5.bmp
+share/glmaze/data/master.bmp
+share/glmaze/data/paused.bmp
+share/glmaze/data/radar.bmp
+share/glmaze/data/shield.bmp
+share/glmaze/data/slave.bmp
+share/glmaze/data/smiley_b.bmp
+share/glmaze/data/smiley_b_icon.bmp
+share/glmaze/data/smiley_c.bmp
+share/glmaze/data/smiley_c_icon.bmp
+share/glmaze/data/smiley_g.bmp
+share/glmaze/data/smiley_g_icon.bmp
+share/glmaze/data/smiley_m.bmp
+share/glmaze/data/smiley_m_icon.bmp
+share/glmaze/data/smiley_r.bmp
+share/glmaze/data/smiley_r_icon.bmp
+share/glmaze/data/smiley_y.bmp
+share/glmaze/data/smiley_y_icon.bmp
+share/glmaze/levels/369.maz
+share/glmaze/levels/brick_b.bmp
+share/glmaze/levels/brick_c.bmp
+share/glmaze/levels/brick_d.bmp
+share/glmaze/levels/brick_g.bmp
+share/glmaze/levels/brick_m.bmp
+share/glmaze/levels/brick_r.bmp
+share/glmaze/levels/brick_y.bmp
+share/glmaze/levels/bricks.bmp
+share/glmaze/levels/complex.maz
+share/glmaze/levels/crate.bmp
+share/glmaze/levels/empty.maz
+share/glmaze/levels/floor1.bmp
+share/glmaze/levels/maze.maz
+share/glmaze/sounds/button.wav
+share/glmaze/sounds/hit.wav
+share/glmaze/sounds/kill.wav
+share/glmaze/sounds/music.mod
+share/glmaze/sounds/shot.wav
+share/glmaze/sounds/wall.wav
+share/pixmaps/glmaze.png
+@dirrm share/glmaze/sounds
+@dirrm share/glmaze/levels
+@dirrm share/glmaze/data
+@dirrm share/glmaze