aboutsummaryrefslogtreecommitdiff
path: root/games/glob2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-03-02 18:06:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-03-02 18:06:29 +0000
commitad925cac3ab4598de293d6ff733e79d0d401f7d3 (patch)
tree3109a9cb4c3eb79167377d4e7763979f74048b2f /games/glob2/Makefile
parent53f0ccb1b9eb62ea84c7a9b7f9b1a64f803a331c (diff)
Notes
Diffstat (limited to 'games/glob2/Makefile')
-rw-r--r--games/glob2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index ea71bfae044d..8e675173e32b 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glob2
-PORTVERSION= 0.9.3
+PORTVERSION= 0.9.4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -19,15 +19,21 @@ LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
speex.1:${PORTSDIR}/audio/speex \
fribidi.0:${PORTSDIR}/converters/fribidi\
freetype.9:${PORTSDIR}/print/freetype2
+# Should work with portaudio v19_20071207
+# Can be built with portaudio2 but does not run cleanly
+#LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
USE_SDL= image net sdl ttf
USE_GL= gl
USE_GMAKE= yes
USE_SCONS= yes
+#SCONS_ARGS= --portaudio=true
INSTALLS_ICONS= yes
SCONS_BUILDENV= ${SCONS_ENV}
+#CFLAGS+= ${PTHREAD_CFLAGS} -I. `pkg-config --cflags portaudio-2.0` -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS} -I. -I${LOCALBASE}/include
+#LINKFLAGS= ${PTHREAD_LIBS} `pkg-config --libs portaudio-2.0` -L${LOCALBASE}/lib
LINKFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
.include <bsd.port.pre.mk>