aboutsummaryrefslogtreecommitdiff
path: root/games/glob2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-02-18 09:45:51 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-02-18 09:45:51 +0000
commit85a9aebd198aa34932c0a829b96da8ab56af2a07 (patch)
treeb77df66d92bb1e407695054614cdce4d92f2f79c /games/glob2/Makefile
parent6bc43465095b7389b9a24b6a76df9651cea7bbdb (diff)
Notes
Diffstat (limited to 'games/glob2/Makefile')
-rw-r--r--games/glob2/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index eda7baa027f4..d3fed7765fe9 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -6,40 +6,46 @@
#
PORTNAME= glob2
-PORTVERSION= 0.8.17
+PORTVERSION= 0.8.18
CATEGORIES= games
MASTER_SITES= http://epfl.ysagoon.com/~glob2/data/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Globulation 2 - a free and innovative strategy game
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/rational.hpp:${PORTSDIR}/devel/boost
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
speex.3:${PORTSDIR}/audio/speex \
freetype.9:${PORTSDIR}/print/freetype2
-USE_SDL= image net sdl
+USE_SDL= image net sdl ttf
USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
-USE_GCC= 3.4
-USE_REINPLACE= yes
-
-PLIST_FILES= bin/glob2
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile with gcc-2.95
+.endif
+
.if ${ARCH} == "alpha"
-BROKEN= "Does not build on alpha"
+BROKEN= Does not build on ${ARCH}
.endif
pre-configure:
- @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" \
+ ${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s|Icon=|Icon=${DATADIR}/|" \
+ ${WRKSRC}/data/glob2.desktop
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/glob2 ${PREFIX}/bin
+ ${MKDIR} ${DATADIR} ${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/glob2.desktop ${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/icons/glob2-icon-48x48.png ${DATADIR}
post-install:
@${ECHO_MSG}