aboutsummaryrefslogtreecommitdiff
path: root/games/glob2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-09-06 21:08:35 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-09-06 21:08:35 +0000
commitea84f08bac8409ff118c68e43a8591408841aa46 (patch)
treea2cf93ed97eed2a46a9605ff6bb97ca7e454db99 /games/glob2
parent40f22eeeba6fe666cc74ba369635bde5323a867b (diff)
downloadports-ea84f08bac8409ff118c68e43a8591408841aa46.tar.gz
ports-ea84f08bac8409ff118c68e43a8591408841aa46.zip
Notes
Diffstat (limited to 'games/glob2')
-rw-r--r--games/glob2/Makefile20
-rw-r--r--games/glob2/distinfo6
-rw-r--r--games/glob2/files/glob2.desktop11
-rw-r--r--games/glob2/files/patch-SConstruct9
-rw-r--r--games/glob2/files/patch-data_icons_Makefile.in11
-rw-r--r--games/glob2/pkg-plist41
6 files changed, 53 insertions, 45 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index 6abac66914b5..847fc1cbcd05 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= glob2
-PORTVERSION= 0.8.23
-PORTREVISION= 2
+PORTVERSION= 0.9.1
CATEGORIES= games
MASTER_SITES= http://dl.sv.nongnu.org/releases/glob2/${PORTVERSION}/
MASTER_SITE_SUBDIR= thierry
@@ -24,10 +23,10 @@ LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
USE_SDL= image net sdl ttf
USE_GL= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
+USE_SCONS= yes
+SCONS_BUILDENV= ${SCONS_ENV}
+LINKFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include
.include <bsd.port.pre.mk>
@@ -35,15 +34,10 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/
BROKEN= Does not build on ${ARCH}
.endif
-pre-configure:
- ${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" \
- ${WRKSRC}/configure
- ${REINPLACE_CMD} -e "s|Icon=|Icon=${DATADIR}/pixmaps/|; \
- s|x48|x48.png|" ${WRKSRC}/data/glob2.desktop
+pre-install:
+ ${CP} ${FILESDIR}/glob2.desktop ${WRKSRC}/data/
post-install:
- ${MKDIR} ${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKSRC}/data/glob2.desktop ${DESKTOPDIR}
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/games/glob2/distinfo b/games/glob2/distinfo
index e0ddcf90a4fa..cb54ee23d35a 100644
--- a/games/glob2/distinfo
+++ b/games/glob2/distinfo
@@ -1,3 +1,3 @@
-MD5 (glob2-0.8.23.tar.gz) = d8807da21fc32db1727dd62b8d5c786a
-SHA256 (glob2-0.8.23.tar.gz) = 4d6e0ae73a4e0fda33cb5a344d678f379ad177c886f1730268eec27158aeaff1
-SIZE (glob2-0.8.23.tar.gz) = 9845036
+MD5 (glob2-0.9.1.tar.gz) = 172d9becf087ffea4eda003307507260
+SHA256 (glob2-0.9.1.tar.gz) = 4924586e1f1eb683775db8b22fc18c39f38c60b1bf4ffc59bd99cd82c0654c14
+SIZE (glob2-0.9.1.tar.gz) = 10080422
diff --git a/games/glob2/files/glob2.desktop b/games/glob2/files/glob2.desktop
new file mode 100644
index 000000000000..8f757300d3b1
--- /dev/null
+++ b/games/glob2/files/glob2.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Globulation 2
+Comment=An innovative new strategy game
+Exec=glob2
+Icon=/usr/local/share/glob2/data/icons/glob2-icon-48x48.png
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=Application;Game;StrategyGame;
diff --git a/games/glob2/files/patch-SConstruct b/games/glob2/files/patch-SConstruct
new file mode 100644
index 000000000000..876a38fd0cc5
--- /dev/null
+++ b/games/glob2/files/patch-SConstruct
@@ -0,0 +1,9 @@
+--- SConstruct.orig Sun Sep 2 05:14:53 2007
++++ SConstruct Tue Sep 4 23:02:18 2007
+@@ -1,5 +1,6 @@
+ def establish_options(env):
+ opts = Options('options_cache.py')
++ opts.Add("CCFLAGS", "Manually add to the CCFLAGS", "")
+ opts.Add("CXXFLAGS", "Manually add to the CXXFLAGS", "-g")
+ opts.Add("LINKFLAGS", "Manually add to the LINKFLAGS", "")
+ opts.Add("INSTALLDIR", "Installation Directory", "/usr/local/share")
diff --git a/games/glob2/files/patch-data_icons_Makefile.in b/games/glob2/files/patch-data_icons_Makefile.in
deleted file mode 100644
index 98e49e0b30b6..000000000000
--- a/games/glob2/files/patch-data_icons_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./data/icons/Makefile.in.orig Fri Aug 4 20:39:55 2006
-+++ ./data/icons/Makefile.in Sat Aug 5 10:02:35 2006
-@@ -168,7 +168,7 @@
- target_cpu = @target_cpu@
- target_os = @target_os@
- target_vendor = @target_vendor@
--glob2icondir = $(datadir)/pixmaps
-+glob2icondir = $(pkgdatadir)/pixmaps
- glob2icon_DATA = $(wildcard $(srcdir)/*.png)
- EXTRA_DIST = $(glob2icon_DATA)
- all: all-am
diff --git a/games/glob2/pkg-plist b/games/glob2/pkg-plist
index 6f7e05ba8722..30c24653b041 100644
--- a/games/glob2/pkg-plist
+++ b/games/glob2/pkg-plist
@@ -1,13 +1,10 @@
bin/glob2
share/applications/glob2.desktop
-%%DATADIR%%/AUTHORS
-%%DATADIR%%/campaigns/Joey_mission_1.map
-%%DATADIR%%/campaigns/Joey_mission_2.map
-%%DATADIR%%/campaigns/Joey_mission_3.map
-%%DATADIR%%/campaigns/Joey_mission_4.map
-%%DATADIR%%/campaigns/Joey_mission_5.map
-%%DATADIR%%/campaigns/Joey_mission_6.map
-%%DATADIR%%/campaigns/Joey_mission_7.map
+%%DATADIR%%/campaigns/Tutorial_Campaign.txt
+%%DATADIR%%/campaigns/tutorial-part1.map
+%%DATADIR%%/campaigns/tutorial-part2.map
+%%DATADIR%%/campaigns/tutorial-part3.map
+%%DATADIR%%/campaigns/tutorial-part4.map
%%DATADIR%%/data/buildings.default.txt
%%DATADIR%%/data/buildings.txt
%%DATADIR%%/data/fonts/sans.ttf
@@ -1646,9 +1643,18 @@ share/applications/glob2.desktop
%%DATADIR%%/data/gui/editor9.png
%%DATADIR%%/data/gui/yog0.png
%%DATADIR%%/data/gui/yog1.png
+%%DATADIR%%/data/icons/glob2-icon-128x128.png
+%%DATADIR%%/data/icons/glob2-icon-16x16.png
+%%DATADIR%%/data/icons/glob2-icon-24x24.png
+%%DATADIR%%/data/icons/glob2-icon-32x32.png
+%%DATADIR%%/data/icons/glob2-icon-48x48.png
+%%DATADIR%%/data/icons/glob2-icon-64x64.png
+%%DATADIR%%/data/keyboard-gui.default.txt
+%%DATADIR%%/data/keyboard-mapedit.default.txt
%%DATADIR%%/data/pal.txt
%%DATADIR%%/data/ressources.txt
%%DATADIR%%/data/texts.ar.txt
+%%DATADIR%%/data/texts.br.txt
%%DATADIR%%/data/texts.ca.txt
%%DATADIR%%/data/texts.cz.txt
%%DATADIR%%/data/texts.de.txt
@@ -1658,6 +1664,7 @@ share/applications/glob2.desktop
%%DATADIR%%/data/texts.eu.txt
%%DATADIR%%/data/texts.fr.txt
%%DATADIR%%/data/texts.hu.txt
+%%DATADIR%%/data/texts.incomplete.txt
%%DATADIR%%/data/texts.it.txt
%%DATADIR%%/data/texts.keys.txt
%%DATADIR%%/data/texts.list.txt
@@ -1671,6 +1678,7 @@ share/applications/glob2.desktop
%%DATADIR%%/data/texts.sr.txt
%%DATADIR%%/data/texts.sv.txt
%%DATADIR%%/data/texts.tr.txt
+%%DATADIR%%/data/texts.zh-tw.txt
%%DATADIR%%/data/units.txt
%%DATADIR%%/data/unitsSkins.txt
%%DATADIR%%/data/zik/a1.ogg
@@ -1687,32 +1695,29 @@ share/applications/glob2.desktop
%%DATADIR%%/maps/Isles.map
%%DATADIR%%/maps/Migration.map
%%DATADIR%%/maps/Muka.map
-%%DATADIR%%/maps/No_name.map
%%DATADIR%%/maps/One_on_One.map
%%DATADIR%%/maps/Playground.map
+%%DATADIR%%/maps/Scarse_Supply.map
%%DATADIR%%/maps/SmallForTwo.map
%%DATADIR%%/maps/Tower_Defense_for_2.map
-%%DATADIR%%/maps/TriangIe.map
%%DATADIR%%/maps/Triangle.map
%%DATADIR%%/maps/WaterInTheDesert.map
-%%DATADIR%%/maps/WaterInTheDesert2.map
%%DATADIR%%/maps/Wild_River.map
%%DATADIR%%/maps/a_new_try.map
%%DATADIR%%/maps/newislands_green_blue.map
%%DATADIR%%/maps/stone_bases.map
%%DATADIR%%/maps/strange2.map
%%DATADIR%%/maps/the_sand_square.map
-%%DATADIR%%/maps/tutorial.map
%%DATADIR%%/maps/weakness.map
-%%DATADIR%%/pixmaps/glob2-icon-128x128.png
-%%DATADIR%%/pixmaps/glob2-icon-16x16.png
-%%DATADIR%%/pixmaps/glob2-icon-24x24.png
-%%DATADIR%%/pixmaps/glob2-icon-32x32.png
-%%DATADIR%%/pixmaps/glob2-icon-48x48.png
-%%DATADIR%%/pixmaps/glob2-icon-64x64.png
+%%DATADIR%%/scripts/tutorial_part1.sgsl
+%%DATADIR%%/scripts/tutorial_part2.sgsl
+%%DATADIR%%/scripts/tutorial_part3.sgsl
+%%DATADIR%%/scripts/tutorial_part4.sgsl
+@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%/data/zik
+@dirrm %%DATADIR%%/data/icons
@dirrm %%DATADIR%%/data/gui
@dirrm %%DATADIR%%/data/gfx/cursor
@dirrm %%DATADIR%%/data/gfx