aboutsummaryrefslogtreecommitdiff
path: root/games/glob2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-04-30 21:45:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-04-30 21:45:29 +0000
commit76595053271c6a7de670447cc702352b42b547dd (patch)
tree9181c3e3abbb060e6a9c290e1071666a357f5c64 /games/glob2
parent54764f306d225e732c12758dff51e575a86373a7 (diff)
downloadports-76595053271c6a7de670447cc702352b42b547dd.tar.gz
ports-76595053271c6a7de670447cc702352b42b547dd.zip
Notes
Diffstat (limited to 'games/glob2')
-rw-r--r--games/glob2/Makefile21
-rw-r--r--games/glob2/distinfo4
-rw-r--r--games/glob2/files/patch-configure24
-rw-r--r--games/glob2/pkg-message7
4 files changed, 49 insertions, 7 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index ff17a7fdcc30..abd27f8e9024 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -6,23 +6,25 @@
#
PORTNAME= glob2
-PORTVERSION= 0.8.6
+PORTVERSION= 0.8.14
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= http://epfl.ysagoon.com/~glob2/data/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Globulation 2 - a free and innovative strategy game
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ speex.3:${PORTSDIR}/audio/speex \
freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= image net sdl
+USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
USE_GCC= 3.4
+USE_REINPLACE= yes
PLIST_FILES= bin/glob2
@@ -32,7 +34,16 @@ PLIST_FILES= bin/glob2
BROKEN= "Does not build on alpha"
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" \
+ ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/glob2 ${PREFIX}/bin
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
.include <bsd.port.post.mk>
diff --git a/games/glob2/distinfo b/games/glob2/distinfo
index d359e67f8745..c4cf6da7125f 100644
--- a/games/glob2/distinfo
+++ b/games/glob2/distinfo
@@ -1,2 +1,2 @@
-MD5 (glob2-0.8.6.tar.gz) = f21d9c8ca7c743c5d5e947d8d639acd9
-SIZE (glob2-0.8.6.tar.gz) = 4047199
+MD5 (glob2-0.8.14.tar.gz) = b0efd6efd2881a781fa694596231c5f6
+SIZE (glob2-0.8.14.tar.gz) = 8952234
diff --git a/games/glob2/files/patch-configure b/games/glob2/files/patch-configure
new file mode 100644
index 000000000000..7433bdcdda29
--- /dev/null
+++ b/games/glob2/files/patch-configure
@@ -0,0 +1,24 @@
+--- configure.orig Sun Aug 8 19:53:25 2004
++++ configure Sat Aug 14 18:01:58 2004
+@@ -5175,8 +5175,8 @@
+ /* end confdefs.h. */
+ #include <GL/gl.h>
+ _ACEOF
+-if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++if { (eval echo "$as_me:$LINENO: \"$ac_cpp $CFLAGS conftest.$ac_ext\"") >&5
++ (eval $ac_cpp $CFLAGS conftest.$ac_ext) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+@@ -5318,8 +5318,8 @@
+ /* end confdefs.h. */
+ #include <GL/glu.h>
+ _ACEOF
+-if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
++if { (eval echo "$as_me:$LINENO: \"$ac_cpp $CFLAGS conftest.$ac_ext\"") >&5
++ (eval $ac_cpp $CFLAGS conftest.$ac_ext) 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
diff --git a/games/glob2/pkg-message b/games/glob2/pkg-message
new file mode 100644
index 000000000000..73d9795f6353
--- /dev/null
+++ b/games/glob2/pkg-message
@@ -0,0 +1,7 @@
+Installation successful: now you can try to launch it typing "glob2".
+
+Anyway, it will not always work, so it is suggested that you type
+"glob2 --help" and read about command lines arguments.
+
+Try to use -G option if you have problems with dri and glx (OpenGL),
+or -m if you have problems with sound.