aboutsummaryrefslogtreecommitdiff
path: root/games/glob2
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-28 03:03:46 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-28 03:03:46 +0000
commit8ccc6a7f5c84637cc3b93225b548bbd8addf7e5c (patch)
tree264de3d975c1835a884aa3b7d69cb6433f2880a9 /games/glob2
parent58f1d4449bcc5cf84fe5da0cd06cfcbf053c8664 (diff)
Notes
Diffstat (limited to 'games/glob2')
-rw-r--r--games/glob2/Makefile100
-rw-r--r--games/glob2/files/patch-SConstruct19
-rw-r--r--games/glob2/files/patch-data__SConscript9
-rw-r--r--games/glob2/files/patch-src_VoiceRecorder.cpp11
-rw-r--r--games/glob2/files/patch-src__ConfigFiles.h (renamed from games/glob2/files/patch-src_ConfigFiles.h)4
-rw-r--r--games/glob2/files/pkg-message.in18
-rw-r--r--games/glob2/pkg-message7
-rw-r--r--games/glob2/pkg-plist24
8 files changed, 117 insertions, 75 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index 5762d124b891..6ddb52c205d4 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -1,44 +1,60 @@
# Created by: thierry@pompo.net
# $FreeBSD$
-PORTNAME= glob2
-PORTVERSION= 0.9.4.4
-PORTREVISION= 5
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION:R}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Globulation 2 - a free and innovative strategy game
-
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- speex.1:${PORTSDIR}/audio/speex \
- fribidi.3:${PORTSDIR}/converters/fribidi \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- freetype.9:${PORTSDIR}/print/freetype2
+PORTNAME= glob2
+PORTVERSION= 0.9.4.4
+PORTREVISION= 6
+CATEGORIES= games
+MASTER_SITES= SAVANNAH/${PORTNAME}/${PORTVERSION:R}/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Globulation 2, free and innovative strategy game
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libspeex.so:${PORTSDIR}/audio/speex \
+ libfribidi.so:${PORTSDIR}/converters/fribidi \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libfreetype.so:${PORTSDIR}/print/freetype2
# Should work with portaudio v19_20071207
# Can be built with portaudio2 but does not run cleanly
-#LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
-
-USE_SDL= image net sdl ttf
-USE_GL= gl
-USE_GMAKE= yes
-USE_SCONS= yes
-#SCONS_ARGS= --portaudio=true
-INSTALLS_ICONS= yes
-SCONS_BUILDENV= ${SCONS_ENV}
-#CFLAGS+= ${PTHREAD_CFLAGS} -I. `pkg-config --cflags portaudio-2.0` -I${LOCALBASE}/include
-CFLAGS+= ${PTHREAD_CFLAGS} -I. -I${LOCALBASE}/include
-#LINKFLAGS= ${PTHREAD_LIBS} `pkg-config --libs portaudio-2.0` -L${LOCALBASE}/lib
-LINKFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-
-LICENSE= GPLv3
-
-NO_STAGE= yes
-post-install:
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+#LIB_DEPENDS+= libportaudio.so:${PORTSDIR}/audio/portaudio2
+
+USES= gmake
+USE_SDL= image net sdl ttf
+USE_GL= gl
+USE_SCONS= yes
+#SCONS_ARGS+= --portaudio=true
+#SCONS_BUILDENV= ${SCONS_ENV}
+SCONS_ARGS= CXXFLAGS+=" -g -pg" INSTALLDIR="${STAGEDIR}${PREFIX}/share"
+CFLAGS+= -Wno-return-type
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 16x16 24x24 32x32 48x48 64x64 128x128
+
+#CFLAGS+= ${PTHREAD_CFLAGS} -I. `pkg-config --cflags portaudio-2.0` -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS} -I. -I${LOCALBASE}/include
+#LINKFLAGS= ${PTHREAD_LIBS} `pkg-config --libs portaudio-2.0` -L${LOCALBASE}/lib
+LINKFLAGS= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/bin|${STAGEDIR}${PREFIX}/bin|' \
+ ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} -e 's|portaudio.h|portaudio2/portaudio.h|' ${WRKSRC}/src/VoiceRecorder.cpp
+ @${REINPLACE_CMD} -e 's|^Icon.*|Icon=${PORTNAME}|' \
+ ${WRKSRC}/data/${PORTNAME}.desktop
+
+.for s in 16 24 32 48 64 128
+ @cd ${WRKSRC}/data/icons && \
+ ${MV} glob2-icon-${s}x${s}.png ${PORTNAME}_${s}x${s}.png
+.endfor
manual-regression-test:
# Don't enable these tests on pointyhat, they take too long.
@@ -48,4 +64,16 @@ manual-regression-test:
(cd ${WRKSRC}/src && ./glob2 -test-games-nox)
.endif
+post-install:
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${INSTALL_DATA} ${WRKSRC}/data/icons/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/games/glob2/files/patch-SConstruct b/games/glob2/files/patch-SConstruct
index a4c34367362b..4844c9663b40 100644
--- a/games/glob2/files/patch-SConstruct
+++ b/games/glob2/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig 2009-08-30 19:23:30.000000000 +0000
-+++ SConstruct 2013-01-28 16:42:04.024490217 +0000
+--- ./SConstruct.orig 2009-08-30 21:23:30.000000000 +0200
++++ ./SConstruct 2013-10-28 02:21:28.000000000 +0100
@@ -14,6 +14,7 @@
def establish_options(env):
@@ -8,6 +8,21 @@
opts.Add("CXXFLAGS", "Manually add to the CXXFLAGS", "-g")
opts.Add("LINKFLAGS", "Manually add to the LINKFLAGS", "-g")
if isDarwinPlatform:
+@@ -22,10 +23,10 @@
+ opts.Add("INSTALLDIR", "Installation Directory", "/usr/local/share")
+ opts.Add("BINDIR", "Binary Installation Directory", "/usr/local/bin")
+ opts.Add("DATADIR", "Directory where data will be put, set to the same as INSTALLDIR", "/usr/local/share")
+- opts.Add(BoolOption("release", "Build for release", 0))
+- opts.Add(BoolOption("profile", "Build with profiling on", 0))
+- opts.Add(BoolOption("mingw", "Build with mingw enabled if not auto-detected", 0))
+- opts.Add(BoolOption("server", "Build only the YOG server, excluding the game and any GUI/sound components", 0))
++ opts.Add(BoolVariable("release", "Build for release", 0))
++ opts.Add(BoolVariable("profile", "Build with profiling on", 0))
++ opts.Add(BoolVariable("mingw", "Build with mingw enabled if not auto-detected", 0))
++ opts.Add(BoolVariable("server", "Build only the YOG server, excluding the game and any GUI/sound components", 0))
+ opts.Add("font", "Build the game using an alternative font placed in the data/font folder", "sans.ttf")
+ Help(opts.GenerateHelpText(env))
+ opts.Update(env)
@@ -111,14 +112,17 @@
missing.append("zlib")
diff --git a/games/glob2/files/patch-data__SConscript b/games/glob2/files/patch-data__SConscript
new file mode 100644
index 000000000000..3959d9adf2c6
--- /dev/null
+++ b/games/glob2/files/patch-data__SConscript
@@ -0,0 +1,9 @@
+--- ./data/SConscript.orig 2009-06-14 12:11:30.000000000 +0200
++++ ./data/SConscript 2013-10-28 01:26:26.000000000 +0100
+@@ -19,6 +19,5 @@
+ SConscript("fonts/SConscript")
+ SConscript("gfx/SConscript")
+ SConscript("gui/SConscript")
+-SConscript("icons/SConscript")
+ SConscript("zik/SConscript")
+
diff --git a/games/glob2/files/patch-src_VoiceRecorder.cpp b/games/glob2/files/patch-src_VoiceRecorder.cpp
deleted file mode 100644
index 9c49c581ad36..000000000000
--- a/games/glob2/files/patch-src_VoiceRecorder.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/VoiceRecorder.cpp.orig 2009-01-06 17:24:57.000000000 +0100
-+++ ./src/VoiceRecorder.cpp 2009-03-01 18:33:04.000000000 +0100
-@@ -36,7 +36,7 @@
- #define SPEEX_FRAME_SIZE 160
-
- #ifdef HAVE_PORTAUDIO
-- #include "portaudio.h"
-+ #include <portaudio2/portaudio.h>
- #else
- #ifdef WIN32
- // Windows audio input include
diff --git a/games/glob2/files/patch-src_ConfigFiles.h b/games/glob2/files/patch-src__ConfigFiles.h
index 738e1de58fc7..8f1c30ca2069 100644
--- a/games/glob2/files/patch-src_ConfigFiles.h
+++ b/games/glob2/files/patch-src__ConfigFiles.h
@@ -1,5 +1,5 @@
---- src/ConfigFiles.h.orig Sat Sep 9 16:07:13 2006
-+++ src/ConfigFiles.h Sun Apr 8 18:55:00 2007
+--- ./src/ConfigFiles.h.orig 2009-06-14 12:11:34.000000000 +0200
++++ ./src/ConfigFiles.h 2013-10-28 01:26:26.000000000 +0100
@@ -178,7 +178,11 @@
else
{
diff --git a/games/glob2/files/pkg-message.in b/games/glob2/files/pkg-message.in
new file mode 100644
index 000000000000..9bb8211100a3
--- /dev/null
+++ b/games/glob2/files/pkg-message.in
@@ -0,0 +1,18 @@
+===============================================================================
+
+Globulation 2 has been installed.
+
+You can try to launch it typing
+
+ glob2
+
+Anyway, it will not always work, so it is suggested that you type
+
+ glob2 --help
+
+and read about command lines arguments.
+
+Try to use -G option if you have problems with dri and glx (OpenGL),
+or -m if you have problems with sound, or -C to disable custom cursor.
+
+===============================================================================
diff --git a/games/glob2/pkg-message b/games/glob2/pkg-message
deleted file mode 100644
index e443149d28f2..000000000000
--- a/games/glob2/pkg-message
+++ /dev/null
@@ -1,7 +0,0 @@
-Installation successful: now you can try to launch it typing "glob2".
-
-Anyway, it will not always work, so it is suggested that you type
-"glob2 --help" and read about command lines arguments.
-
-Try to use -G option if you have problems with dri and glx (OpenGL),
-or -m if you have problems with sound, or -C to disable custom cursor.
diff --git a/games/glob2/pkg-plist b/games/glob2/pkg-plist
index 754d1af7931e..2b44fdae01c9 100644
--- a/games/glob2/pkg-plist
+++ b/games/glob2/pkg-plist
@@ -1737,23 +1737,13 @@ share/applications/glob2.desktop
%%DATADIR%%/scripts/tutorial_part2.sgsl
%%DATADIR%%/scripts/tutorial_part3.sgsl
%%DATADIR%%/scripts/tutorial_part4.sgsl
-share/icons/hicolor/128x128/apps/glob2-icon-128x128.png
-share/icons/hicolor/16x16/apps/glob2-icon-16x16.png
-share/icons/hicolor/24x24/apps/glob2-icon-24x24.png
-share/icons/hicolor/32x32/apps/glob2-icon-32x32.png
-share/icons/hicolor/48x48/apps/glob2-icon-48x48.png
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
+share/icons/hicolor/128x128/apps/glob2.png
+share/icons/hicolor/16x16/apps/glob2.png
+share/icons/hicolor/24x24/apps/glob2.png
+share/icons/hicolor/32x32/apps/glob2.png
+share/icons/hicolor/48x48/apps/glob2.png
+share/icons/hicolor/64x64/apps/glob2.png
+share/pixmaps/glob2.png
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%/data/zik