aboutsummaryrefslogtreecommitdiff
path: root/games/gltron/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /games/gltron/Makefile
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
downloadports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.tar.gz
ports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.zip
Notes
Diffstat (limited to 'games/gltron/Makefile')
-rw-r--r--games/gltron/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index 2feef46aae4d..6a10e3847ab8 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -16,12 +16,11 @@ EXTRACT_SUFX= -source.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A 3D worm game for two players for X Window System
-LIB_DEPENDS= SDL_sound-1.0.1:${PORTSDIR}/audio/sdl_sound \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
USE_GL= yes
-USE_SDL= yes
+USE_SDL= sdl sound
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -33,7 +32,7 @@ CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
.if defined(WITH_SDL_NET)
-LIB_DEPENDS+= SDL_net:${PORTSDIR}/net/sdl_net
+USE_SDL+= net
CONFIGURE_ARGS+= --enable-network
.endif