aboutsummaryrefslogtreecommitdiff
path: root/games/gltron
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/gltron
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'games/gltron')
-rw-r--r--games/gltron/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index 223254204c8c..a7ba9397a336 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -9,8 +9,7 @@ PORTNAME= gltron
PORTVERSION= 0.70
PORTREVISION= 6
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
EXTRACT_SUFX= -source.tar.gz
MAINTAINER= lx@FreeBSD.org
@@ -18,7 +17,7 @@ COMMENT= A 3D worm game for two players for X Window System
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-USE_GL= yes
+USE_GL= gl
USE_SDL= sdl sound
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -26,8 +25,8 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-warn
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if defined(WITH_SDL_NET)
USE_SDL+= net