aboutsummaryrefslogtreecommitdiff
path: root/games/gma
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-18 11:25:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-18 11:25:51 +0000
commitc8f26211d7c759b801203f44f5fbefd4a52ae14b (patch)
tree55354b7e22476bef570b91e1f1df4e61ddb5c772 /games/gma
parentcbb89eb5f34d013d88b03c88bda443681dd08475 (diff)
downloadports-c8f26211d7c759b801203f44f5fbefd4a52ae14b.tar.gz
ports-c8f26211d7c759b801203f44f5fbefd4a52ae14b.zip
Notes
Diffstat (limited to 'games/gma')
-rw-r--r--games/gma/Makefile9
-rw-r--r--games/gma/files/patch-configure43
-rw-r--r--games/gma/files/patch-moves.h11
-rw-r--r--games/gma/files/patch-scores.cc11
-rw-r--r--games/gma/files/patch-scores.h15
5 files changed, 81 insertions, 8 deletions
diff --git a/games/gma/Makefile b/games/gma/Makefile
index a08deb89a426..8ac24e284826 100644
--- a/games/gma/Makefile
+++ b/games/gma/Makefile
@@ -13,13 +13,6 @@ MASTER_SITES= http://www.student.nada.kth.se/~d92-jwa/code/gma/
MAINTAINER= ijliao@FreeBSD.org
COMMENT= Go-moku game which learns playing the game from studying its opponent
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
-USE_GCC= 2.95
GNU_CONFIGURE= yes
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/gma/files/patch-configure b/games/gma/files/patch-configure
new file mode 100644
index 000000000000..6a881013b68e
--- /dev/null
+++ b/games/gma/files/patch-configure
@@ -0,0 +1,43 @@
+--- configure.orig Sun May 18 19:14:38 2003
++++ configure Sun May 18 19:17:02 2003
+@@ -1246,40 +1246,6 @@
+ fi
+
+
+-ac_safe=`echo "stl.h" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for stl.h""... $ac_c" 1>&6
+-echo "configure:1252: checking for stl.h" >&5
+-if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+- echo $ac_n "(cached) $ac_c" 1>&6
+-else
+- cat > conftest.$ac_ext <<EOF
+-#line 1257 "configure"
+-#include "confdefs.h"
+-#include <stl.h>
+-EOF
+-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+-{ (eval echo configure:1262: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
+-if test -z "$ac_err"; then
+- rm -rf conftest*
+- eval "ac_cv_header_$ac_safe=yes"
+-else
+- echo "$ac_err" >&5
+- echo "configure: failed program was:" >&5
+- cat conftest.$ac_ext >&5
+- rm -rf conftest*
+- eval "ac_cv_header_$ac_safe=no"
+-fi
+-rm -f conftest*
+-fi
+-if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
+- echo "$ac_t""yes" 1>&6
+- :
+-else
+- echo "$ac_t""no" 1>&6
+-{ echo "configure: error: This program requires STL to compile. Sorry." 1>&2; exit 1; }
+-fi
+-
+ ac_safe=`echo "string" | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for string""... $ac_c" 1>&6
+ echo "configure:1286: checking for string" >&5
diff --git a/games/gma/files/patch-moves.h b/games/gma/files/patch-moves.h
new file mode 100644
index 000000000000..285c9e2bff86
--- /dev/null
+++ b/games/gma/files/patch-moves.h
@@ -0,0 +1,11 @@
+--- src/moves.h.orig Sun May 18 19:18:04 2003
++++ src/moves.h Sun May 18 19:18:19 2003
+@@ -24,7 +24,7 @@
+
+ #include "pattern.h"
+
+-#include <stl.h>
++#include <map.h>
+
+ class Moves:map<Pattern,int>
+ {
diff --git a/games/gma/files/patch-scores.cc b/games/gma/files/patch-scores.cc
new file mode 100644
index 000000000000..52b1542eadd2
--- /dev/null
+++ b/games/gma/files/patch-scores.cc
@@ -0,0 +1,11 @@
+--- src/scores.cc.orig Sun May 18 19:20:37 2003
++++ src/scores.cc Sun May 18 19:20:51 2003
+@@ -50,7 +50,7 @@
+ return result;
+ }
+
+-void Scores::mark_good(const Pattern pattern, int goodness = 1)
++void Scores::mark_good(const Pattern pattern, int goodness)
+ {
+ // Mark this position as beneficial
+ int i;
diff --git a/games/gma/files/patch-scores.h b/games/gma/files/patch-scores.h
new file mode 100644
index 000000000000..dc7dd65e45a3
--- /dev/null
+++ b/games/gma/files/patch-scores.h
@@ -0,0 +1,15 @@
+--- src/scores.h.orig Mon Apr 17 02:52:22 2000
++++ src/scores.h Sun May 18 19:19:41 2003
+@@ -22,9 +22,11 @@
+ #ifndef SCORES_H
+ #define SCORES_H
+
+-#include <stl.h>
++#include <map.h>
+ #include <string>
+ #include "pattern.h"
++
++using namespace std;
+
+ class Scores
+ {