aboutsummaryrefslogtreecommitdiff
path: root/games/gnake
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-09-24 04:28:17 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-09-24 04:28:17 +0000
commita550534baf6a344e6563abd23b2e3892f80328dc (patch)
treef3076bfb9c2e497ed522e94258c26eb1900d24cc /games/gnake
parent620716986f14dfdba2430a37c3e88a139622cd0c (diff)
downloadports-a550534baf6a344e6563abd23b2e3892f80328dc.tar.gz
ports-a550534baf6a344e6563abd23b2e3892f80328dc.zip
Notes
Diffstat (limited to 'games/gnake')
-rw-r--r--games/gnake/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/gnake/Makefile b/games/gnake/Makefile
index d3bb61043111..4fe9677615b3 100644
--- a/games/gnake/Makefile
+++ b/games/gnake/Makefile
@@ -22,7 +22,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
${WRKSRC}/gnake.c
@@ -30,10 +29,10 @@ do-build:
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>