aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-games/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /games/gnome-games/Makefile
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
Notes
Diffstat (limited to 'games/gnome-games/Makefile')
-rw-r--r--games/gnome-games/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index eba339873a13..b36d2def0e2d 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gnomegames2
-PORTVERSION= 2.8.3
+PORTVERSION= 2.10.0
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-games/2.8
+MASTER_SITE_SUBDIR= sources/gnome-games/2.10
DISTNAME= gnome-games-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,11 +19,12 @@ COMMENT= The game applications package for the Gnome 2 Desktop Environment
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_PYTHON= yes
INSTALLS_OMF= yes
+USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack libgnomeui \
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui \
librsvg2 desktopfileutils
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -32,16 +33,24 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= aisleriot.schemas blackjack.schemas gataxx.schemas \
glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas \
gnome-stones.schemas gnometris.schemas gnomine.schemas \
- gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas \
- same-gnome.schemas
+ gnotravex.schemas gnotski.schemas gtali.schemas iagno.schemas \
+ libgnomegames.schemas mahjongg.schemas same-gnome.schemas
CONFLICTS= sol-1.0.*
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libhowl.so) || defined(WITH_MDNS)
+LIB_DEPENDS+= howl:${PORTSDIR}/net/howl
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${REINPLACE_CMD} -e 's|bin/python|bin/env python|g' \
+ ${WRKSRC}/libgames-support/games-server.py
post-install:
- @-update-desktop-database > /dev/null
+ @-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>