aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-games
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-16 05:34:00 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-16 05:34:00 +0000
commit6c41bf6fc9aa96e0cf6e1627df5f933a3842eb1b (patch)
tree9732d246129e19af03b5d915965696502f402309 /games/gnome-games
parentdef707e297209655910450b7f13c6ebfb14c4610 (diff)
downloadports-6c41bf6fc9aa96e0cf6e1627df5f933a3842eb1b.tar.gz
ports-6c41bf6fc9aa96e0cf6e1627df5f933a3842eb1b.zip
Notes
Diffstat (limited to 'games/gnome-games')
-rw-r--r--games/gnome-games/Makefile2
-rw-r--r--games/gnome-games/pkg-install25
-rw-r--r--games/gnome-games/pkg-plist132
3 files changed, 92 insertions, 67 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 48a9091f16cc..1e8550b7848a 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomegames2
PORTVERSION= 2.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-games/2.2
diff --git a/games/gnome-games/pkg-install b/games/gnome-games/pkg-install
new file mode 100644
index 000000000000..c754797a5caf
--- /dev/null
+++ b/games/gnome-games/pkg-install
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ exit 0
+fi
+
+SCORES="glines.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnome-stones.scores gnome-xbill.scores gnometris.scores gnomine.Biiiig.scores gnomine.Custom.scores gnomine.Medium.scores gnomine.Tiny.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.2.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.3.scores gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gtali.scores iagno.b1.scores iagno.b2.scores iagno.b3.scores iagno.w1.scores iagno.w2.scores iagno.w3.scores mahjongg.difficult.scores mahjongg.easy.scores same-gnome.scores"
+
+if [ "$1" = "MAINTAINER" ]; then
+ for i in ${SCORES}; do
+ echo "@unexec [ -s %D/share/gnome/games/${i} ] || rm -f %D/share/gnome/games/${i}"
+ done
+ exit 0
+fi
+
+if [ "$2" = "POST-INSTALL" ]; then
+ mkdir -p ${PKG_PREFIX}/share/gnome/games
+ for i in ${SCORES}; do
+ if [ ! -f ${PKG_PREFIX}/share/gnome/games/${i} ]; then
+ touch -f ${PKG_PREFIX}/share/gnome/games/${i}
+ chown games:games ${PKG_PREFIX}/share/gnome/games/${i}
+ chmod 664 ${PKG_PREFIX}/share/gnome/games/${i}
+ fi
+ done
+fi
diff --git a/games/gnome-games/pkg-plist b/games/gnome-games/pkg-plist
index 58da08b93ca3..e7c02977d397 100644
--- a/games/gnome-games/pkg-plist
+++ b/games/gnome-games/pkg-plist
@@ -76,72 +76,72 @@ share/gnome/applications/mahjongg.desktop
share/gnome/applications/same-gnome.desktop
share/gnome/applications/sol.desktop
share/gnome/applications/xbill.desktop
-share/gnome/games/glines.scores
-share/gnome/games/gnibbles.1.0.scores
-share/gnome/games/gnibbles.1.1.scores
-share/gnome/games/gnibbles.2.0.scores
-share/gnome/games/gnibbles.2.1.scores
-share/gnome/games/gnibbles.3.0.scores
-share/gnome/games/gnibbles.3.1.scores
-share/gnome/games/gnibbles.4.0.scores
-share/gnome/games/gnibbles.4.1.scores
-share/gnome/games/gnobots2.classic_robots-safe.scores
-share/gnome/games/gnobots2.classic_robots-super-safe.scores
-share/gnome/games/gnobots2.classic_robots.scores
-share/gnome/games/gnobots2.nightmare-safe.scores
-share/gnome/games/gnobots2.nightmare-super-safe.scores
-share/gnome/games/gnobots2.nightmare.scores
-share/gnome/games/gnobots2.robots2-safe.scores
-share/gnome/games/gnobots2.robots2-super-safe.scores
-share/gnome/games/gnobots2.robots2.scores
-share/gnome/games/gnobots2.robots2_easy-safe.scores
-share/gnome/games/gnobots2.robots2_easy-super-safe.scores
-share/gnome/games/gnobots2.robots2_easy.scores
-share/gnome/games/gnobots2.robots_with_safe_teleport-safe.scores
-share/gnome/games/gnobots2.robots_with_safe_teleport-super-safe.scores
-share/gnome/games/gnobots2.robots_with_safe_teleport.scores
-share/gnome/games/gnome-stones.scores
-share/gnome/games/gnome-xbill.scores
-share/gnome/games/gnometris.scores
-share/gnome/games/gnomine.Biiiig.scores
-share/gnome/games/gnomine.Custom.scores
-share/gnome/games/gnomine.Medium.scores
-share/gnome/games/gnomine.Tiny.scores
-share/gnome/games/gnotravex.2x2.scores
-share/gnome/games/gnotravex.3x3.scores
-share/gnome/games/gnotravex.4x4.scores
-share/gnome/games/gnotravex.5x5.scores
-share/gnome/games/gnotravex.6x6.scores
-share/gnome/games/gnotski.1.scores
-share/gnome/games/gnotski.11.scores
-share/gnome/games/gnotski.12.scores
-share/gnome/games/gnotski.13.scores
-share/gnome/games/gnotski.14.scores
-share/gnome/games/gnotski.15.scores
-share/gnome/games/gnotski.16.scores
-share/gnome/games/gnotski.17.scores
-share/gnome/games/gnotski.2.scores
-share/gnome/games/gnotski.21.scores
-share/gnome/games/gnotski.22.scores
-share/gnome/games/gnotski.23.scores
-share/gnome/games/gnotski.24.scores
-share/gnome/games/gnotski.25.scores
-share/gnome/games/gnotski.26.scores
-share/gnome/games/gnotski.3.scores
-share/gnome/games/gnotski.4.scores
-share/gnome/games/gnotski.5.scores
-share/gnome/games/gnotski.6.scores
-share/gnome/games/gnotski.7.scores
-share/gnome/games/gtali.scores
-share/gnome/games/iagno.b1.scores
-share/gnome/games/iagno.b2.scores
-share/gnome/games/iagno.b3.scores
-share/gnome/games/iagno.w1.scores
-share/gnome/games/iagno.w2.scores
-share/gnome/games/iagno.w3.scores
-share/gnome/games/mahjongg.difficult.scores
-share/gnome/games/mahjongg.easy.scores
-share/gnome/games/same-gnome.scores
+@unexec [ -s %D/share/gnome/games/glines.scores ] || rm -f %D/share/gnome/games/glines.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.1.0.scores ] || rm -f %D/share/gnome/games/gnibbles.1.0.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.1.1.scores ] || rm -f %D/share/gnome/games/gnibbles.1.1.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.2.0.scores ] || rm -f %D/share/gnome/games/gnibbles.2.0.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.2.1.scores ] || rm -f %D/share/gnome/games/gnibbles.2.1.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.3.0.scores ] || rm -f %D/share/gnome/games/gnibbles.3.0.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.3.1.scores ] || rm -f %D/share/gnome/games/gnibbles.3.1.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.4.0.scores ] || rm -f %D/share/gnome/games/gnibbles.4.0.scores
+@unexec [ -s %D/share/gnome/games/gnibbles.4.1.scores ] || rm -f %D/share/gnome/games/gnibbles.4.1.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.classic_robots-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.classic_robots-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.classic_robots-super-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.classic_robots-super-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.classic_robots.scores ] || rm -f %D/share/gnome/games/gnobots2.classic_robots.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.nightmare-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.nightmare-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.nightmare-super-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.nightmare-super-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.nightmare.scores ] || rm -f %D/share/gnome/games/gnobots2.nightmare.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots2-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots2-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots2-super-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots2-super-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots2.scores ] || rm -f %D/share/gnome/games/gnobots2.robots2.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots2_easy-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots2_easy-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots2_easy-super-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots2_easy-super-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots2_easy.scores ] || rm -f %D/share/gnome/games/gnobots2.robots2_easy.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots_with_safe_teleport-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots_with_safe_teleport-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots_with_safe_teleport-super-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots_with_safe_teleport-super-safe.scores
+@unexec [ -s %D/share/gnome/games/gnobots2.robots_with_safe_teleport.scores ] || rm -f %D/share/gnome/games/gnobots2.robots_with_safe_teleport.scores
+@unexec [ -s %D/share/gnome/games/gnome-stones.scores ] || rm -f %D/share/gnome/games/gnome-stones.scores
+@unexec [ -s %D/share/gnome/games/gnome-xbill.scores ] || rm -f %D/share/gnome/games/gnome-xbill.scores
+@unexec [ -s %D/share/gnome/games/gnometris.scores ] || rm -f %D/share/gnome/games/gnometris.scores
+@unexec [ -s %D/share/gnome/games/gnomine.Biiiig.scores ] || rm -f %D/share/gnome/games/gnomine.Biiiig.scores
+@unexec [ -s %D/share/gnome/games/gnomine.Custom.scores ] || rm -f %D/share/gnome/games/gnomine.Custom.scores
+@unexec [ -s %D/share/gnome/games/gnomine.Medium.scores ] || rm -f %D/share/gnome/games/gnomine.Medium.scores
+@unexec [ -s %D/share/gnome/games/gnomine.Tiny.scores ] || rm -f %D/share/gnome/games/gnomine.Tiny.scores
+@unexec [ -s %D/share/gnome/games/gnotravex.2x2.scores ] || rm -f %D/share/gnome/games/gnotravex.2x2.scores
+@unexec [ -s %D/share/gnome/games/gnotravex.3x3.scores ] || rm -f %D/share/gnome/games/gnotravex.3x3.scores
+@unexec [ -s %D/share/gnome/games/gnotravex.4x4.scores ] || rm -f %D/share/gnome/games/gnotravex.4x4.scores
+@unexec [ -s %D/share/gnome/games/gnotravex.5x5.scores ] || rm -f %D/share/gnome/games/gnotravex.5x5.scores
+@unexec [ -s %D/share/gnome/games/gnotravex.6x6.scores ] || rm -f %D/share/gnome/games/gnotravex.6x6.scores
+@unexec [ -s %D/share/gnome/games/gnotski.1.scores ] || rm -f %D/share/gnome/games/gnotski.1.scores
+@unexec [ -s %D/share/gnome/games/gnotski.11.scores ] || rm -f %D/share/gnome/games/gnotski.11.scores
+@unexec [ -s %D/share/gnome/games/gnotski.12.scores ] || rm -f %D/share/gnome/games/gnotski.12.scores
+@unexec [ -s %D/share/gnome/games/gnotski.13.scores ] || rm -f %D/share/gnome/games/gnotski.13.scores
+@unexec [ -s %D/share/gnome/games/gnotski.14.scores ] || rm -f %D/share/gnome/games/gnotski.14.scores
+@unexec [ -s %D/share/gnome/games/gnotski.15.scores ] || rm -f %D/share/gnome/games/gnotski.15.scores
+@unexec [ -s %D/share/gnome/games/gnotski.16.scores ] || rm -f %D/share/gnome/games/gnotski.16.scores
+@unexec [ -s %D/share/gnome/games/gnotski.17.scores ] || rm -f %D/share/gnome/games/gnotski.17.scores
+@unexec [ -s %D/share/gnome/games/gnotski.2.scores ] || rm -f %D/share/gnome/games/gnotski.2.scores
+@unexec [ -s %D/share/gnome/games/gnotski.21.scores ] || rm -f %D/share/gnome/games/gnotski.21.scores
+@unexec [ -s %D/share/gnome/games/gnotski.22.scores ] || rm -f %D/share/gnome/games/gnotski.22.scores
+@unexec [ -s %D/share/gnome/games/gnotski.23.scores ] || rm -f %D/share/gnome/games/gnotski.23.scores
+@unexec [ -s %D/share/gnome/games/gnotski.24.scores ] || rm -f %D/share/gnome/games/gnotski.24.scores
+@unexec [ -s %D/share/gnome/games/gnotski.25.scores ] || rm -f %D/share/gnome/games/gnotski.25.scores
+@unexec [ -s %D/share/gnome/games/gnotski.26.scores ] || rm -f %D/share/gnome/games/gnotski.26.scores
+@unexec [ -s %D/share/gnome/games/gnotski.3.scores ] || rm -f %D/share/gnome/games/gnotski.3.scores
+@unexec [ -s %D/share/gnome/games/gnotski.4.scores ] || rm -f %D/share/gnome/games/gnotski.4.scores
+@unexec [ -s %D/share/gnome/games/gnotski.5.scores ] || rm -f %D/share/gnome/games/gnotski.5.scores
+@unexec [ -s %D/share/gnome/games/gnotski.6.scores ] || rm -f %D/share/gnome/games/gnotski.6.scores
+@unexec [ -s %D/share/gnome/games/gnotski.7.scores ] || rm -f %D/share/gnome/games/gnotski.7.scores
+@unexec [ -s %D/share/gnome/games/gtali.scores ] || rm -f %D/share/gnome/games/gtali.scores
+@unexec [ -s %D/share/gnome/games/iagno.b1.scores ] || rm -f %D/share/gnome/games/iagno.b1.scores
+@unexec [ -s %D/share/gnome/games/iagno.b2.scores ] || rm -f %D/share/gnome/games/iagno.b2.scores
+@unexec [ -s %D/share/gnome/games/iagno.b3.scores ] || rm -f %D/share/gnome/games/iagno.b3.scores
+@unexec [ -s %D/share/gnome/games/iagno.w1.scores ] || rm -f %D/share/gnome/games/iagno.w1.scores
+@unexec [ -s %D/share/gnome/games/iagno.w2.scores ] || rm -f %D/share/gnome/games/iagno.w2.scores
+@unexec [ -s %D/share/gnome/games/iagno.w3.scores ] || rm -f %D/share/gnome/games/iagno.w3.scores
+@unexec [ -s %D/share/gnome/games/mahjongg.difficult.scores ] || rm -f %D/share/gnome/games/mahjongg.difficult.scores
+@unexec [ -s %D/share/gnome/games/mahjongg.easy.scores ] || rm -f %D/share/gnome/games/mahjongg.easy.scores
+@unexec [ -s %D/share/gnome/games/same-gnome.scores ] || rm -f %D/share/gnome/games/same-gnome.scores
share/gnome/gnect/catseyes_40x40.gnect
share/gnome/gnect/classic_40x40.gnect
share/gnome/gnect/classic_50x50.gnect