aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-games
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /games/gnome-games
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Notes
Diffstat (limited to 'games/gnome-games')
-rw-r--r--games/gnome-games/Makefile26
-rw-r--r--games/gnome-games/distinfo6
-rw-r--r--games/gnome-games/files/patch-configure11
-rw-r--r--games/gnome-games/files/patch-gnome-stones_Makefile.in11
-rw-r--r--games/gnome-games/files/patch-iagno_othello.c20
-rw-r--r--games/gnome-games/pkg-install10
-rw-r--r--games/gnome-games/pkg-plist120
7 files changed, 81 insertions, 123 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index a290533cafa9..6bccbc608daf 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/games/gnomegames2/Makefile,v 1.89 2005/10/03 15:30:09 ahze Exp $
+# $MCom: ports/games/gnomegames2/Makefile,v 1.111 2006/04/13 07:52:34 bland Exp $
#
PORTNAME= gnomegames2
-PORTVERSION= 2.12.3
-PORTREVISION= 1
+PORTVERSION= 2.14.1
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-games/2.12
+MASTER_SITE_SUBDIR= sources/gnome-games/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-games-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,6 +21,7 @@ LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_BZIP2= yes
USE_PYTHON= yes
+USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -32,17 +32,18 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= aisleriot.schemas blackjack.schemas gataxx.schemas \
- glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas \
- gnome-stones.schemas gnometris.schemas gnomine.schemas \
- gnotravex.schemas gnotski.schemas gtali.schemas iagno.schemas \
- libgnomegames.schemas mahjongg.schemas same-gnome.schemas
+ glines.schemas gnect.schemas gnibbles.schemas \
+ gnobots2.schemas gnometris.schemas gnomine.schemas \
+ gnotravex.schemas gnotski.schemas gtali.schemas \
+ iagno.schemas libgnomegames.schemas mahjongg.schemas \
+ same-gnome.schemas
CONFLICTS= sol-1.0.*
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libhowl.so) || defined(WITH_MDNS)
-LIB_DEPENDS+= howl:${PORTSDIR}/net/howl
+.if exists(${LOCALBASE}/lib/libavahi-client.a) || defined(WITH_MDNS)
+LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi
.endif
post-patch:
@@ -50,6 +51,11 @@ post-patch:
's|malloc\.h|stdlib.h|g'
@${REINPLACE_CMD} -e 's|bin/python|bin/env python|g' \
${WRKSRC}/libgames-support/games-server.py
+ @${REINPLACE_CMD} -e 's|howl|avahi-compat-howl|' \
+ ${WRKSRC}/configure
+# @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+# 's|664|666|g ; \
+# s|2555|0555|g'
post-install:
@-update-desktop-database
diff --git a/games/gnome-games/distinfo b/games/gnome-games/distinfo
index 4f66339c4cc8..13dd1e201ee9 100644
--- a/games/gnome-games/distinfo
+++ b/games/gnome-games/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-games-2.12.3.tar.bz2) = 06d3cfaf24dd1f0b2df1df005c69d4ff
-SHA256 (gnome2/gnome-games-2.12.3.tar.bz2) = 0bd560e6094fd0bedf5316223eeef90a99451bb739a91d7a0438a858f66a3835
-SIZE (gnome2/gnome-games-2.12.3.tar.bz2) = 4932211
+MD5 (gnome2/gnome-games-2.14.1.tar.bz2) = 9893da6c2f8eecdbc596cec9a017a8b2
+SHA256 (gnome2/gnome-games-2.14.1.tar.bz2) = c9c364883f260a57d6501f8e79564738a88e76e9fe29168613a58ef94e0d7b8a
+SIZE (gnome2/gnome-games-2.14.1.tar.bz2) = 5095238
diff --git a/games/gnome-games/files/patch-configure b/games/gnome-games/files/patch-configure
deleted file mode 100644
index f8413ef3cff4..000000000000
--- a/games/gnome-games/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Wed Dec 17 11:58:34 2003
-+++ configure Wed Dec 17 11:58:35 2003
-@@ -22452,7 +22452,7 @@
- else
-
- cat >>confdefs.h <<_ACEOF
--#define GNOME_ICONDIR "${prefix}/share/pixmaps"
-+#define GNOME_ICONDIR "${datadir}/pixmaps"
- _ACEOF
-
- fi
diff --git a/games/gnome-games/files/patch-gnome-stones_Makefile.in b/games/gnome-games/files/patch-gnome-stones_Makefile.in
deleted file mode 100644
index 92fbe9e8806c..000000000000
--- a/games/gnome-games/files/patch-gnome-stones_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnome-stones/Makefile.in.orig Tue Jul 23 20:37:40 2002
-+++ gnome-stones/Makefile.in Tue Jul 23 20:38:10 2002
-@@ -202,7 +202,7 @@
- Caves_in_files = default.caves.in tutorial.caves.in gnomekoban.caves.in atari.caves.in
- Caves_DATA = $(Caves_in_files:.caves.in=.caves)
-
--gtkrcdir = $(datadir)
-+gtkrcdir = $(datadir)/gnome-stones
- gtkrc_DATA = gnome-stonesrc gnome-stonesrc.ko
-
- Mimedir = $(datadir)/mime-info
diff --git a/games/gnome-games/files/patch-iagno_othello.c b/games/gnome-games/files/patch-iagno_othello.c
deleted file mode 100644
index 1d6d8e88a6a7..000000000000
--- a/games/gnome-games/files/patch-iagno_othello.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- iagno/othello.c.orig Tue Jan 25 11:24:35 2005
-+++ iagno/othello.c Tue Jan 25 11:24:56 2005
-@@ -784,14 +784,14 @@
- found_free = TRUE;
- }
-
-- // check if a player is dead
-+ /* check if a player is dead */
- if (!found_me && found_not_me)
- return (S_LOSING_GAME);
- else if (found_me && !found_not_me)
- return (S_WINNING_GAME);
-
-- // if the game is finished, return the actual score rather than
-- // a huristic
-+ /* if the game is finished, return the actual score rather than
-+ * a huristic */
- if (!found_free)
- return (actual_score);
-
diff --git a/games/gnome-games/pkg-install b/games/gnome-games/pkg-install
index fe5c51770457..cbbb71f5595f 100644
--- a/games/gnome-games/pkg-install
+++ b/games/gnome-games/pkg-install
@@ -5,13 +5,19 @@ PATH=/bin:/usr/bin:/usr/sbin
case $2 in
POST-INSTALL)
mkdir -p ${PKG_PREFIX}/share/gnome/games
- SCORES="glines.Large.scores glines.Medium.scores glines.Small.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnome-stones.scores gnometris.scores gnomine.Custom.scores gnomine.Large.scores gnomine.Medium.scores gnomine.Small.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski.10.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.18.scores gnotski.19.scores gnotski.2.scores gnotski.20.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.27.scores gnotski.28.scores gnotski.29.scores gnotski.3.scores gnotski.30.scores gnotski.31.scores gnotski.32.scores gnotski.33.scores gnotski.34.scores gnotski.35.scores gnotski.36.scores gnotski.37.scores gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gnotski.8.scores gnotski.9.scores gtali.scores mahjongg.bridges.scores mahjongg.cloud.scores mahjongg.confounding.scores mahjongg.difficult.scores mahjongg.dragon.scores mahjongg.easy.scores mahjongg.pyramid.scores mahjongg.tictactoe.scores mahjongg.ziggurat.scores same-gnome.Large.scores same-gnome.Medium.scores same-gnome.Small.scores"
+ SCORES="glines.scores glines.Large.scores glines.Medium.scores glines.Small.scores gnibbles.1.0.scores gnibbles.1.1.scores gnibbles.2.0.scores gnibbles.2.1.scores gnibbles.3.0.scores gnibbles.3.1.scores gnibbles.4.0.scores gnibbles.4.1.scores gnobots2.classic_robots-safe.scores gnobots2.classic_robots-super-safe.scores gnobots2.classic_robots.scores gnobots2.nightmare-safe.scores gnobots2.nightmare-super-safe.scores gnobots2.nightmare.scores gnobots2.robots2-safe.scores gnobots2.robots2-super-safe.scores gnobots2.robots2.scores gnobots2.robots2_easy-safe.scores gnobots2.robots2_easy-super-safe.scores gnobots2.robots2_easy.scores gnobots2.robots_with_safe_teleport-safe.scores gnobots2.robots_with_safe_teleport-super-safe.scores gnobots2.robots_with_safe_teleport.scores gnometris.scores gnomine.Custom.scores gnomine.Large.scores gnomine.Medium.scores gnomine.Small.scores gnotravex.2x2.scores gnotravex.3x3.scores gnotravex.4x4.scores gnotravex.5x5.scores gnotravex.6x6.scores gnotski.1.scores gnotski.10.scores gnotski.11.scores gnotski.12.scores gnotski.13.scores gnotski.14.scores gnotski.15.scores gnotski.16.scores gnotski.17.scores gnotski.18.scores gnotski.2.scores gnotski.20.scores gnotski.21.scores gnotski.22.scores gnotski.23.scores gnotski.24.scores gnotski.25.scores gnotski.26.scores gnotski.27.scores gnotski.28.scores gnotski.29.scores gnotski.3.scores gnotski.30.scores gnotski.31.scores gnotski.32.scores gnotski.33.scores gnotski.34.scores gnotski.35.scores gnotski.36.scores gnotski.37.scores gnotski.4.scores gnotski.5.scores gnotski.6.scores gnotski.7.scores gnotski.8.scores gnotski.9.scores gtali.scores mahjongg.bridges.scores mahjongg.cloud.scores mahjongg.confounding.scores mahjongg.difficult.scores mahjongg.dragon.scores mahjongg.easy.scores mahjongg.pyramid.scores mahjongg.tictactoe.scores mahjongg.ziggurat.scores same-gnome.Small.scores same-gnome.Medium.scores same-gnome.Large.scores"
for i in ${SCORES}; do
if [ ! -f ${PKG_PREFIX}/share/gnome/games/${i} ]; then
touch -f ${PKG_PREFIX}/share/gnome/games/${i}
chown games:games ${PKG_PREFIX}/share/gnome/games/${i}
- chmod 0664 ${PKG_PREFIX}/share/gnome/games/${i}
+ chmod 0666 ${PKG_PREFIX}/share/gnome/games/${i}
fi
done
+ if [ -f ${PKG_PREFIX}/share/gnome/games/same-gnome.scores ]; then
+ mv -f ${PKG_PREFIX}/share/gnome/games/same-gnome.scores \
+ ${PKG_PREFIX}/share/gnome/games/same-gnome.Small.scores
+ ln -sf ${PKG_PREFIX}/share/gnome/games/same-gnome.Small.scores \
+ ${PKG_PREFIX}/share/gnome/games/same-gnome.scores
+ fi
;;
esac
diff --git a/games/gnome-games/pkg-plist b/games/gnome-games/pkg-plist
index 950685f8655f..733b9c028330 100644
--- a/games/gnome-games/pkg-plist
+++ b/games/gnome-games/pkg-plist
@@ -5,7 +5,6 @@ bin/glines
bin/gnect
bin/gnibbles
bin/gnobots2
-bin/gnome-stones
bin/gnometris
bin/gnomine
bin/gnotravex
@@ -18,12 +17,6 @@ bin/sol
etc/sound/events/gnibbles.soundlist
etc/sound/events/gnobots2.soundlist
etc/sound/events/iagno.soundlist
-lib/gnome-stones/objects/libgnome-stones.a
-lib/gnome-stones/objects/libgnome-stones.la
-lib/gnome-stones/objects/libgnome-stones.so
-lib/gnome-stones/objects/libgnomekoban.a
-lib/gnome-stones/objects/libgnomekoban.la
-lib/gnome-stones/objects/libgnomekoban.so
share/gnome/applications/blackjack.desktop
share/gnome/applications/freecell.desktop
share/gnome/applications/gataxx.desktop
@@ -31,7 +24,6 @@ share/gnome/applications/glines.desktop
share/gnome/applications/gnect.desktop
share/gnome/applications/gnibbles.desktop
share/gnome/applications/gnobots2.desktop
-share/gnome/applications/gnome-stones.desktop
share/gnome/applications/gnometris.desktop
share/gnome/applications/gnomine.desktop
share/gnome/applications/gnotravex.desktop
@@ -41,11 +33,11 @@ share/gnome/applications/iagno.desktop
share/gnome/applications/mahjongg.desktop
share/gnome/applications/same-gnome.desktop
share/gnome/applications/sol.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
share/gnome/blackjack/Ameristar.rules
share/gnome/blackjack/Atlantic_City.rules
share/gnome/blackjack/Vegas_Downtown.rules
share/gnome/blackjack/Vegas_Strip.rules
+@unexec [ -s %D/share/gnome/games/glines.scores ] || rm -f %D/share/gnome/games/glines.scores
@unexec [ -s %D/share/gnome/games/glines.Large.scores ] || rm -f %D/share/gnome/games/glines.Large.scores
@unexec [ -s %D/share/gnome/games/glines.Medium.scores ] || rm -f %D/share/gnome/games/glines.Medium.scores
@unexec [ -s %D/share/gnome/games/glines.Small.scores ] || rm -f %D/share/gnome/games/glines.Small.scores
@@ -72,7 +64,6 @@ share/gnome/blackjack/Vegas_Strip.rules
@unexec [ -s %D/share/gnome/games/gnobots2.robots_with_safe_teleport-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots_with_safe_teleport-safe.scores
@unexec [ -s %D/share/gnome/games/gnobots2.robots_with_safe_teleport-super-safe.scores ] || rm -f %D/share/gnome/games/gnobots2.robots_with_safe_teleport-super-safe.scores
@unexec [ -s %D/share/gnome/games/gnobots2.robots_with_safe_teleport.scores ] || rm -f %D/share/gnome/games/gnobots2.robots_with_safe_teleport.scores
-@unexec [ -s %D/share/gnome/games/gnome-stones.scores ] || rm -f %D/share/gnome/games/gnome-stones.scores
@unexec [ -s %D/share/gnome/games/gnometris.scores ] || rm -f %D/share/gnome/games/gnometris.scores
@unexec [ -s %D/share/gnome/games/gnomine.Custom.scores ] || rm -f %D/share/gnome/games/gnomine.Custom.scores
@unexec [ -s %D/share/gnome/games/gnomine.Large.scores ] || rm -f %D/share/gnome/games/gnomine.Large.scores
@@ -133,6 +124,7 @@ share/gnome/blackjack/Vegas_Strip.rules
@unexec [ -s %D/share/gnome/games/same-gnome.Large.scores ] || rm -f %D/share/gnome/games/same-gnome.Large.scores
@unexec [ -s %D/share/gnome/games/same-gnome.Medium.scores ] || rm -f %D/share/gnome/games/same-gnome.Medium.scores
@unexec [ -s %D/share/gnome/games/same-gnome.Small.scores ] || rm -f %D/share/gnome/games/same-gnome.Small.scores
+@unexec [ -L %D/share/gnome/games/same-gnome.scores ] || rm -f %D/share/gnome/games/same-gnome.scores
share/gnome/gnect/white_ob.cn4
share/gnome/gnibbles/level001.gnl
share/gnome/gnibbles/level002.gnl
@@ -165,18 +157,15 @@ share/gnome/gnobots2/nightmare.cfg
share/gnome/gnobots2/robots2.cfg
share/gnome/gnobots2/robots2_easy.cfg
share/gnome/gnobots2/robots_with_safe_teleport.cfg
+share/gnome/gnome-games/ataxx/themes/2.14/classic.png
share/gnome/gnome-games/mahjongg/maps/mahjongg.map
share/gnome/gnome-games/same-gnome/themes/2.10/planets.png
share/gnome/gnome-games/same-gnome/themes/2.10/stones.png
-share/gnome/gnome-stones/atari.caves
-share/gnome/gnome-stones/default.caves
-share/gnome/gnome-stones/gnome-stonesrc
-share/gnome/gnome-stones/gnome-stonesrc.ko
-share/gnome/gnome-stones/gnomekoban.caves
-share/gnome/gnome-stones/tutorial.caves
share/gnome/help/aisleriot/C/agnes.xml
share/gnome/help/aisleriot/C/aisleriot.xml
+share/gnome/help/aisleriot/C/athena.xml
share/gnome/help/aisleriot/C/auld_lang_syne.xml
+share/gnome/help/aisleriot/C/aunt_mary.xml
share/gnome/help/aisleriot/C/backbone.xml
share/gnome/help/aisleriot/C/bakers_dozen.xml
share/gnome/help/aisleriot/C/bakers_game.xml
@@ -189,6 +178,7 @@ share/gnome/help/aisleriot/C/carpet.xml
share/gnome/help/aisleriot/C/chessboard.xml
share/gnome/help/aisleriot/C/clock.xml
share/gnome/help/aisleriot/C/cover.xml
+share/gnome/help/aisleriot/C/cruel.xml
share/gnome/help/aisleriot/C/definitions.xml
share/gnome/help/aisleriot/C/diamond_mine.xml
share/gnome/help/aisleriot/C/doublets.xml
@@ -204,6 +194,7 @@ share/gnome/help/aisleriot/C/fortress.xml
share/gnome/help/aisleriot/C/fortunes.xml
share/gnome/help/aisleriot/C/fourteen.xml
share/gnome/help/aisleriot/C/freecell.xml
+share/gnome/help/aisleriot/C/gaps.xml
share/gnome/help/aisleriot/C/gay_gordons.xml
share/gnome/help/aisleriot/C/glenwood.xml
share/gnome/help/aisleriot/C/golf.xml
@@ -214,6 +205,7 @@ share/gnome/help/aisleriot/C/isabel.xml
share/gnome/help/aisleriot/C/jamestown.xml
share/gnome/help/aisleriot/C/jumbo.xml
share/gnome/help/aisleriot/C/kansas.xml
+share/gnome/help/aisleriot/C/kings_audience.xml
share/gnome/help/aisleriot/C/king_albert.xml
share/gnome/help/aisleriot/C/klondike.xml
share/gnome/help/aisleriot/C/labyrinth.xml
@@ -230,6 +222,7 @@ share/gnome/help/aisleriot/C/plait.xml
share/gnome/help/aisleriot/C/poker.xml
share/gnome/help/aisleriot/C/quatorze.xml
share/gnome/help/aisleriot/C/royal_east.xml
+share/gnome/help/aisleriot/C/saratoga.xml
share/gnome/help/aisleriot/C/scorpion.xml
share/gnome/help/aisleriot/C/scuffle.xml
share/gnome/help/aisleriot/C/seahaven.xml
@@ -255,8 +248,10 @@ share/gnome/help/aisleriot/C/yield.xml
share/gnome/help/aisleriot/C/yukon.xml
share/gnome/help/aisleriot/C/zebra.xml
share/gnome/help/aisleriot/fr/agnes.xml
+share/gnome/help/aisleriot/fr/athena.xml
share/gnome/help/aisleriot/fr/aisleriot.xml
share/gnome/help/aisleriot/fr/auld_lang_syne.xml
+share/gnome/help/aisleriot/fr/aunt_mary.xml
share/gnome/help/aisleriot/fr/backbone.xml
share/gnome/help/aisleriot/fr/bakers_dozen.xml
share/gnome/help/aisleriot/fr/bakers_game.xml
@@ -269,6 +264,7 @@ share/gnome/help/aisleriot/fr/carpet.xml
share/gnome/help/aisleriot/fr/chessboard.xml
share/gnome/help/aisleriot/fr/clock.xml
share/gnome/help/aisleriot/fr/cover.xml
+share/gnome/help/aisleriot/fr/cruel.xml
share/gnome/help/aisleriot/fr/definitions.xml
share/gnome/help/aisleriot/fr/diamond_mine.xml
share/gnome/help/aisleriot/fr/doublets.xml
@@ -284,6 +280,7 @@ share/gnome/help/aisleriot/fr/fortress.xml
share/gnome/help/aisleriot/fr/fortunes.xml
share/gnome/help/aisleriot/fr/fourteen.xml
share/gnome/help/aisleriot/fr/freecell.xml
+share/gnome/help/aisleriot/fr/gaps.xml
share/gnome/help/aisleriot/fr/gay_gordons.xml
share/gnome/help/aisleriot/fr/glenwood.xml
share/gnome/help/aisleriot/fr/golf.xml
@@ -294,6 +291,7 @@ share/gnome/help/aisleriot/fr/isabel.xml
share/gnome/help/aisleriot/fr/jamestown.xml
share/gnome/help/aisleriot/fr/jumbo.xml
share/gnome/help/aisleriot/fr/kansas.xml
+share/gnome/help/aisleriot/fr/kings_audience.xml
share/gnome/help/aisleriot/fr/king_albert.xml
share/gnome/help/aisleriot/fr/klondike.xml
share/gnome/help/aisleriot/fr/labyrinth.xml
@@ -310,6 +308,7 @@ share/gnome/help/aisleriot/fr/plait.xml
share/gnome/help/aisleriot/fr/poker.xml
share/gnome/help/aisleriot/fr/quatorze.xml
share/gnome/help/aisleriot/fr/royal_east.xml
+share/gnome/help/aisleriot/fr/saratoga.xml
share/gnome/help/aisleriot/fr/scorpion.xml
share/gnome/help/aisleriot/fr/scuffle.xml
share/gnome/help/aisleriot/fr/seahaven.xml
@@ -367,25 +366,21 @@ share/gnome/help/gnobots2/es/gnobots2.xml
share/gnome/help/gnobots2/es/legal.xml
share/gnome/help/gnobots2/it/gnobots2.xml
share/gnome/help/gnobots2/it/legal.xml
-share/gnome/help/gnome-stones/C/figures/main-game.png
-share/gnome/help/gnome-stones/C/figures/main-start.png
-share/gnome/help/gnome-stones/C/figures/preferences-joystick.png
-share/gnome/help/gnome-stones/C/figures/preferences-main.png
-share/gnome/help/gnome-stones/C/gnome-stones.xml
-share/gnome/help/gnome-stones/C/legal.xml
share/gnome/help/gnometris/C/gnometris.xml
share/gnome/help/gnometris/C/legal.xml
-share/gnome/help/gnomine/C/figures/advanced_121_a.png
-share/gnome/help/gnomine/C/figures/advanced_121_b.png
-share/gnome/help/gnomine/C/figures/advanced_121_c.png
-share/gnome/help/gnomine/C/figures/basic-corner.png
-share/gnome/help/gnomine/C/figures/basic-flat3.png
-share/gnome/help/gnomine/C/figures/basic-wall.png
-share/gnome/help/gnomine/C/figures/gnomine-begin-play.png
-share/gnome/help/gnomine/C/figures/gnomine-fail.png
-share/gnome/help/gnomine/C/figures/gnomine-fresh.png
-share/gnome/help/gnomine/C/figures/gnomine-preferences.png
-share/gnome/help/gnomine/C/figures/gnomine-won.png
+share/gnome/help/gnomine/C/figures/easy-hints-1.png
+share/gnome/help/gnomine/C/figures/easy-hints-2.png
+share/gnome/help/gnomine/C/figures/easy-hints-3.png
+share/gnome/help/gnomine/C/figures/faces.png
+share/gnome/help/gnomine/C/figures/flags.png
+share/gnome/help/gnomine/C/figures/hard-hints-1.png
+share/gnome/help/gnomine/C/figures/hard-hints-2.png
+share/gnome/help/gnomine/C/figures/hard-hints-3.png
+share/gnome/help/gnomine/C/figures/highscores.png
+share/gnome/help/gnomine/C/figures/imnotsureflagscheckbox.png
+share/gnome/help/gnomine/C/figures/main-window.png
+share/gnome/help/gnomine/C/figures/preferences.png
+share/gnome/help/gnomine/C/figures/statusbar.png
share/gnome/help/gnomine/C/gnomine.xml
share/gnome/help/gnomine/C/legal.xml
share/gnome/help/gnotravex/C/figures/gnotravex_game.png
@@ -419,8 +414,6 @@ share/gnome/help/same-gnome/C/figures/play.png
share/gnome/help/same-gnome/C/figures/start-up.png
share/gnome/help/same-gnome/C/legal.xml
share/gnome/help/same-gnome/C/same-gnome.xml
-share/gnome/mime-info/gnome-stones.keys
-share/gnome/mime-info/gnome-stones.mime
share/gnome/omf/gnome-games/aisleriot-C.omf
share/gnome/omf/gnome-games/aisleriot-fr.omf
share/gnome/omf/gnome-games/blackjack-C.omf
@@ -432,7 +425,6 @@ share/gnome/omf/gnome-games/gnobots2-C.omf
share/gnome/omf/gnome-games/gnobots2-da.omf
share/gnome/omf/gnome-games/gnobots2-es.omf
share/gnome/omf/gnome-games/gnobots2-it.omf
-share/gnome/omf/gnome-games/gnome-stones-C.omf
share/gnome/omf/gnome-games/gnometris-C.omf
share/gnome/omf/gnome-games/gnomine-C.omf
share/gnome/omf/gnome-games/gnotravex-C.omf
@@ -472,7 +464,7 @@ share/gnome/pixmaps/gnibbles/bonus3.svg
share/gnome/pixmaps/gnibbles/bonus4.svg
share/gnome/pixmaps/gnibbles/bonus5.svg
share/gnome/pixmaps/gnibbles/diamond.svg
-share/gnome/pixmaps/gnibbles/gnibbles-logo.png
+share/gnome/pixmaps/gnibbles/gnibbles-logo.svg
share/gnome/pixmaps/gnibbles/gnibbles.png
share/gnome/pixmaps/gnibbles/life.svg
share/gnome/pixmaps/gnibbles/questionmark.svg
@@ -505,7 +497,9 @@ share/gnome/pixmaps/gnome-blackjack.png
share/gnome/pixmaps/gnome-cardgame.png
share/gnome/pixmaps/gnome-games-common/cards/bonded.png
share/gnome/pixmaps/gnome-games-common/cards/paris.svg
-share/gnome/pixmaps/gnome-gnobots2.png
+share/gnome/pixmaps/gnome-games-common/icons/rteleport.png
+share/gnome/pixmaps/gnome-games-common/icons/teleport.png
+share/gnome/pixmaps/gnome-gnobots2.svg
share/gnome/pixmaps/gnome-gnomine.png
share/gnome/pixmaps/gnome-gnotravex.png
share/gnome/pixmaps/gnome-gsame.png
@@ -513,25 +507,6 @@ share/gnome/pixmaps/gnome-gtali.png
share/gnome/pixmaps/gnome-gtetris.png
share/gnome/pixmaps/gnome-mahjongg.png
share/gnome/pixmaps/gnome-nibbles.png
-share/gnome/pixmaps/gnome-stones-file.png
-share/gnome/pixmaps/gnome-stones.png
-share/gnome/pixmaps/gnome-stones/amoeba.png
-share/gnome/pixmaps/gnome-stones/animated_curtain.png
-share/gnome/pixmaps/gnome-stones/background.png
-share/gnome/pixmaps/gnome-stones/boulder.png
-share/gnome/pixmaps/gnome-stones/butterfly.png
-share/gnome/pixmaps/gnome-stones/crate.png
-share/gnome/pixmaps/gnome-stones/curtain.png
-share/gnome/pixmaps/gnome-stones/diamond.png
-share/gnome/pixmaps/gnome-stones/dirt.png
-share/gnome/pixmaps/gnome-stones/door.png
-share/gnome/pixmaps/gnome-stones/empty.png
-share/gnome/pixmaps/gnome-stones/explosion.png
-share/gnome/pixmaps/gnome-stones/firefly.png
-share/gnome/pixmaps/gnome-stones/frame.png
-share/gnome/pixmaps/gnome-stones/gnome.png
-share/gnome/pixmaps/gnome-stones/title-tile.png
-share/gnome/pixmaps/gnome-stones/wall.png
share/gnome/pixmaps/gnometris/7blocks-gw.png
share/gnome/pixmaps/gnometris/7blocks-tig.png
share/gnome/pixmaps/gnomine/bang.svg
@@ -557,14 +532,15 @@ share/gnome/pixmaps/iagno/classic.png
share/gnome/pixmaps/iagno/woodtrim.png
share/gnome/pixmaps/mahjongg/postmodern.svg
share/gnome/pixmaps/mahjongg/smooth.png
-share/gnome/pixmaps/rteleport.png
-share/gnome/pixmaps/teleport.png
share/gnome/sol-games/agnes.scm
+share/gnome/sol-games/aunt_mary.scm
+share/gnome/sol-games/athena.scm
share/gnome/sol-games/auld_lang_syne.scm
share/gnome/sol-games/backbone.scm
share/gnome/sol-games/bakers_dozen.scm
share/gnome/sol-games/bakers_game.scm
share/gnome/sol-games/beleaguered_castle.scm
+share/gnome/sol-games/block_ten.scm
share/gnome/sol-games/bristol.scm
share/gnome/sol-games/camelot.scm
share/gnome/sol-games/canfield.scm
@@ -572,6 +548,7 @@ share/gnome/sol-games/carpet.scm
share/gnome/sol-games/chessboard.scm
share/gnome/sol-games/clock.scm
share/gnome/sol-games/cover.scm
+share/gnome/sol-games/cruel.scm
share/gnome/sol-games/diamond_mine.scm
share/gnome/sol-games/doublets.scm
share/gnome/sol-games/eagle_wing.scm
@@ -584,6 +561,7 @@ share/gnome/sol-games/fortress.scm
share/gnome/sol-games/fortunes.scm
share/gnome/sol-games/fourteen.scm
share/gnome/sol-games/freecell.scm
+share/gnome/sol-games/gaps.scm
share/gnome/sol-games/gay_gordons.scm
share/gnome/sol-games/glade/statistics.glade
share/gnome/sol-games/glenwood.scm
@@ -595,6 +573,7 @@ share/gnome/sol-games/isabel.scm
share/gnome/sol-games/jamestown.scm
share/gnome/sol-games/jumbo.scm
share/gnome/sol-games/kansas.scm
+share/gnome/sol-games/kings_audience.scm
share/gnome/sol-games/king_albert.scm
share/gnome/sol-games/klondike.scm
share/gnome/sol-games/labyrinth.scm
@@ -610,6 +589,7 @@ share/gnome/sol-games/plait.scm
share/gnome/sol-games/poker.scm
share/gnome/sol-games/quatorze.scm
share/gnome/sol-games/royal_east.scm
+share/gnome/sol-games/saratoga.scm
share/gnome/sol-games/scorpion.scm
share/gnome/sol-games/scuffle.scm
share/gnome/sol-games/seahaven.scm
@@ -671,6 +651,7 @@ share/locale/cs/LC_MESSAGES/gnome-games.mo
share/locale/cy/LC_MESSAGES/gnome-games.mo
share/locale/da/LC_MESSAGES/gnome-games.mo
share/locale/de/LC_MESSAGES/gnome-games.mo
+share/locale/dz/LC_MESSAGES/gnome-games.mo
share/locale/el/LC_MESSAGES/gnome-games.mo
share/locale/en_CA/LC_MESSAGES/gnome-games.mo
share/locale/en_GB/LC_MESSAGES/gnome-games.mo
@@ -691,7 +672,9 @@ share/locale/id/LC_MESSAGES/gnome-games.mo
share/locale/is/LC_MESSAGES/gnome-games.mo
share/locale/it/LC_MESSAGES/gnome-games.mo
share/locale/ja/LC_MESSAGES/gnome-games.mo
+share/locale/ka/LC_MESSAGES/gnome-games.mo
share/locale/ko/LC_MESSAGES/gnome-games.mo
+share/locale/ku/LC_MESSAGES/gnome-games.mo
share/locale/lt/LC_MESSAGES/gnome-games.mo
share/locale/lv/LC_MESSAGES/gnome-games.mo
share/locale/mk/LC_MESSAGES/gnome-games.mo
@@ -717,6 +700,7 @@ share/locale/sr/LC_MESSAGES/gnome-games.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-games.mo
share/locale/sv/LC_MESSAGES/gnome-games.mo
share/locale/ta/LC_MESSAGES/gnome-games.mo
+share/locale/th/LC_MESSAGES/gnome-games.mo
share/locale/tr/LC_MESSAGES/gnome-games.mo
share/locale/uk/LC_MESSAGES/gnome-games.mo
share/locale/vi/LC_MESSAGES/gnome-games.mo
@@ -724,6 +708,12 @@ share/locale/wa/LC_MESSAGES/gnome-games.mo
share/locale/xh/LC_MESSAGES/gnome-games.mo
share/locale/zh_CN/LC_MESSAGES/gnome-games.mo
share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/sounds/iagno
@dirrm share/gnome/sounds/gnometris
@dirrm share/gnome/sounds/gnobots2
@@ -735,7 +725,7 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/pixmaps/gtali
@dirrm share/gnome/pixmaps/gnomine
@dirrm share/gnome/pixmaps/gnometris
-@dirrm share/gnome/pixmaps/gnome-stones
+@dirrm share/gnome/pixmaps/gnome-games-common/icons
@dirrm share/gnome/pixmaps/gnome-games-common/cards
@dirrm share/gnome/pixmaps/gnome-games-common
@dirrm share/gnome/pixmaps/gnobots2
@@ -770,9 +760,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/help/gnomine
@dirrm share/gnome/help/gnometris/C
@dirrm share/gnome/help/gnometris
-@dirrm share/gnome/help/gnome-stones/C/figures
-@dirrm share/gnome/help/gnome-stones/C
-@dirrm share/gnome/help/gnome-stones
@dirrm share/gnome/help/gnobots2/it
@dirrm share/gnome/help/gnobots2/es
@dirrm share/gnome/help/gnobots2/da
@@ -799,17 +786,18 @@ share/locale/zh_TW/LC_MESSAGES/gnome-games.mo
@dirrm share/gnome/help/aisleriot/C/figures
@dirrm share/gnome/help/aisleriot/C
@dirrm share/gnome/help/aisleriot
-@dirrm share/gnome/gnome-stones
@dirrm share/gnome/gnome-games/same-gnome/themes/2.10
@dirrm share/gnome/gnome-games/same-gnome/themes
@dirrm share/gnome/gnome-games/same-gnome
@dirrm share/gnome/gnome-games/mahjongg/maps
@dirrm share/gnome/gnome-games/mahjongg
+@dirrm share/gnome/gnome-games/ataxx/themes/2.14
+@dirrm share/gnome/gnome-games/ataxx/themes
+@dirrm share/gnome/gnome-games/ataxx
@dirrm share/gnome/gnome-games
@dirrm share/gnome/gnobots2
@dirrm share/gnome/gnibbles
@dirrm share/gnome/gnect
@dirrm share/gnome/blackjack
-@dirrm lib/gnome-stones/objects
-@dirrm lib/gnome-stones
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true