aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-nibbles/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /games/gnome-nibbles/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'games/gnome-nibbles/Makefile')
-rw-r--r--games/gnome-nibbles/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/gnome-nibbles/Makefile b/games/gnome-nibbles/Makefile
new file mode 100644
index 000000000000..c5bd39d73658
--- /dev/null
+++ b/games/gnome-nibbles/Makefile
@@ -0,0 +1,30 @@
+# Created by: FreeBSD GNOME Team <gnome@freebsd.org>
+# $FreeBSD$
+# $MCom: ports/trunk/games/gnome-nibbles/Makefile 19989 2014-10-18 09:53:56Z gusi $
+
+PORTNAME= gnome-nibbles
+PORTVERSION= 3.14.1
+CATEGORIES= games gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Gnome nibbles
+
+BUILD_DEPENDS= vala:${PORTSDIR}/lang/vala \
+ itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
+ libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3
+
+USES= gettext gmake pathfix pkgconfig tar:xz
+USE_GNOME= gtk30 intlhack librsvg2 libxml2:build
+INSTALLS_ICONS= yes
+USE_GL= gl
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.gnome.nibbles.gschema.xml
+
+.include <bsd.port.mk>