aboutsummaryrefslogtreecommitdiff
path: root/games/gnomebreakout
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-23 19:07:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-23 19:07:35 +0000
commit0be207c7414d62e6d182bce5a1fea19371466c85 (patch)
tree82c9412e54eebe1501c3117b2fa8f4063451aeec /games/gnomebreakout
parent593f9dff959427714e8d42aa45487c6b600e40be (diff)
downloadports-0be207c7414d62e6d182bce5a1fea19371466c85.tar.gz
ports-0be207c7414d62e6d182bce5a1fea19371466c85.zip
Notes
Diffstat (limited to 'games/gnomebreakout')
-rw-r--r--games/gnomebreakout/Makefile15
-rw-r--r--games/gnomebreakout/distinfo4
-rw-r--r--games/gnomebreakout/files/patch-aa14
-rw-r--r--games/gnomebreakout/files/patch-src::anim.c18
-rw-r--r--games/gnomebreakout/pkg-descr2
-rw-r--r--games/gnomebreakout/pkg-plist1
6 files changed, 33 insertions, 21 deletions
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index b872ba552898..eafa8885543a 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -6,19 +6,26 @@
#
PORTNAME= gnomebreakout
-PORTVERSION= 0.5.2
-PORTREVISION= 1
+PORTVERSION= 0.5.3
CATEGORIES= games gnome
-MASTER_SITES= http://users.senet.com.au/~alcaron/
+MASTER_SITES= http://www.users.on.net/mipearson/
DISTNAME= gnome-breakout-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME version of the classic breakout game
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_GNOME= gnomehack gnomeprefix libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|games.games|root:games|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-Werror||g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|@GETTEXT_PACKAGE@|@PACKAGE@|g' ${WRKSRC}/po/Makefile.in.in
+
.include <bsd.port.mk>
diff --git a/games/gnomebreakout/distinfo b/games/gnomebreakout/distinfo
index 2ed5508d785e..5f8af51fbc41 100644
--- a/games/gnomebreakout/distinfo
+++ b/games/gnomebreakout/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome-breakout-0.5.2.tar.gz) = 3464e74aae8dce37da5336ed10ea6452
-SIZE (gnome-breakout-0.5.2.tar.gz) = 223835
+MD5 (gnome-breakout-0.5.3.tar.gz) = 38da8b1d1594e7ed6e94bd334d7c7d25
+SIZE (gnome-breakout-0.5.3.tar.gz) = 197538
diff --git a/games/gnomebreakout/files/patch-aa b/games/gnomebreakout/files/patch-aa
deleted file mode 100644
index d1de0efb9613..000000000000
--- a/games/gnomebreakout/files/patch-aa
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Thu Feb 8 12:20:37 2001
-+++ Makefile.in Thu Feb 8 12:21:38 2001
-@@ -446,7 +446,7 @@
- install-data-local:
- -$(mkinstalldirs) $(DESTDIR)$(scoredir)
- -touch $(DESTDIR)$(scoredir)/gnome-breakout.scores
-- -chown games.games $(DESTDIR)$(scoredir)/gnome-breakout.scores
-+ -chown root:games $(DESTDIR)$(scoredir)/gnome-breakout.scores
- -chmod 0664 $(DESTDIR)$(scoredir)/gnome-breakout.scores
- -chgrp games $(DESTDIR)$(bindir)/gnome-breakout && chmod 2755 $(DESTDIR)$(bindir)/gnome-breakout
-
diff --git a/games/gnomebreakout/files/patch-src::anim.c b/games/gnomebreakout/files/patch-src::anim.c
new file mode 100644
index 000000000000..95f0e9fc4874
--- /dev/null
+++ b/games/gnomebreakout/files/patch-src::anim.c
@@ -0,0 +1,18 @@
+--- src/anim.c.orig Mon May 10 19:42:51 2004
++++ src/anim.c Thu May 20 00:26:00 2004
+@@ -47,6 +47,7 @@
+ Animation newanim;
+ char *fullfilename;
+ int i;
++ GError *gerror = NULL;
+
+ /* Find the number of frames */
+ fullfilename = g_strdup_printf("%s.%d.png", filename, 0);
+@@ -64,7 +65,6 @@
+ sizeof(GdkPixbuf *));
+ for(i = 0; i < newanim.num_frames; i++) {
+ fullfilename = g_strdup_printf("%s.%d.png", filename, i);
+- GError *gerror = NULL;
+ newanim.pixmaps[i] = gdk_pixbuf_new_from_file(fullfilename,
+ &gerror);
+ if(!newanim.pixmaps[i]) {
diff --git a/games/gnomebreakout/pkg-descr b/games/gnomebreakout/pkg-descr
index 8682b7c68611..8d4d32c6619b 100644
--- a/games/gnomebreakout/pkg-descr
+++ b/games/gnomebreakout/pkg-descr
@@ -2,4 +2,4 @@ GNOME Breakout is a clone of the classic arcade game Breakout,
written for GNOME. Still in development, but very playable, and
very addictive.
-WWW: http://users.senet.com.au/~alcaron/software.html
+WWW: http://www.users.on.net/mipearson/
diff --git a/games/gnomebreakout/pkg-plist b/games/gnomebreakout/pkg-plist
index 1290ab9a4f80..d65943985f0c 100644
--- a/games/gnomebreakout/pkg-plist
+++ b/games/gnomebreakout/pkg-plist
@@ -69,6 +69,7 @@ share/gnome/gnome-breakout/pixmaps/title.png
share/gnome/pixmaps/gnome-breakout.png
share/locale/de/LC_MESSAGES/gnome-breakout.mo
share/locale/ru/LC_MESSAGES/gnome-breakout.mo
+share/locale/sv/LC_MESSAGES/gnome-breakout.mo
share/locale/tr/LC_MESSAGES/gnome-breakout.mo
@dirrm share/gnome/gnome-breakout/pixmaps
@dirrm share/gnome/gnome-breakout/levels